Array
(
)

aplicativo some após algum tempo

Pjava
   - 25 abr 2013

Fiz um aplicativo que mostra uns gráficos num telão. Bem, usei o timer da palheta Ajax Extensions e configurei que a cada 30s, chamasse outro gráfico e nessa tela eu fiz o mesmo e assim sucessivamente. Tenho um problema de performance que depois de muitos testes, chegamos a conclusão que não é meu sistema e nem o servidor onde se hospeda o site(Na empresa prestadora). Bom, vamos ao X da questão. Quando a aplicação sobe, faço o login e chamo o primeiro gráfico. Funciona bem até que em determinado momento, ele deixa a tela em branco, o cursor rodando,rodando e nada de aparecer. Aí vou na máquina, e dou Ctrl+F5 e tudo volta ao normal. Percebi que quanto maior é o tempo de swap entre os gráficos, mas frequente aparece esse problema. Baixei o tempo para 10s entre as chamadas, e em um espaço de mais ou menos 1:30h, não percebi o problema. Aumento para 30s, o problema aparece em mais ou menos em 20 ou 30 min. Se aumento para 5min, aí ele chama apenas uma vez e já dá esse erro. Alguém já passou por isso?

Pjava
   - 26 abr 2013

Bem, baixei o tempo. Continua dando esporadicamente esse problema, mas se deixar, no tempo do timer ele volta a exibir a gráfico. Só queria entender se isso é da máquina ou não. Então testei em minha máquina, deixei bastante tempo e na minha máquina não deu o problema. Pode ser devido ao problema de performance que estamos tendo, conforme eu postei em outra Thread. Pode encerrar o post, que é "pau" de performance, Hardware, rede ou qualquer coisa do tipo.

Popdem Fechar.

0
|
0

José
   - 12 set 2013

Tópico concluído

0
|
0