Array
(
)

Atributo não reconhecido 'targetFramework'.

Fredh
   - 13 set 2011

Estou desenvolvendo um site no vs2010 com framework 4.0 e windows 7.Já copiei o site para o diretório onde o IIS vai enxergar, porem quando quando exibir dá o seguinte erro:

Erro de configuração

Descrição: Erro durante o processamento de um arquivo de configuração necessário para o serviço desta solicitação. Examine os detalhes específicos do erro e modifique esse arquivo de configuração apropriadamente. 

Mensagem de Erro do Analisador: Atributo não reconhecido 'targetFramework'. Observe que os nomes de atributos diferenciam maiúsculas e minúsculas.

Erro de Origem: 

Linha 9:  </connectionStrings>
Linha 10: <system.web>
Linha 11:    <compilation debug="true" targetFramework="4.0">
Linha 12: <assemblies>
Linha 13: <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />

Arquivo de Origem: C:\inetpub\wwwroot\web.config    Linha: 11 

Informações sobre a Versão: Microsoft .NET Framework Versão:2.0.50727.5446; Versão do ASP.NET:2.0.50727.5420

Alguém pode me ajudar?Grato

Luciano Leandro
   - 24 set 2011

Bom dia
esse erro ocorre pois provavelmente a versão do IIS que você está usando não suporta a versão 4.0 do .Net Framework pois esse atributo não existe em versões anteriores a 4.0.
Caso precise esteja a vontade pra me mandar um email ou posta aqui na comunidade .
Estarei a disposição

Abraços

___________________________________________

Luciano - PontonetHost
www.pontonethost.com.br
www.blog.pontonethost.com.br
Email: design@pontonethost.com.br