Array
(
)

Componente RX para aplicações CLX

Guilhermebsb
   - 16 dez 2004

Bom dia!
Gostaria de saber se alguém conhece componentes RX para aplicações Delphi CLX,

OU

Que conheça algum ´COMBOBOX´ igual ao do RX (VLC) que ao ir escrevendo na combo ele acha o registro, diferente do DBComboBox do próprio DELPHI que só da para colocar a primeira letra.

Atenciosamente, Guilherme.


Dopi
   - 16 dez 2004

A algum tempo atras achei no CodeCentral uma traduçao de alguns componentes da Jedi para a CLX...

Parece que o projeto nunca foi concluido... e alguns componentes importantes (como todos os DBAware) não existem...

Tb tive alguma dor de cabeça para conseguir instalar o pacote... Achei alguns erros de Miusculas/Minuscula, e outros que não me lembro mais... Acabei desistindo de usa-lo... mas se quiser tentar...

http://cc.borland.com/ccweb.exe/author?authorid=171869


Mordred
   - 30 ago 2005

Bom, pelo visto essa biblioteca é mesmo osso duro de roer... tb não consegui instalar ela aqui... mas que droga...


Dopi
   - 30 ago 2005

Ola Mordred,

Quando recebi a resposta desse tópico fiquei curioso e tentei instalar a biblioteca novamente...

E com algumas modificações no código original consegui... Veja o resultado dela no Linux
[img:f7ad920a62]http://www.djsystem.com.br/fotos/div/snapshot1.png[/img:f7ad920a62]

Se quiser, envio um ZIP com os Packages para CLX em D7 e K3...

Necessita da JCL 3.0, mesmo no K3

A JVCL NAO pode estar instalada..

A biblioteca JediCLX parece ser baseada na Jedi 2.10... e vários componentes não foram migrados.

Baixei os fontes dela em:
http://sourceforge.net/project/showfiles.php?group_id=102965


Editando o tópico.
Dopi, a imagem ficou muito grande para o quadro do fórum, fazendo com que dificulte a leitura do texto do tópico. Se puder redimensionar, por favor... os leitores agradecem. Conto com sua compreensão e colaboração.

Sandra/Moderação


Dopi
   - 30 ago 2005

Veja o Programa rodando:

[img:39a0e71d55]http://www.djsystem.com.br/fotos/div/snapshot2.png[/img:39a0e71d55]

Eu apenas inseri um monte de componentes e testei... Aparentemente funcionou bem no Linux e no Windows


Mordred
   - 31 ago 2005

Cara, que legal! Mas o que foi que você mexeu no código antes de instalar? Seria bom saber, assim evitava de eu ficar perguntando as coisas toda hora por aqui no fórum :P
Além disso já vi vários tópicos com problemas na hora de instalar componentes... quem sabe a tua resposta não ajuda a comunidade de uma forma geral? :D
A propósito, já te mandei uma MP com meu endereço de e-mail! MUITO OBRIGADO!


Dopi
   - 31 ago 2005


Citação:

Editando o tópico.
Dopi, a imagem ficou muito grande para o quadro do fórum, fazendo com que dificulte a leitura do texto do tópico. Se puder redimensionar, por favor... os leitores agradecem. Conto com sua compreensão e colaboração.

Sandra/Moderação


Perdão Sandra... nem havia percebido... já redimensionei para 640x480, se for necessário posso diminuir mais...

@Mordred
Já enviei para o seu e-mail... Por favor leia o INSTALAR.TXT que está dentro do ZIP



Editando!

Citação:
Perdão Sandra... nem havia percebido... já redimensionei para 640x480, se for necessário posso diminuir mais...

Tranquilo, Daniel. Ficou jóia. :wink:
Sandra