Array
(
    [0] => stdClass Object
        (
            [Votos_Balanceados] => 1
            [id] => 493899
            [titulo] => Dúvida Caracteres PHP
            [dataCadastro] => DateTime Object
                (
                    [date] => 2014-09-29 09:02:44
                    [timezone_type] => 3
                    [timezone] => America/Sao_Paulo
                )

            [isFirstPost] => -1
            [idUsuario] => 262490
            [status] => A
            [isExample] => 
            [NomeUsuario] => Marisiana Battistella
            [Apelido] => Marisiana
            [Foto] => 262490_20141229171421.jpg
            [Conteudo] => Você está usando UTF-8 ?
        )

)

Dúvida Caracteres PHP

Fernando André
   - 29 set 2014

Olá pessoal, tenho um sistema de site administrável onde pelo painel de controle é possível alterar o título do site, porém quando o usuário coloca um titulo com acento, no facebook essas letras somem, veja na imagem abaixo:
http://prntscr.com/4rcdtr
Vejam que onde existe o acento ( Rádio e Universitário) os dois acentos A a letra some, como posso resolver isso?
Obrigado.

Post mais votado

Marisiana
   - 29 set 2014

Você está usando UTF-8 ?

1
|
0

Ronaldo Lanhellas
   - 29 set 2014


Citação:
Olá pessoal, tenho um sistema de site administrável onde pelo painel de controle é possível alterar o título do site, porém quando o usuário coloca um titulo com acento, no facebook essas letras somem, veja na imagem abaixo:

http://prntscr.com/4rcdtr

Vejam que onde existe o acento ( Rádio e Universitário) os dois acentos A a letra some, como posso resolver isso?

Obrigado.


Primeiro tente verificar se está salvando com acento no seu banco de dados, caso não esteja, você pode verificar o tipo de codificação do banco que provavelmente não está permitindo acentos.

1
|
0

Fernando André
   - 29 set 2014

Tinha verificado e não tinha nenhum charset no código, então coloquei charset=iso-8859-1 para verificar, mais acho que demora alguns dias até a atualização funcionar no facebook.

0
|
0

Fernando André
   - 30 set 2014

Para finalizar o post, a solução era a mais simples possível, apenas coloquei a linha

#Código

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />


E deu certo, obrigado pela ajuda

0
|
0

Marisiana
   - 30 set 2014

Bacana isso!
Trabalhei pouco tempo com PHP e HTML, e não tinha entendido a importância dessa linha na pagina HTML.

0
|
0