Array
(
)

Erro ao instalar sistema sem VS2008

Facc
   - 14 abr 2010

Bom dia,

Estou recebendo esse erro no momento que vou instalar o sistema em um terminal em que não possui o VS2k8
Segue o arquivo

#Código

INFORMAES SOBRE VERSES DE PLATAFORMAS
Windows : 5.1.2600.196608 (Win32NT)
Common Language Runtime : 2.0.50727.1433
System.Deployment.dll : 2.0.50727.1433 (REDBITS.050727-1400)
mscorwks.dll : 2.0.50727.1433 (REDBITS.050727-1400)
dfdll.dll : 2.0.50727.1433 (REDBITS.050727-1400)
dfshim.dll : 2.0.50727.1433 (REDBITS.050727-1400)

ORIGENS
URL da Implantao : file://126.0.0.172/pagina_aspx/Informativo/Central/InformaCentralDesk.application
URL do Provedor de Implantao : file://126.0.0.172/Pagina_ASPX/Informativo/Central/InformaCentralDesk.application
URL do Aplicativo : file://126.0.0.172/pagina_aspx/Informativo/Central/Application%20Files/InformaCentralDesk_1_0_0_47/InformaCentralDesk.exe.manifest

IDENTIDADES
Identidade da Implantao : InformaCentralDesk.application, Version=1.0.0.47, Culture=neutral, PublicKeyToken=1273d35f35d3472c, processorArchitecture=msil
Identidade do Aplicativo : InformaCentralDesk.exe, Version=1.0.0.47, Culture=neutral, PublicKeyToken=1273d35f35d3472c, processorArchitecture=msil, type=win32

RESUMO DO APLICATIVO
* Aplicativo instalvel.

RESUMO DOS ERROS
Um resumo dos erros pode ser encontrado a seguir. Os detalhes desses erros so relacionados posteriormente no log.
* Exceo na ativao de \\126.0.0.172\pagina_aspx\Informativo\Central\InformaCentralDesk.application. As seguintes mensagens de erro foram detectadas:
+ Assinatura de nome forte invlida para este conjunto de mdulos (assembly) stdole.dll.

RESUMO DA FALHA DA TRANSAO DE ARMAZENAMENTO DO COMPONENTE
Nenhum erro de transao foi detectado.

AVISOS
No houve avisos durante esta operao.

STATUS DO ANDAMENTO DA OPERAO
* [14/4/2010 11:02:19] : A ativao de \\126.0.0.172\pagina_aspx\Informativo\Central\InformaCentralDesk.application foi iniciada.
* [14/4/2010 11:02:22] : O processamento do manifesto da implantao foi concludo com xito.
* [14/4/2010 11:02:22] : A instalao do aplicativo foi iniciada.
* [14/4/2010 11:02:22] : O processamento do manifesto do aplicativo foi concludo com xito.
* [14/4/2010 11:02:28] : A solicitao de confiana e de deteco da plataforma foi concluda.

DETALHES DOS ERROS
Os erros a seguir foram detectados durante esta operao.
* [14/4/2010 11:02:30] System.Deployment.Application.InvalidDeploymentException (SignatureValidation)
- Assinatura de nome forte invlida para este conjunto de mdulos (assembly) stdole.dll.
- Origem: System.Deployment
- Rastreamento de pilha:
em System.Deployment.Application.ComponentVerifier.VerifyStrongNameAssembly(String filePath, AssemblyManifest assemblyManifest)
em System.Deployment.Application.ComponentVerifier.StrongNameAssemblyComponent.Verify()
em System.Deployment.Application.ComponentVerifier.VerifyComponents()
em System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
em System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
em System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
em System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension)
em System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

DETALHES DA TRANSAO DE ARMAZENAMENTO DO COMPONENTE
Nenhuma informao de transao est disponvel.

Netasper
   - 14 abr 2010

Ta faltando o Framework não?

0
|
0

Facc
   - 14 abr 2010

Pensei que fosse isso, mas está instalado, pois no mesmo terminal já está rodando alguns sistemas que utilizam

Imagem da maquina onde quero instalar

0
|
0

Facc
   - 15 abr 2010

Problema resolvido!

Fiz o seguinte... Parei de tentar resolver o problema e fui embora, no dia seguinte (hoje) voltei a quebrar a cabeça, e fiz algumas alterações, tirei o mshtml.dll do require e o stdole.dll deixei como PreRequisito no publish (botão application files)

Assim consegui resolver.

Como dizem por aí, "Se um problema é persistente, pare tudo e vá embora, ele se arruma"

Obrigado!

0
|
0