Array
(
)

Erro Build » Publish Web Site

Rodrigo Campos
   - 28 fev 2011

Bom dia amigos,

estou com problema ao gerar o site para publicar,

o projeto está prontinho e rodando eu apenas dei continuidade em um projeto que já havia começado, por isso estou perdido nao entendo muito de asp.net

o erro é o seguinte,

Error    1    The CodeDom provider type "Microsoft.VJSharp.VJSharpCodeProvider, VJSharpCodeProvider, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" could not be located. 

o que será que pode ser?!

agradeço desde já!

obg

Samuel Diogo
   - 28 fev 2011

Vc já tem o .NetFramework 4 instalado do seu pc? se não instale e me diga se resolveu seu problema...
sds,sam

Rodrigo Campos
   - 01 mar 2011

tenho sim!

Rodrigo Campos
   - 01 mar 2011

pior que estou precisando publicar esse projeto Urgente e já esta me dando dor de cabeça isso a dias,,

já pesquisei em tanto lugar e nada!

Samuel Diogo
   - 01 mar 2011

brou eu tenho andado pesquisando sobre seu problema, e ele se resume ao .netframework 4, alguns falam que é pq o .net não foi instalado corretamente, mas a solução mais "pratica" que eu encontrei foi colocar essas dll's que o debuger precisa na basta bin do seu projeto...
Bom, agora eu sugiro que você tente esta solução, estarei procurando mais informações e provalmente hoje a noite posto mais informações..
Tente também usar este comando pelo cmd do Visual Studio:
aspnet_merge.exe
http://msdn.microsoft.com/pt-br/library/bb397866(v=vs.90).aspx

sds,sam

Rodrigo Campos
   - 01 mar 2011

entao Samuel, fiz esses processos, infelizmente nada!

ps: olha oque tenho no compilation

<compilation debug

Samuel Diogo
   - 01 mar 2011

Olá nobre Rodrigo,

Antes de mais nada, esse erro está querendo dizer que o debuger não está encontrando referências do VJSharp, bom VJ Sharp para quem não conhece é uma linguagem derivada do J++, que após diversos conflitos judiciais ficou "abandonada" pela Micro$oft, e nos meados de 2007 a Microsoft retirou dos Visual Studio a IDE J#...   No seu caso, o você deve ter algum arquivo no seu projeto com extenção .jsl (Jay Sharp Language).   Bom, solução tem duas recomendas:   Se o arquivo .jsl for muito importante para seu projeto instále no seu pc o : Microsoft Visual J# .NET Version 1.1 Redistributable Package   Provavelmente, na hora de instalar ele vai pedir também o .netframework 1.1!   A segunda solução, seria você converter (ou re-escrever) esse código em uma outra linguagem, já que trata-se de uma linguagem parada no tempo, muitos servidores atuais não suportam mais esse tipo código, as linguagens que seria mais interessante e facil para você e sua equipe seria java (a sintaxe JSharp é indêntica ao java) ou C# que na minha opnião é uma das melhores linguagens de todos os tempos! rsrsrs   Para ter o mesmo erro que vc teve, eu criei um site qualquer e dei um builde (resultado: OK!) e dps, com o notpad criei uma aquivo em branco e salvei  como helpRodrigo.jsl, e cliquei Build Web Site... advinha?   Error 1 The CodeDom provider type "Microsoft.VJSharp.VJSharpCodeProvider, VJSharpCodeProvider, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" could not be located.    rsrsrsrs   Creio que finalmente consegui te ajudar! Havendo dúvidas conte comigo!   sds, Sam    

Rodrigo Campos
   - 02 mar 2011

Samuel deu certo velho

instalei http://www.microsoft.com/downloads/en/details.aspx?familyid=e3cf70a9-84ca-4fea-9e7d-7d674d2c7ca1&displaylang=en

e deu certo!

cara valeu pela atenção Mesmo,,,

quebrou um galhão, e o topico tá aqui para futuros problemas,

muito obrigado mesmo! (y)





Rodrigo Campos
   - 03 mar 2011

Sem querer Abusar,,

como já disse nunca tinha trabalhado com asp.net

consegui já compilar o site mas agora ao jogar no FTP e visualizar o site no browser

me da o seguinte erro,,

<authentication mode="Windows" />

oque será que pode ser?

olha oque tenho no meu config

<?xml version="1.0"?>
<configuration>
<appSettings/>
<system.web>
<customErrors mode="Off"/>
<compilation debug="false" strict="false" explicit="true" targetFramework="4.0">
<assemblies>
<add assembly="System.Data.OracleClient, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>
<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
<namespaces>
<clear/>
<add namespace="System"/>
<add namespace="System.Collections"/>
<add namespace="System.Collections.Generic"/>
<add namespace="System.Collections.Specialized"/>
<add namespace="System.Configuration"/>
<add namespace="System.Text"/>
<add namespace="System.Text.RegularExpressions"/>
<add namespace="System.Linq"/>
<add namespace="System.Xml.Linq"/>
<add namespace="System.Web"/>
<add namespace="System.Web.Caching"/>
<add namespace="System.Web.SessionState"/>
<add namespace="System.Web.Security"/>
<add namespace="System.Web.Profile"/>
<add namespace="System.Web.UI"/>
<add namespace="System.Web.UI.WebControls"/>
<add namespace="System.Web.UI.WebControls.WebParts"/>
<add namespace="System.Web.UI.HtmlControls"/>
</namespaces>
</pages>
<authentication mode="Windows" />
</system.web>
</configuration>

Samuel Diogo
   - 03 mar 2011

Olá Rodrigo,
neste caso mude seu authrentication mode para "form", siga as dicas do mestre Macorrati no link abaixo:
http://www.macoratti.net/colab2.htm
segue abaixo um link de referência sobre o authentication mode:
http://msdn.microsoft.com/pt-br/library/532aee0e.aspx
sds,Sam





Rodrigo Campos
   - 11 mar 2011

ja tentei todos os modos e nao consegui ainda,

será que preciso mudar alguma coisa no FTP?

Jorob
   - 11 mar 2011

Tente setar o Authentication para None para ver se o aplicativo roda...   Abraço 

Samuel Diogo
   - 11 mar 2011

Olá Rodrigo, qual é o servidor?

Rodrigo Campos
   - 18 mar 2011

eu estou usando a hospedagem da UOL, será que serve?

Rodrigo Campos
   - 31 mai 2011

Por favor, vou subir o topico,

infelizmente até hoje nao consegui publicar o site owh ele aí,, da esse erro

http://www.cbninformatica.com.br/viacao

algum por favor sabe oque pode ser???

estou tao desesperado com isso, que estava disposto a passar o projeto para alguem tentar ver pra mim! tá dificil...

a hospedagem é UOL!

Obrigado quem puder me ajudar!

abç


Rodrigo Campos
   - 01 jun 2011

corrigindo o site está aqui

http://www.cbninfo.com.br/viacao/

Samuel Diogo
   - 23 jun 2011

olá Rodrigo, desculpe por demorar respondê-lo, até então achei que esti já havia sido resolvido.... rsrs
o erro da página abaixo:
http://www.cbninfo.com.br/viacao
parte mais importante desta message de erro:
This error can be caused by a virtual directory not being configured as an
application in IIS.
O erro descrito acima diz que você não configurou seu site no IIS.
para configurar, segue abaixo o tutorial da uol ensinando como fazer isto:
http://ajuda.uolhost.com.br/index.php?ind=&p=resposta&res=581
e quando quando estiver ainda só testando em seu pc, configure isto também na sua maquina:
no Win7 Clique em Iniciar, clique com o lado diretio em  Computador e selecione "Gerenciar" ou "Manage"
Na tela do Gerenciador do Computador clique em Aplicações e Serviços, clique em Internet Information Services (IIS)  e proceda com as configurações:


Outro detalhe, se o modo de autenticação é via form, verifique se form está devidamente configurado:
exemplo:<authentication mode="Forms"> <forms cookieless="AutoDetect" loginUrl="~/Login.aspx" name="FORMAUTH"/> </authentication>

A pagina pode acessar pessoas anonimas? ou seja sem logar? verique se você instanciou isto claramente:exemplo:
<anonymousIdentification enabled="true"/>

Mais um outro detalhe, o site cbninfo.com.br está funfando normalmente, exceto quando tento acessar esta pagina "aviacao", e eu não vejo nehuma ligação desta pagina com o seu site...

Rodrigo Campos
   - 24 jun 2011

bom dia Samuel

agradeço muito pela atenção!

fiz a criação da aplicacao IIS no servidor da UOL

agora joguei nesse dominio

www.cbninformatica.com.br/viacao

daí me retornou outro erro

<compilation debug="true" strict="false" explicit="true" targetFramework="4.0">

parece que é referente ao framework, vou ver se a hospedagem UOL suporte 4.0

agora no meu computador eu sou obrigado a configurar também, IIS? porque aqui roda normalzinho filé,

o site é aberto, a pessoa entra e só, sem login nem nada,,

aqui está o meu web.conf

*************

<?xml version="1.0"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
    <connectionStrings>
        <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient"/>
    </connectionStrings>
    <system.web>
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>
        <authentication mode="none" />
            <!-- <forms loginUrl="~/Account/Login.aspx" timeout="2880"/>
        </authentication> -->
        <membership>
            <providers>
                <clear/>
                <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/"/>
            </providers>
        </membership>
        <profile>
            <providers>
                <clear/>
                <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/"/>
            </providers>
        </profile>
        <roleManager enabled="false">
            <providers>
                <clear/>
                <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/"/>
                <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/"/>
            </providers>
        </roleManager>
    </system.web>
    <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
    </system.webServer>
</configuration>


*************


este dominio é apenas para o meu cliente testar o site, para depois eu jogar em outro servidor!

tá dificil, já tentei tanta coisa, estou até pensando em mudar a linguagem para de programação,

eu dei continuidade no projeto, por isso estou apanhando, eu nunca tinha feito nada em .net

espero que possa me ajudar, agradeço muito!

abç

Samuel Diogo
   - 24 jun 2011

Boa tarde Rogrigo,
A afirmação abaixo da UOL Host é bem ambigua, mas creio que o mesmo só dá suporte para .net 3.5

Na ativação das hospedagens, a versão do .NET Framework disponível é a 3.5. 

Esta versão suporta a seguinte lista de Frameworks

.NET Framework 2.0
.NET Framework 3.0
.NET Framework 3.5
.NET Framework 3.5 SP1
.NET Framework 4.0 (source: http://ajuda.uolhost.com.br/index.php?ind=44&p=resposta&res=256)

mas verique melhor quais são as opções no painel de controle sobre o dotnet instanciado no diretorio virtual do IIS
http://forum.imasters.com.br/topic/412757-net-framework-4/

e Quanto...:
agora no meu computador eu sou obrigado a configurar também, IIS? porque aqui roda normalzinho filé,

Se tah funfando então não mexe com isto nao!rsrsrs
Um detalhe que achei instranho, mas não sei se tem alguma coisa relacionada ao erros, no atual exception diz 
[...]<add assembly="System.Data.OracleClient,[...]sendo que no seu webconfig está dizendo:[...]add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;[...]
Bro qualquer coisa estou disponivel também via email do perfil.Sds,Samuel Diogo