Array
(
    [0] => stdClass Object
        (
            [Votos_Balanceados] => 1
            [id] => 516126
            [titulo] => Erro do Developer Toolbox no PHP 5.1
            [dataCadastro] => DateTime Object
                (
                    [date] => 2015-04-08 16:25:11
                    [timezone_type] => 3
                    [timezone] => America/Sao_Paulo
                )

            [isFirstPost] => -1
            [idUsuario] => 351539
            [status] => A
            [isExample] => 
            [NomeUsuario] => Fabio Veloso
            [Apelido] => 
            [Foto] => 
            [Conteudo] => Esse erro é devido a atualização do PHP eu tenho os arquivos que corrigem esse erro se quiser deixe seu email aqui eu envio.
        )

)

Erro do Developer Toolbox no PHP 5.1

Wb
   - 03 fev 2015

Boa noite pessoal, estou tendo problemas ao implementar um sistema de postagens que utiliza o Developer Toolbox do Dream Weaver, testei esse sistema em uma versão inferior do php/mysql (local) e funcionou redondinho, aí quando transferi este sistema para um servidor online (Locaweb) que usa o PHP/mysql 5.1 foram exibidas as seguintes mensagens:
#Código

Strict Standards: Declaration of tNG_multiple::getFieldError() should be compatible with tNG_fields::getFieldError($fName) in /home/wanderson/postagem/includes/tng/tNG_multiple.class.php on line 22

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 179

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 226

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 240

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 195

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 179

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 226

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 240

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 195

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 179

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 226

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 240

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG.class.php on line 195

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG_multiple.class.php on line 208

Strict Standards: Non-static method tNG_log::log() should not be called statically, assuming $this from incompatible context in /home/wanderson/postagem/includes/tng/tNG_multiple.class.php on line 176

...Já procurei, e até achei como resolver esse problema em outros fóruns e sites da web, só que essas soluções não funcionaram no meu caso, sempre continua dando o mesmo erro.
Desde já agradeço a ajuda de todos.

Post mais votado

Fabio Veloso
   - 08 abr 2015

Esse erro é devido a atualização do PHP eu tenho os arquivos que corrigem esse erro se quiser deixe seu email aqui eu envio.

Israel
   - 06 nov 2015

Olá Fabio Veloso, poderia enviar os arquivos de correção para meu e-mail. israel@macielfontoura.com
Obrigado!
meu php é versão 5.4.45