Array
(
)

Erro no ApplyUpdates

Marioribeiro
   - 11 ago 2004

Pessoal me ajudem por favor, fiz uma rotina de inclusão de registro, e estava td funcionando perfeitamente bem, ai resolvi excluir minha tabela e refaze-la, refiz as conexões e tudo ok. Até o Post funciona perfeito mas na hora do ApplyUpdates da o seguinte erro:
Project PCliFor.exe raised exceptiom class EDatabaseError with message ´Table unknown clifor
At line 1, column 8

Por favor me ajudem, ja tentei de tudo e contia esse erro


Vinicius2k
   - 11 ago 2004

Mario,

É dbExpress? se for ele é *CaseSensitive... se vc tiver criado a tabela no Banco de dados em maiúsculas, precisa utilizar maiusculas na instrução SQL do DataSet/Query, no seu caso ´CLIFOR´...
Se tiver usado aspas na criação da tabela vc também precisará, sempre, referenciar-se a elas usando as aspas...

* Nunca encontrei uma explicação sobre a razão que, as vezes funciona e as vezes não funciona... vc pode, por exemplo, passar o nome da tabela para maiúsculas e resolver o problema, e logo em seguida voltar para minúsculas e talvez continue a funcionar normalmente...

T+


Marioribeiro
   - 11 ago 2004

Valeu companheiro, é Dbexpress, e era este o erro realmente, não sei como pode acontecer, deve ser BUG pois qdo vc adiciona os componetes e os campos aos mesmos não da erro, deveria dar né. Mas....

mto obrigado


Vinicius2k
   - 11 ago 2004

Eu encaro isso como um BUG pq ainda não encontrei uma razão que explique o problema...
Pensei que fosse ser corrigido no update pack 1 do Delphi 7, mas não foi...

T+