Array
(
)

expressão quot;sumquot; está saindo com valor 0

Paulinux
   - 13 fev 2006

Pessoal estou com um problemão ,, eu migrei meu sistema do delphi 3.0 para o delphi 7.0 , porem alguns relatórios importantes estão saindo com os valores zerados ,, já tentei quase tudo e não consegui resolver esse problema ,, ja removi as expressões e coloquei outras ja refiz até o relatorio e ainda assim nao funciona ,, eu uso campos com variaveis e muitos desse campos não são fisicos no banco de dados.


Aroldo Zanela
   - 13 fev 2006

Colega,

Não me recordo de nenhuma mudança significativa com o QR. Conseguiu resolver o problema? Pode adicionar mais detalhes?


Paulinux
   - 14 fev 2006

Meu Amigo , eu acho que pode ser a versão do quickreport que eu estou usando,, v3.5 porque eu não encontrei nada de errado que pudesse fazer com que o relatório saisse com valor zerado , ainda mais depois que eu mudei o tipo da banda de: groupfooter para detail e tirei o link entre o group header e groupfooter,, desse forma o relatório me traz os valores mas esses valores vem um a um , ou seja se o cliente tem uma conta com 10 parcelas no relatório aparece as 10 parcelas ,, agora no delphi 3 esse mesmo relatório com o mesmo cliente me traz as 10 parcelas somadas e o valor total no final do relatorio .

cliente qtde valor

10002 10 R$ 1000.00 assim é no delphi 3


cliente qtde valor

10002 1 R$ 100.00
10002 1 R$ 100.00
10002 1 R$ 100.00
10002 1 R$ 100.00

assim sai no delphi 7 quando eu tiro o link do group header com o groupfooter e mudo o groupfooter para detail.
o relatório fica muito extenso e o layout fica horrivel