Array
(
)

Paradox - muito lento na rede

Janete
   - 02 dez 2005

Pessoal, sei q não é fácil falar de paradox, mas eu procurei tanto e não consigo achar mais nada q me ajude a melhorar o desempenho do meu sistema em rede, já fiz de tudo, são 6 computadores em rede com 4 win 2000, 1 Win98 e 1 XP, é bem estranho por q se abrir um pc somente na rede já fica lento, não entendo isso, e tá muito lento as últimas configurações q fiz no BDE foi a seguinte:

System | Init |
Definition 64 MG 32 MG 128 MG 256 MG 96 MG 80 MG

AUTO ODBC FALSE
DATA REPOSITORY
DEFAULT DRIVER PARADOX
LANGDRIVER ANSI
LOCAL SHARE TRUE TRUE TRUE TRUE TRUE TRUE
LO MEM USE LIMIT 32 32 32 32 32 32
MAXBUFSIZE 16384 8192 32768 65536 24576 20480
MAXFILESHANDLES 100 100 100 100 100 100
MEMSIZE 42 18 90 192 66 54
MINBUFSIZE 4096 4096 4096 4096 4096 4096
MTS POOLING FALSE
SHAREDMEMLOCATION
SHAREDMEMSIZE 14080 6016 30000 61056 22016 18048
SQLQRYMODE
SYSFLAGS 0
VERSION 4.0
CONFIGURATION TAB

Configuration | Drivers | Native | Paradox
BLOCK SIZE 16384
FILL FACTOR 95
LEVEL 7


*****
Enabled BCD = True
Strictintegrty = True

Apenas para micros / terminais com sistema operacional windows NT, XP ou 2000 em Sharedmenlocation = 0x7f000000 configure essa opção fornecendo endereço de memória alta para compartilhamento e gerenciamento de dados. essa configuração evitará problemas na atualização de índices secudários

Será q tem algum outro problema na rede mesmo? ou tem mais alguma coisa q eu possa fazer pra melhorar isso? agradeço muito qualquer ajuda.


Edilcimar
   - 02 dez 2005

Eu uso piradox em rede, deixo tudo como default do bde, só troco o shared e o net dir, e não tenho problema algum com velocidade, além da normal é claro, será que o problema não é placa de rede? Será que não é uma das configurações que vc mudou?


Janete
   - 02 dez 2005


Citação:
Eu uso piradox em rede, deixo tudo como default do bde, só troco o shared e o net dir, e não tenho problema algum com velocidade, além da normal é claro, será que o problema não é placa de rede? Será que não é uma das configurações que vc mudou?


até qdo pc vc tem em rede?


Edilcimar
   - 02 dez 2005

tenho 1 rede com 4 computadores, conectada através de cabo, e a mesma está conectada a outra rede via rádio com mais 3 computadores, o servidor fica na primeira rede e não é dedicado, está sendo usado como caixa


Janete
   - 02 dez 2005


Citação:
tenho 1 rede com 4 computadores, conectada através de cabo, e a mesma está conectada a outra rede via rádio com mais 3 computadores, o servidor fica na primeira rede e não é dedicado, está sendo usado como caixa


Vc usa IP fixo ou automático?


Janete
   - 02 dez 2005


Citação:

Citação:
tenho 1 rede com 4 computadores, conectada através de cabo, e a mesma está conectada a outra rede via rádio com mais 3 computadores, o servidor fica na primeira rede e não é dedicado, está sendo usado como caixa


Vc usa IP fixo ou automático?

Outra pergunta, vc usa hub normal ou barra 1000 e as placas de redes é 10/1000?


Edilcimar
   - 02 dez 2005

os 2 servidores de rede (conectados via radio) comunicam-se com ip fixo, o servidor do programa(1 dos caixas) contém o programa, todos os outros computadores comunicam-se com ele através de mapeamento de unidade com ip fixo


Janete
   - 02 dez 2005


Citação:
os 2 servidores de rede (conectados via radio) comunicam-se com ip fixo, o servidor do programa(1 dos caixas) contém o programa, todos os outros computadores comunicam-se com ele através de mapeamento de unidade com ip fixo


Como vc trabalha com seu sistema, vc constuma usar mas query ou table? E vc tem tabelas muito grandes? qual o tamanho?


Edilcimar
   - 03 dez 2005

trabalho com table, so uso umas poucas queryes, tenho diversas tabelas, algumas com mais de 10.000 registros, inclusive uma com mais de 50.000, o tamanho total das tabelas + índices está por volta de 45Gb


Edilcimar
   - 03 dez 2005

desculpe escrevi errado 45 Mb


Janete
   - 03 dez 2005


Citação:
desculpe escrevi errado 45 Mb


Nossa então não entendo por q o meu fica tão lento, outra pergunta... quando a LOCAL SHARE no BDE todas as máquinas ficam TRUE ou só o servidor vc coloca TRUE e as estações ficam FALSE como vc faz?


Edilcimar
   - 03 dez 2005

estão todas com true e o caminho(net dir) indicando o local onde está o bd