Array
(
)

Problema com a conversao de dados. Acho que e ^^

Ricardo Hippler
   - 06 mar 2011

Ola boa noite, estou com o seguinte problema. Tipo estou fazendo um cadastro de clientes, meu primeiro... dai tipo ta tudo belezinha dai quando mando rodar ele roda ok. clico em gravar cliente ele da o seguinte erro:

Input string was not in a correct format... No caso pelo debug vi que ele esta falando que essa linha esta errada.

cliente.Codigo = int.parse(tb_cod_cli.Text);

No caso nao vejo erro aki pois no banco de dados defini o codigo como inteiro.

Sei que e outra coisa tonta mais se puder ajudar agradeço.

ah reparei que ele esta dando erro em todos que contem numero no caso da linha.

cliente.Numero = Convert.ToInt32(mtb_numero.Text);

tambem deu erro e tipo esse numero e o numero da casa da pessoa e la no banco coloquei como int.

obs. coloquei // no codigo para testar por isso achei mais esse erro. E tipo o pior que ja fiz isso vendo as video aulas do Neri e la no que fiz rodo bleza agora no meu programinha que estou tentando fazer nao vai.

E erro de conversao mesmo. pois tbm acabei de tentar fazer assim e deu erro

cliente.Numero = Convert.ToInt32(mtb_numero.Text.ToString());

Afff e osso ser leigo.


Se alguem quiser me ajudar pelo msn agradeço e muito, dai mando o codigo

ricardinho_hippler@hotmail.com

Obrigado a todos.

Ricardo Hippler
   - 06 mar 2011

Como excluo esse topico ? Pois ja consegui resolver o problema... so que agora tem outro uahaua
mais queria excluir esse obrigado.

0
|
0

Rodrigo Odasaki
   - 06 mar 2011


  Ricardo a idéia não é postar uma pergunta e quando você conseguir resolver simplesmente apagar. Se conseguiu achar a solução post a solução e compartilhe com todos.

A sua dúvida pode ser a dúvida de outras pessoas.
Existem pessoas que utilizam o fórum somente quando precisam de ajuda, não acho errado, porém acho muito interessante e benéfica para comunidade sempre compartilhar os conhecimentos.

Att,
Rodrigo Odasaki

0
|
0

Ricardo Hippler
   - 07 mar 2011

Ata ok foi mal... Entao vai ai a solucao
tipo eu estava colocando o cliente.Codigo sendo que ele eu coloquei para ser gerado automaticamente a cada criacao de um novo cliente.
Entao quando voce tira ele ele roda normal.
E fui no banco de dados e alterei o cliente.numero de inteiro para varchar(5) pois vai que na casa  da pessoa nao tem numero, dai rodou tudo certinho sem erro.
So q toda hora parece que eu procuro um erro novo uahaua
agora estou com problema de fazer o banco de dados receber M ou F dependendo do que a pessoa escolher no cadastro do cliente.
Mais da um erro amanha posto ele e assim que conseguir posto pro pessoal aqui que estiver com o mesmo problema.

Desculpa ai ok ta ai a solucao q encontrei.

0
|
0