Array
(
)

Problemas com o novo VISUAL STUDIO 2008

Garba
   - 05 ago 2008

Bom dia, estou com o seguinte problema...

quando crio um webform e coloco uma gridview por exemplo ou um button e dou 2 clicks em cima para utilizar o evento do item ao invéz de ir para o code-behind ele abre o evento no próprio html como script mas não quero isso e só acontece de vez enquando, mais quando utilizo ajax...

Outro problema é quando tenho uma gridview e no evento rowdeleting dela quando coloco uma imagem ao invéz do simples link ´delete´ e quando clico na imagem para deletar o evento ´rowdeleting´ é executado 2 vezes, notei isso pq estava um pouco mais lento e qdo debuguei vi que passou 2 vezes... aí fiz o teste somente com o link ao invez de por imagem e passou 1 vez só... estranho demais, não tem uma lógica pra isso...

Por favor, se alguem souber poste aí...

Obrigado!

Vagner.net
   - 13 ago 2008

Em relação a geração do evento, isso ocorre devido a especificação durante a criação do arquivo ASPX no [URL=´http://msdn.microsoft.com/pt-br/vs2008/´]Visual Studio 2008[/URL], onde vc define a opção ´Place code in separate file´.
Caso essa opção não seja selecionada o Code Behind com os métodos, eventos e outras declarações de linguagem, será gerado no próprio arquivo ASPX.

Qualquer dúvida estou a disposição. ^_^

Vide: [url=´http://forum.clubedohardware.com.br/problemas-visual-studio/564842´]Fórum Clube do Hardware[/url][/url]

Garba
   - 13 ago 2008

valeu vagner, sempre deixo esta opção selecionada, mas as vezes ocorre este problema mesmo assim... não sei pq.. principalmente qdo abro somente o aspx..

outro problema que está ocorrendo é que as vezes quando passo do code-behind pro html o código html bagunça tudo sozinho... ou até mesmo quando mudo de uma tela pra outra.. não sei o pq disso, mas meus códigos bagunçam tudo, quase sempre tenho que dar ctrl + z para voltar pq até os ícones da tela mudam de posição... alguem sabe como arrumar isso??

obrigado...