Array
(
)

Problemas com Sp4

Wantuilcezar
   - 30 mai 2005

Pessoal,
tive uma grande surpresa ao instalar o SP4 em um servidor de
produção aqui na empresa. Nós testamos o SP4 por duas semanas nos nossos
servidores de Testes, Desenvolvimento e Homologação, todos com até 4GB de
memória e 1, 2 e 4 processadores, para só então, começar a aplicá-lo nos
servidores de produção.
Ontem, nós iniciamos a primeira instalação em um servidor de
produção, com 8GB de memória (AWE habilitado) e 4 processadores. Nós
habilitamos 6.5GB de memória para o SQL Server, então após a aplicação do
SP4, o SQL só vê 4GB. No error log apareceu a seguinte mensagem: ´Warning:
unable to allocate ´min server memory´ of 6530MB´.
Fazendo busca no Knowledge Base da MS, achei um artigo de
BUG, com data de 25/05/2005, falando sobre este problema que é um BUG do
SP4:
´BUG: Not all memory is available when AWE is enabled on a computer
that is running a 32-bit version of SQL Server 2000 SP4´
http://support.microsoft.com/default.aspx?scid=kb;en-us;899761
Acredito que muitos usuários desta lista possuem em seus ambientes
de trabalho servidores com configuração semelhante ou melhor (+ de 4GB e AWE
Habilitado). Algum de vcs instalaram o SP4 em um servidor semelhante, seja
de produção ou de homologação, teste, etc?

A solução, segundo o artigo, é deseintalar o SP4 (significa
reinstalar todo o SQL Server) ou entrar em contato com o suporte da MS.
Estamos com um suporte aberto e em breve estarei conversando com alguém da MS para saber se tem correção.

Wantuilcezar
   - 29 jun 2005

Já se encontra disponível no site da MS um fix para acertar o problema.

http://support.microsoft.com/default.aspx?kbid=899761