Array
(
)

Problemas no Visual Studio 2012

Pea
|
MVP
    24 ago 2013

Pessoal,
Sou iniciante no Visual Studio e resolvi utilizar a versão 2012.
Estou com alguns problemas que imagino que deva ser de fácil resolução :
Problema 1 - Criei um projeto em branco ASP.NET utilizando linguacem C#. Coloquei um DetaislView e segui o passo a passo para conetar ao banco de dados, ate ai tudo bem. Meu problema é que se a tabela não possui dados o objeto não aparece na tela ao abrir a pagina, só aparece se houverem dados dentro da tabela o que pode ser ???
Problema 2 - Coloquei um objeto do tipo Image na MasterPage, porém quando tento associar a imagem indo em propriedades -> Image url eu não consigo visualizar nada dentro das pastas. Coloquei uma pasta Imagem que aparece, mas imagem JPG que esta dentro dela não aparece pra ser escolhida o que pode ser ???
Grato
Fabrizzio

Aluisio Cavalcante
   - 24 ago 2013

sobre o numero 1, acho que seja necessario ter dados.

Fernanda Acacia
   - 24 ago 2013

sim, é necessario ter dados na base.

Pjava
   - 25 ago 2013

1) Para visualizar é necessário ter dados sim. O C# facilitou bastante. Antes, para quem usava Delphi, ele mostra grids vazios, o que na minha humilde opinião não faz sentido algum, tanto que nos meus bons tempos de delphi, eu sempre dava um visible false, caso não houvesse dado. O C#(.NET) simplificou mais ainda, não mostrando.

2) Cara, como está sua chamada a essa imagem? Pode passar para nós aqui o código? Está chamando via Code Behind ou Asp.Net?

Pea
|
MVP
    25 ago 2013

Obrigado pelas respostas pessoal,

Bom quanto a minha duvida 1 - Estou seguindo o passo a passo de uma video aula aqui do site onde se cria uma aplicação CatalogMagazines ( http://www.devmedia.com.br/curso/criando-uma-aplicacao-web-completa-curso-basico/12), acho que ele usava a versão 2005. Minha duvida passa a ser, se ele não aparece na tela, como fazer para inserir os registros utilizando essa forma de programação ???? por que quando tem registros o link de INSERT aparece.

Quanto a minha duvida 2 - Apenas coloquei um componente Image e cliquei no ImageUrl pra colocar a imagem mas nao aparece a imagem da pasta.

Pea
|
MVP
    25 ago 2013

Achei o problema , coisa de principiante srrrs a propriedade DefaultMode estava com ReadOnly, Coloquei como Insert e funcionou.
Vou fuçar mais pra ver o problema do Image.

Tiago
|
MVP
Pontos: 120
    25 ago 2013

O lance da imagem acredito que possa ser mais simples, tente da um refresh na solution ou no projeto... ou entao clique em "Show all files". Pelo que entendi acredito que uma dessas soluções possa lhe ajudar.

Fernanda Acacia
   - 25 ago 2013

deu certo?

Pea
|
MVP
    26 ago 2013

Coloquei na propriedade ImageUrl um caminho de uma imagem da internet e funcionou. Mas a pasta que criei dentro do projeto nao teve santo pra fazer funcionar.

Pjava
   - 26 ago 2013

Cara, remove essa pasta(delete) e crie outra. Adicione as imagens que serão usadas nessa pasta e teste outra vez. Vá no seu arquivo .aspx ou em sua máster ou em seu cshtml e passe a url da imagem certa e depois teste. Inspecione pelo browser o que está acontecendo, se realmente está lendo a url da imagem.