Array
(
)

Publicação Site

Glauco
   - 12 dez 2012

Pessoal boa tarde,
Sou bem iniciante na área de .net, peço ajuda de vocês para resolver este problema. Fiz uma aplicação em asp.net publiquei local e funcionou certinho pelo servidor ISS, porém no momento de hospedá-lo apareceu seguinte erro...

Citação:
There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined


Citação:

5: <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
6: <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
7: <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">


podem me ajudar a resolver ?

Glauco
   - 12 dez 2012

Obrigado por responder...

Porém não entendi muito bem, mas deu pra ter uma boa noção quanto a compatibilidade... Teria uma outra solução ?

Robson Robsonalves.net
   - 13 dez 2012

Bem, o seu problema começou após uma troca de framework, como aconteceu no caso acima?

se sim, tenta substituir dentro do web.config toda a tag <sectionGroup>, por isso:

#Código

<sectionGroup name="system.web.extensions" 
  type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<sectionGroup name="scripting" 
  type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<section name="scriptResourceHandler" 
  type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
  requirePermission="false" allowDefinition="MachineToApplication"/>
<sectionGroup name="webServices" 
  type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
<section name="jsonSerialization" 
  type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
  requirePermission="false" allowDefinition="Everywhere"/>
<section name="profileService" 
  type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
  requirePermission="false" allowDefinition="MachineToApplication"/>
<section name="authenticationService" 
  type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
  requirePermission="false" allowDefinition="MachineToApplication"/>
<section name="roleService" 
  type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, 
        Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 
  requirePermission="false" allowDefinition="MachineToApplication"/>
</sectionGroup>
</sectionGroup>


Ref: http://www.codeproject.com/Articles/255278/IIS-deployment-error-There-is-a-duplicate-scriptRe

Glauco
   - 13 dez 2012

Mais ou menos, esclarecendo mais o caso... fiz uma aplicação no VS 2008 que, se não me engano tem como nativo o framework 3.5, publiquei o site local e funcionou de forma esperada, porém no momento de hospedar deu esse erro

Robson Robsonalves.net
   - 13 dez 2012

o seu IIS tem framework 4.0?
se sim, altera o framework do seu diretório para 2.0

Glauco
   - 13 dez 2012

Robson, Obrigado pela ajuda...

Hoje cedo, entrei em contanto com a empresa de hospedagem, e pedi alteração de versão do FrameWork de 4.0 para 3.5. Após eles terem feito alteração o site está exibindo conforme esperado. Foi bom ter dado erro, porque assim aprendi muito, até achar a solução... mais uma vez obrigado pela ajuda..

att.
Kayo

Robson Robsonalves.net
   - 13 dez 2012

Aprendemos sempre com os erros (e tentando ajudar rsrs)

Abraços!