Array
(
)

quick report

Fernando_ramos
   - 08 mar 2006

Amigos.
bom dia.

mais uma vez venho solicitar a ajuda de vcs!

eu montei um preview personalizado...baseado na dica abaixo

#Código


[url]http://www.guiadodelphi.com.br/ler.php?codigo=458[/url]


ta funcionando 95¬ bem....

o q acontece é....

eu tenho um form...com o quick rep.
um segundo form com um botão ´FECHAR´ e outro botão ´OK´, este segundo botão chama o meu terceiro form que possui o prwview personalizado, sem fechar o form (form 2 que tem os botões), tudo funciona bem, porém após eu fechar o form q tem o preview personalizado, e retornar ao form q tem os botões....ao clicar no botão ´FECHAR´ esta não funciona mais...ao clicar nada acontrece...nao da erro e nada acontece!!!!.....eu tirar o form personalizado...o botão funciona perfeitamente.....

no onclick do botão tem isso

#Código

form2.close;


e no onpreview do form que tem o quickrep tem isso


Citação:

Form3.QRPreview1.QRPrinter := TQRPrinter(Sender);
Form3.Show;


se alguem tiver ideia....

eu to achando q , sei la..alguma coisa ta ficando presa...mas como sou iniciante...eu só acho!

abraços!


Gigatel
   - 08 mar 2006

Cara to com o mesmo problema....

to achando que este problema é bem comum...ou insolucionável...


Fernando_ramos
   - 08 mar 2006

Bom.....quem sabe achamos alguém com a possivel solução.

abraços!


Fernando_ramos
   - 13 mar 2006

pessoal,

alguem poderia me ajudar?


M
   - 13 mar 2006

Fernando estou com o mesmo problema. Mas estou trabalhando para tentar solucionar.
Caso consia a solução eu lhe aviso, só deixo claro que este problema não é só seu.

Ps: Caso consiga a solição me avise, poi preciso muito desta solução.

Mauricio
b.00000@ig.com.br