Array
(
)

Relatório Crystal Reports

Paulo Sousa
   - 28 fev 2013

Olá.
Preciso criar um relatório no Crystal mas utilizo uma procedure que gera informações a partir de uma tabela temporária no Sql. Como faço para definir o design do relatório neste caso uma vez que se criar um dataset com a procedure eu não consigo listar os campos?
Posso fazer de outra forma, ou seja acessar a procedure via código? neste caso como faço o design?
obrigado

Marcelo Franzini
   - 24 mai 2013

Olá Paulo ...

Você pode colocar a procedure no Report Header e adicionar a tabela temporaria no relatório sem problemas.

Caso ainda não tenha resolvido o problema pode me encaminhar mais informações acessando meu site www.crystalreportsolution.com.br

Marcelo

0
|
0

Paulo Sousa
   - 24 mai 2013

Opa Marcelo,

Muito obrigado pelo retorno. Consegui concluir o relatório. Abraço

0
|
0

Adriano Merett
   - 24 mai 2013

Olá Paulo Pereira de Sousa boa noite, cara vi que vc esta trabalhando com o Crystal reports, amigo estou tendo um grande problema aqui para criar relatórios com o Crystal gostaria de saber de vc, qual versão do Visual Studio vc usa e qual a versão do Crystal Reports amigo por favor se puder me ajudar eu fico agradecido pois já bati muito a cabeça com esse crystal aqui e nada ele dá um montes de erros ná hora de compilar o projeto, meu e-mail é merettgodoy@gmail.com aguardo resposta amigão.

0
|
0

Mauricio Souza,
   - 28 mai 2013

Amigo, não sei se vou te ajudar, mas em "testes" a última versão do Crystal Reports está funcionando tanto no Visual Studio 2010 como no 2012.

0
|
0

Adriano Merett
   - 30 mai 2013

Pois é amigão eu baixei esta versão aqui do Crystal reports CRforVS_13_0_5 testei ele com o Visual studio 2010 ulimate não deu certo ai desinstalei, e instalei o visual studio 2010 profissional, mas nada, cheguei até formatar minha máquina, e instalar tudo de novo, mas continuou o mesmo problema, lamentável.

0
|
0

Mauricio Souza,
   - 30 mai 2013

Amigo, será que você está baixando certo? Fica disponível o report viewer do Crystal Reports na ToolBox?

0
|
0

Black
   - 30 mai 2013


Citação:
Pois é amigão eu baixei esta versão aqui do Crystal reports CRforVS_13_0_5 testei ele com o Visual studio 2010 ulimate não deu certo ai desinstalei, e instalei o visual studio 2010 profissional, mas nada, cheguei até formatar minha máquina, e instalar tudo de novo, mas continuou o mesmo problema, lamentável.


Amigo seguinte, já tive esse problema, o crystal não funciona se você estiver usando .net framework 4.0 ou 4.5 CLIENT
faz assim no seu projeto clica com o botão direito vai em propriedades na aba application vê se a opção taget framework
ta como client profile se estiver e só mudar que vai resolver seu problema, se precisar de mais ajuda é só falar
já apanhei muito com o crystal, qualquer coisa tamo ai!!

0
|
0

Pjava
   - 31 mai 2013

Olá Paulo, bom dia. Assim como muitos tentaram te ajudar, seria interessante você postar a resolução para que outros possam ser ajudados também. Essa á a essência do forum.

0
|
0

Paulo Sousa
   - 01 jun 2013

Srs, Bom dia.

Em relação a solução do meu problema com o Crystal, estou utilizando o Visual Studio 2008 com o Crystal reports que foi instalado com a mesma. Não tenho problemas com a utilização do mesmo em relação a compilação. Fiz vários testes de utilização de procedures relativo a dúvida aqui postada. A Empresa adquiriu o Data Dynamics Reports e passamos a utilizar esta ferramenta para a criação dos relatórios e foi bem mais tranquilo. Qualquer dúvida estou a disposição.

0
|
0

Adriano Merett
   - 01 jun 2013

Olá Paulo meu querido, muito obrigado mesmo cara, resolveu o meu problema, fazia dias que estava buscando a solução e não tinha encontrado mas foi isto mesmo que você me falou, só uma observação esta opção não esta na aba aplication esta na aba Compile: projeto > Properties > Compile > Advanced Compile Options.. > em Target framework (all configurations): estava .NET Framework 4 Client Profile > ai mudei para .NET Framework 4, funcionou que é uma maravilha muito obrigado mesmo.

0
|
0

Adriano Merett
   - 01 jun 2013


Citação:

Citação:
Pois é amigão eu baixei esta versão aqui do Crystal reports CRforVS_13_0_5 testei ele com o Visual studio 2010 ulimate não deu certo ai desinstalei, e instalei o visual studio 2010 profissional, mas nada, cheguei até formatar minha máquina, e instalar tudo de novo, mas continuou o mesmo problema, lamentável.


Amigo seguinte, já tive esse problema, o crystal não funciona se você estiver usando .net framework 4.0 ou 4.5 CLIENT
faz assim no seu projeto clica com o botão direito vai em propriedades na aba application vê se a opção taget framework
ta como client profile se estiver e só mudar que vai resolver seu problema, se precisar de mais ajuda é só falar
já apanhei muito com o crystal, qualquer coisa tamo ai!!


Olá Paulo meu querido, muito obrigado mesmo cara, resolveu o meu problema, fazia dias que estava buscando a solução e não tinha encontrado mas foi isto mesmo que você me falou, só uma observação esta opção não esta na aba aplication esta na aba Compile: projeto > Properties > Compile > Advanced Compile Options.. > em Target framework (all configurations): estava .NET Framework 4 Client Profile > ai mudei para .NET Framework 4, funcionou que é uma maravilha muito obrigado mesmo.

0
|
0

Black
   - 02 jun 2013


Citação:

Citação:

Citação:
Pois é amigão eu baixei esta versão aqui do Crystal reports CRforVS_13_0_5 testei ele com o Visual studio 2010 ulimate não deu certo ai desinstalei, e instalei o visual studio 2010 profissional, mas nada, cheguei até formatar minha máquina, e instalar tudo de novo, mas continuou o mesmo problema, lamentável.


Amigo seguinte, já tive esse problema, o crystal não funciona se você estiver usando .net framework 4.0 ou 4.5 CLIENT
faz assim no seu projeto clica com o botão direito vai em propriedades na aba application vê se a opção taget framework
ta como client profile se estiver e só mudar que vai resolver seu problema, se precisar de mais ajuda é só falar
já apanhei muito com o crystal, qualquer coisa tamo ai!!


Olá Paulo meu querido, muito obrigado mesmo cara, resolveu o meu problema, fazia dias que estava buscando a solução e não tinha encontrado mas foi isto mesmo que você me falou, só uma observação esta opção não esta na aba aplication esta na aba Compile: projeto > Properties > Compile > Advanced Compile Options.. > em Target framework (all configurations): estava .NET Framework 4 Client Profile > ai mudei para .NET Framework 4, funcionou que é uma maravilha muito obrigado mesmo.


fico feliz em ter ajudado, qualquer coisa e só falar, outra coisa fui eu que respondi, kkkkkkkkk
só pra constar mesmo

0
|
0

Paulo Sousa
   - 02 jun 2013

Obrigado Black.

Os créditos são todos seus. Abraço.

0
|
0

Marcelo Franzini
   - 03 jun 2013

Pessoal, Boa Noite ...

Publiquei no meu site vejam se ficou legar, aceito sugestões ...

www.crystalreportsolution.com.br

Abrs,
Marcelo

0
|
0

José
   - 18 set 2013

Como a duvida já foi solucionada, estou finalizando este tópico.
Obrigado a todos.

0
|
0