Array
(
)

USES não Funciona

Uoquisala
   - 09 ago 2004

Alguem sabe me dizer pq isto acontece.

Tenho o form01 e o Form02,

Coloco no uses do form02 a unit do Form01 para poder ter acesso as conecções ou coloco em implementation, mais não acontece nada não consigo enxergar nada da unit do form01.

Isto acontece de vez em quando.

Alguem sabe me dizer.


Rafs
   - 09 ago 2004

Já vi isso algumas vezes, mas não sei exatamente o pq acontece.
Mas percebi que se eu salvar o projeto, ou compilá-lo, após incluir a unit na cláusula uses, este problema não ocorre.


Uoquisala
   - 09 ago 2004

Jafiz isso e de nada adiantou.


Citação:
Já vi isso algumas vezes, mas não sei exatamente o pq acontece.
Mas percebi que se eu salvar o projeto, ou compilá-lo, após incluir a unit na cláusula uses, este problema não ocorre.



Okama
   - 09 ago 2004

Se for pra visualizar as conexões tente abrir o form, algumas vezes ocorreu comigo usando Data Module e percebi que o Delphi não lê os arquivos fechados.

Pode ser coincidência, mas sempre funcionou.


Uoquisala
   - 09 ago 2004

de nada adiantou tb, to ferrado se não funcionar terei que refazer tudo de novo.


Citação:
Se for pra visualizar as conexões tente abrir o form, algumas vezes ocorreu comigo usando Data Module e percebi que o Delphi não lê os arquivos fechados.

Pode ser coincidência, mas sempre funcionou.



Okama
   - 09 ago 2004

Faz o seguinte, remove tudo e quando você for compilar o delphi irá perguntar se quer adicionar a unit. O mesmo ocorre quando vc referencia form1.Edit1.text no Form2.


Deryck
   - 09 ago 2004

Aperte ALT + F11 OU F12 (NÃO ME LEMBRO), ele ira mostra um tele , e vc escolhe qual unitvc quer adicionar no seu form!


Oscar Candido
   - 10 ago 2004


Citação:
Aperte ALT + F11 OU F12 (NÃO ME LEMBRO), ele ira mostra um tele , e vc escolhe qual unitvc quer adicionar no seu form!


é Alt+F11, ou File =>Use Unit, sempre faço desse modo, acho que assim corre menos risco de dar algum erro.
outra coisa é salvar todo o projeto antes de colocar os uses, assim se eu mudar o nome de alguma Unit quando eu salvar não vai dar problema


Uoquisala
   - 10 ago 2004

Gente agradeço a todos os que estão me ajudando, mais todos estes processos que nossos amigos nos disseram aqui ja fiz e não funciona, tudo bem que se eu reinstalar o Delphi7 ele volta ao normal mais e a terceira vez que faço isso queria uma solução.

Se ainda assim poderem ajudar agradeço.



Citação:

Citação:
Aperte ALT + F11 OU F12 (NÃO ME LEMBRO), ele ira mostra um tele , e vc escolhe qual unitvc quer adicionar no seu form!


é Alt+F11, ou File =>Use Unit, sempre faço desse modo, acho que assim corre menos risco de dar algum erro.
outra coisa é salvar todo o projeto antes de colocar os uses, assim se eu mudar o nome de alguma Unit quando eu salvar não vai dar problema