Quick Tips: LPE - Parte 2

Você precisa estar logado para dar um feedback. Clique aqui para efetuar o login
Para efetuar o download você precisa estar logado. Clique aqui para efetuar o login
Confirmar voto
0
 (1)  (0)

Existem várias definições para “Algoritmos”, mas podemos definir como uma seqüência finita de ações que descrevem como um problema pode ser resolvido.




Algoritmos


    Existem várias definições para “Algoritmos”, mas podemos definir como uma seqüência finita de ações que descrevem como um problema pode ser resolvido. Quando as ações de um algoritmo obedecem a sintaxe de uma linguagem de programação, passamos a chamá-lo de Programa.

    Embora pareça complicado, o conceito de algoritmo nos é bastante  familiar. Todos os dias estamos executando algoritmo. Isto significa que a palavra se aplica não só aos computadores, mas também aos procedimentos humanos. Veja Abaixo:

1.1 Receita Culinária
1.2 Instruções para uso de um eletrodoméstico
1.3 Partitura Musical


    Instruções são como frases que indicam as ações a serem executadas. São compostas de um verbo imperativo mais um complemento. Por Exemplo:

1.1 Bata duas claras em neve
1.2 Gire o seletor de canais
1.3 Espere o sinal verde


    Desenvolver um bom algoritmo é a principal chave para a programação de computadores. Só comece a codificar um programa após o algoritmo estar totalmente desenvolvido e  testado. Veja um exemplo de Algoritmo:

1.    Molhe o Cabelo
2.     Repita
2.1.    Coloque a quantidade de uma tampa de xampu no cabelo
2.2.    Massageie forte até fazer espuma
2.3.    enxágüe

Vejamos uma versão melhorada desse algoritmo:

1. Molhe o Cabelo
2. Repita duas vezes
2.1 Coloque a quantidade de uma tampa de xampu no cabelo
2.2 Massageie forte até fazer espuma
2.3 Enxágüe



Outros exemplos de algoritmos:


Contexto Culinário.

  1. Misture os Ingredientes
  2. Unte O tabuleiro com manteiga
  3. Despeje a mistura no tabuleiro
  4. Se há queijo parmezon então
    1. Espalhe sobre a mistura
  5. Leve o tabuleiro ao forno
  6. Enquanto não corar
    1. Deixe o tabuleiro no forno
  7. Retire do Forno
  8. Deixe esfriar
  9. Experimente antes de servir




Contexto Administrativo:

  1. Verifique preenchimento do formulário
  2. Se preenchimento correto então
    1. Arquive o documento
    2. Forneça protocolo
  3. senão
    1. Lamente
    2. Torne a lamentar
    3. Peça ao cliente para comprar outro formulário
  4. Despeça-se educadamente do cliente
Bem pessoal já viu a importancia de um algoritmo para a solução de um problema. Deixo aqui a solução para o problema exposto no algoritmo anterior. Veja:

  1. SE (X < Y+Z) E (Y < X+Z) E (Z < X+Y) ENTAO
    1. SE (X=Y) E (Y=Z) ENTAO
      1. ESCREVAL( "EQUILÁTERO" )
    2. SENAO
      1. SE (X<>Y) E (Y<>Z) E (X<>Z) ENTAO
        1. ESCREVAL( "ESCALENO" )
      1. SENAO
        1. ESCREVAL( "ISÓSCELES" )
      2. FIMSE
    3. FIMSE
  2. SENAO
    1. ESCREVAL( "NÃO É TRIÂNGULO" )
  3. FIMSE
E para variar mais um problema para vocês:

Faça um programa para solicitar o código da turma, a quantidade de alunos do sexo masculino, a quantidade
de alunos do sexo feminino e a quantidade de alunos aprovados de uma determinada turma. Calcular e informar:
a porcentagem de alunos do sexo masculino; a porcentagem de alunos do sexo feminino; a porcentagem de
alunos reprovados; o total de alunos da turma.

Abraços e até lá !!!!!!



 
Você precisa estar logado para dar um feedback. Clique aqui para efetuar o login
Receba nossas novidades
Ficou com alguma dúvida?