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Aplicações Cliente/Servidor
Uso de múltiplos Data Modules 

No passado, principalmente 
quando se programava para 
MS-DOS, a quantidade de me-

mória RAM disponível era irrisória, o 
que obrigava os programadores muitas 
vezes a usar técnicas complexas para 
economizar alguns poucos bytes de me-
mória de leitura. 

Atualmente os computadores possuem 
grande quantidade de memória RAM dis-
ponível, mas isto não é motivo para que 
se aloque memória desnecessariamente, 
já que nem sempre a aplicação rodará 
localmente. Por exemplo: uma aplicação 
instalada num servidor pode ser acessada 
simultaneamente por diversos usuários 
via Windows Terminal Services (WTS). 
Estes usuários podem estar em qualquer 
lugar do mundo, mas rodarão a aplicação 
diretamente no servidor. Se o sistema e 
o número de usuários forem grandes, e 
o desenvolvedor abusar da alocação de 
memória, pode haver problema de falta 
de memória mesmo em computadores 

com mais de 1 GB de RAM.
Este artigo mostra passo a passo uma 

técnica simples e eficaz para criar Data 
Modules em tempo de execução em apli-
cações Cliente/Servidor, o que torna a 
inicialização da aplicação mais rápida 
e ao mesmo tempo consome menos me-
mória RAM.

Entendendo a arquitetura
Data Module nada mais é do que um 

repositório de componentes não visuais 
assim como o próprio nome sugere.  Sua 
finalidade é alocar componentes de 
acesso a dados a fim de separar regras 
de negócio da interface. Com isso tem-se 
uma maior facilidade na manutenção e/
ou em uma possível migração de Cliente/
Servidor (duas camadas) para n-tiers (três 
ou mais camadas). 

A Figura 1 ilustra como fica a arquitetu-
ra de uma aplicação usando Data Modules, 
onde os componentes de acesso a dados 
e as regras de negócios estariam neles, 
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ficando somente na parte do formulário 
os componentes visuais e os que não 
acessam dados.

Criando a Aplicação
Essa aplicação será constituída de um 

formulário principal e 4 Data Modules. 
Portanto crie uma nova aplicação utilizan-
do o menu File|New>Application. Salve o 
projeto na pasta de sua preferência. Para a 
Unit dê o nome de “uPrincipal.pas” e para 
o projeto dê o nome de “Employee.dpr”, 
por último altere a propriedade Name do 
formulário para “frmPrincipal”.

Configurando os Data Modules
Adicione um Data Module usando o 

menu File|New>Data Module e salve-o 
com nome de “uDMConexao”, altere a 
propriedade Name para “dmConexao”. 
Coloque o dmConexao para que seja criado 
antes do frmPrincipal. Para isso acesse 
Project>Options ou use o atalho Ctrl + 
Shift + F11 e na aba Forms mude a ordem 
para que o dmConexao esteja primeiro que 
o frmPrincipal.

Por padrão, todos os formulários e Data 
Modules são criados automaticamente 
quando o programa é inicializado, para 
alterar isso vá em Tools|Environment 
Options>Designer e desmarque a opção 
Auto create forms & data modules. Outra 
forma de fazer a mesma coisa é a partir 
da janela Project>Options, após criar o Figura 1. Arquitetura de uma aplicação com Data Module

Figura 2. Opções do projeto com todos os Data Modules criados Figura 3. Exemplo de Conexão com o FireBird
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formulário ou Data Module selecionar os 
que não serão criados com a aplicação e 
arrastá-los para o lado (Avaliable forms). 
No final do desenvolvimento do aplica-
tivo mostrado neste artigo, deverá ter-se 
a mesma configuração apresentada na 
Figura 2.

O próximo passo é configurar a conexão 
com a base de dados. Para este aplica-
tivo será usada a base de exemplo que 
acompanha o FireBird. Para isso adicione 
um componente SQLConnection (“sqlCo-
nexao”), que está na aba dbExpress, ao 
sqlConexao dê dois cliques no componente 
para configurar suas propriedades.

Crie uma nova conexão clicando no 
botão “+”. Na caixa de diálogo que se 
abre selecione o driver Interbase em 
Driver Name, dê um nome a conexão em 
Connection Name e confirme.

Nota: O Delphi traz por padrão algu-

mas conexões previamente configura-

das, como é o caso de IBConnection.  

Após criar a conexão configure a pro-
priedade DataBase informando o endereço 
completo para o arquivo EMPLOYEE.
FDB, normalmente localizado na pasta 
C:\Arquivos de Programas\Firebird_1_5\
Firebird\Examples\empbuild\. A proprieda-
de User_Name é o usuário que será usado 
para conectar no servidor, por padrão é 
SYSDBA e a senha é masterkey (atributo 
Password). Mude o SQLDialect para 3 e 
pressione OK, a configuração deverá ficar 
semelhante a mostrada na Figura 3. 

No Object Inspector mude as proprie-
dades LoginPrompt para False e ative 
a conexão mudando para True a pro-
priedade Connected. Pronto, a conexão 
com o servidor de banco de dados está 
estabelecida.

Adicione um novo Data Module ao proje-

to. Ele conterá a query que será usada para 
mostrar os dados da tabela Country. Sal-
ve-o com o nome de “uDMLista”, mude 
a propriedade Name para “dmLista” e 
adicione uma referência a Unit dmConexao 
usando para isso o menu File>Use Unit 
ou o atalho Alt + F11. Agora adicione um 
componente do tipo SQLQuery ao Data 
Module, renomeie-o para “qryCountry” e 
na propriedade SQLConnection coloque a 
conexão criada no dmConexao. Coloque a 
seguinte consulta na propriedade SQL:

select * from COUNTRY

Ative e desative a query para verificar 
se a consulta inserida está correta. Feito 
isso adicione mais dois componentes: um 
DataSetProvider(“dspCountry”) alterando 
a propriedade DataSet para “qryCoun-
try”. Um ClientDataSet(“cdsCountry”) 
com a propriedade DataSetProvider apon-
tada para o dspCountry. Dê dois cliques 
no cdsCountry e com o botão direito do 
mouse selecione a opção  Add all fields, 
com isso estará adicionando todos os 
campos da tabela ao Fields Editor.

 Adicione outro SQLQuery que será uti-
lizado para mostrar os dados da tabela 
Customer. Mude as propriedades Name 
para “qryCustomerLista”, SQLConnection 
para “dmConexao.sqlConexao”, e para o 
SQL adicione a instrução a seguir:

select * from CUSTOMER 

Adicione agora um DataSetProvider(“d
spCustomerLista”) e mude seu DataSet 
para “qryCustomerLista”. Finalmente 
adicione um ClientDataSet(“cdsCustom
erLista”). Seu ProviderName deverá ser 
apontado para dspCustomerLista. Por fim 
dê dois cliques no cdsCustomerLista e 
com o botão direito do mouse selecione 
a opção Add all fields (Figura 4).

Adicione mais um Data Module para a 

Figura 4. dmLista depois de configurado

tabela Customer da nossa base de dados. 
Salve com o nome de “uDMCustomer.
pas” e mude a propriedade Name para 
“dmCustomer”. Adicione uma referência 
ao dmConexao usando Alt + F11 assim 
como foi feito anteriormente.

Nesse ponto serão adicionados os 
componentes que permitem inserir 
novos registros na tabela. Para isso 
adicione três componentes sendo: um 
SQLQuery(“qryCustomer”), SQLCon-
nection como “dmConexao.sqlConexao” 
e propriedade SQL com a instrução a 
seguir:

select * from CUSTOMER

Um DataSetProvider(“dspCustomer”) 
com a propriedade DataSet apontada 
para qryCustomer e por último um 
ClientDataSet(“cdsCustomer”) com sua 
propriedade ProviderName igual a dsp-
Customer.

Assim como nos demais ClientDataSets 
adicione todos os campos da tabela 
usando a opção Add all fields encontrado 
no menu de contexto do Fields Editor, ou 
seja, clique duas vezes no cdsCustomer e 
em seguida com o botão direito escolha 
a opção mencionada(Tabela 1).

No evento BeforeOpen do cdsCustomer 
digite: 
{ Cria o dmLista }
dmLista := TdmLista.Create(nil);
{ Abre o cdsCountry }
dmLista.cdsCountry.Open;

E no evento AfterClose digite:
{ Fecha o cdsCountry }
dmLista.cdsCountry.Close;
{ Libera de memória o dmLista }
FreeAndNil(dmLista);

Nota: Não esqueça de adicionar a 

Unit do Data Module dmLista ao Uses 

do Data Module dmCustomer. Utilize 

File>Use unit ou Alt + F11.  

Componente Propriedade Valor

SQLQuery1

Name qryCustomer

SQLConnection dmConexao.SQLConnection1

SQL SELECT * FROM CUSTOMER

DataSetProvider1
Name dspCustomer

DataSet qryCustomer

ClientDataSet1
Name cdsCustomer

DataSetProvider dspCustomer

Tabela 1. Configuração dos componentes utilizados no dmCustomer



44  ClubeDelphi – Aplicações Cliente/Servidor Edição 90 - ClubeDelphi  45  

easy DeLphi

Com estes dois eventos garante-se que 
o dmLista será criado quando for aberto o 
cdsCustomer e quando ele for fechado será 
liberado de memória, não permanecendo 
em memória quando desnecessário.

Adicione também a este Data Module 
mais um SQLQuery que desta vez será 
usado pelo Generator CUST_NO_GEN, 
que vai garantir que não se tenha cha-
ves primárias repetidas para a tabela 
Customer, altere as propriedade Name 
para “qryGenCustomer”, SQLConnection 
coloque a conexão criada no dmConexao, 
que neste caso é sqlConexao, e insira o 
seguinte select na propriedade SQL:
select GEN_ID(cust_no_gen,1) from 
rdb$database

Nota: Generator é um objeto do banco 

de dados Firebird que, com o auxílio da 

função GEN_ID também do banco, gera 

números seqüenciais, os famosos Auto 

Incrementados.

De dois cliques na query e adicione todos 
os campos. No evento AfterInsert do cds-

Listagem 1. Código do evento AfterInsert do cdsCustomer

procedure TdmCustomer.cdsCustomerAfterInsert(DataSet: TDataSet);
begin
  { Abre a qryGenCustomer }
  qryGenCustomer.Open;
  { Atribui o valor do qryGenCusomerGEN_ID para o cdsCustomerCUST_NO }
  cdsCustomerCUST_NO.Value := qryGenCustomerGEN_ID.AsInteger;
  { Fecha a qryGenCustomer }
  qryGenCustomer.Close;
end;

Componente Propriedade Valor

SQLQuery1

Name qrySales

SQLConnection dmConexao.SQLConnection1

SQL SELECT * FROM SALES

DataSetProvider1
Name dspSales

DataSet qrySales

ClientDataSet1
Name cdsSales

DataSetProvider dspSales

Tabela 2. Configuração dos componentes utilizados para o dmSales

Figura 5. dmSales depois de configurado

Customer digite o código da Listagem 1.
Para tornar mais clara a utilização será 

criado agora mais um cadastro para a tabe-
la SALES que tem relacionamento “n” para 
1 com a tabela CUSTOMER. Seguindo a 
mesma idéia usada anteriormente para o 
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Figura 6. frmPrincipal depois de alterado para o cadastro da tabela Customer     

cadastro da tabela CUSTOMER crie um 
novo Data Module salve com o nome de 
“uDMSales.pas” e mude a propriedade 
Name para “dmSales”. Figura 5

Adicione um componente SQLQuery, um 
DataSetProvider e um ClientDataSet confi-
gurando-os de acordo com a Tabela 2.

Dê dois cliques no cdsSales com o botão 
direito do mouse selecione a opção Add 
All Fields. Para o evento BeforeOpen do 
cdsSales digite:

{ Cria o dmLista }
dmLista := TDMLista.Create(nil);
{ Abre o cdsCustomerLista }
dmLista.cdsCustomerLista.Open; 

E para o evento AfterClose do cdsSales 
digite:

dmLista.cdsCustomerLista.Close; 
{ Fecha o cdsCustomerLista }
FreeAndNil(dmLista); 
{ Libera de memoria o dmLista }

Com isto tem-se somente em memória o 
dmLista enquanto o cdsSales estiver aberto.

Configurando o formulário principal
Abra o frmPrincipal adicione uma re-

ferência aos Data Modules dmCustomer, 
dmLista e dmSales. Adicione dois GroupBoxs 
mudando a propriedade Name para “gbx-
Customer” e “gbxSales” respectivamente. 
Adicione também 4 DataSources alterando 
a propriedade Name de cada um deles 
para dsCustomer,  dsSales, dsCountryLista e 
dsCustomerLista. Altere a propriedade Da-
taSet de cada um deles apontando-os para 
seus respectivos ClientDataSets O dsCusto-
mer receberá “dmCustomer.cdsCustomer”, 
para o dsSales coloque “dmSales.cdsSales”, 
no dsCountryLista receberá “dmLista.cds-
Country e para o dsCustomerLista coloque 
“dmLista.cdsCustomerLista”.

Dentro do gbxCustomer adicione 10 DBE-
dits, 11 Labels e um DBLookupComboBox. 
Para os componentes DBEdit configure a 
propriedade DataSource para dsCustomer 
e a propriedade DataField faça com que 
cada um receba um campo diferente. 

No DBLookupComboBox altere as seguin-
tes propriedades: Name para “cbxCoun-
try”, ListSource para “dsCountryLista”, 
ListField para “CURRENCY”, KeyField 
para “COUNTRY”, DataSource para ds-
Customer e DataField para “COUNTRY”.

Dentro do “gbxSales” adicione 10 DBE-
dits, 11 Labels e um DBLookupComboBox. 
Altere a propriedade DataSource dos DBE-

Listagem 2. Código do botão Novo

procedure TfrmPrincipal.btnNovoClienteClick(Sender: TObject);
begin
  { Verifica se já foi instanciado a o dmCustomer }
  if dmCustomer = nil then 
    { Instância a variável dmCustomer } 
    dmCustomer := TdmCustomer.Create(nil); 
  { Abre o cdsCustomer }
  dmCustomer.cdsCustomer.Open; 
  { Insere um novo registro no cdsCustomer }
  dmCustomer.cdsCustomer.Insert; 
end;

Listagem 3. Código do botão Salvar

procedure TfrmPrincipal.btnSalvarClienteClick(Sender: TObject);
begin
  { Verifica se já foi criada o dmCustomer }
  if dmCustomer <> nil then 
  begin
    { Guarda uma linha no cdsCustomer }
    dmCustomer.cdsCustomer.Post; 
    { Salva as alterações guardadas no cdsCustomer para o banco }
    dmCustomer.cdsCustomer.ApplyUpdates(0);
    { Libera da memoria o dmCustomer. }
    FreeAndNil(dmCustomer); 
  end
  else 
    { Caso não exista em memória ainda o dmCustomer emite uma mensagem }
    ShowMessage(‘Você deve clicar em novo antes de salvar um registro’);
end;

Listagem 4. Código do botão Cancelar

procedure TfrmPrincipal.btnCancelarClienteClick(Sender: TObject);
begin
  { Verifica se já foi criada o dmCustomer }
  if dmCustomer <> nil then
  begin
    { Cancela tudas as alterações realizadas no cdsCustomer. }
    dmCustomer.cdsCustomer.Cancel;  
    { Libera da memória o dmCustomer. }
    FreeAndNil(dmCustomer);
  end
  else 
    { Caso não exista em memória ainda o dmCustomer emite uma mensagem. }
    ShowMessage(‘Você deve clicar no novo antes de cancelar um’ + ‘registro’);
end;
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Listagem 5. Código do botão Nova Venda

procedure TfrmPrincipal.btnNovaVendaClick(Sender: TObject);
begin
  { Verifica se já foi criado o dmSales }
  if dmSales = nil then
    { Instancia a variável dmSales }
    dmSales := TdmSales.Create(nil);
  { Abre o cdsSales }
  dmSales.cdsSales.Open;
  { Insere um novo registro no cdsSales }
  dmSales.cdsSales.Insert;
end;

Listagem 6. Código do botão Salvar Venda

procedure TfrmPrincipal.btnSalvarVendaClick(Sender: TObject);
begin
  { Verifica se já foi criado o dmSales }
  if dmSales <> nil then
  begin
    { Guarda uma linha no cdsSales }
    dmSales.cdsSales.Post;
    { Salva as alterações guardadas no cdsSales para o banco }
    dmSales.cdsSales.ApplyUpdates(0);
    { Fecha o cdsSales }
    dmSales.cdsSales.Close;
    { Libera da memoria o dmSales }
    FreeAndNil(dmSales);
  end
  else
    { Caso não exista em memória ainda o dmCustomer emiti uma mensagem }
    ShowMessage(‘Você deve clicar no novo antes de salvar um registro’);
end;

Listagem 7. Código do botão Cancelar Venda

procedure TfrmPrincipal.btnCancelarVendaClick(Sender: TObject);
begin
  { Vrifica se já foi criada o dmSales }
  if dmSales <> nil then
  begin
    { Cancela tudas as alterações realizadas no cdsSales }    
    dmSales.cdsSales.Cancel;
    { Fecha o cdsSales }
    dmSales.cdsSales.Close;
    { Libera da memória o dmSales }
    FreeAndNil(dmSales);
  end
  else
    { Caso não exista em memória ainda o dmCustomer emiti uma mensagem }
    ShowMessage(‘Você deve clicar no novo antes de cancelar um registro’);
end;

dit para dsSales e ajuste o DataField para 
que nenhum DBEdit  fique com o mesmo 
campo. Já para o DBLooKupComboBox alte-
re as seguintes propriedades: Name para 
cbxSales, ListSource para dsCustomerLista, 
ListField para “CUSTOMER”, KeyField 
para “CUST_NO”, DataSource para dsSales 
e DataField para “CUST_NO”.

Após concluídas essas configurações o 
formulário principal deverá se parecer 
com a Figura 6.

Codificando o exemplo
Faremos agora a parte de codificação 

do exemplo. Antes de codificar, insira 6 
componentes Button sendo 3 no GroupBox 
superior com os nomes btnNovoCliente, 
btnSalvarCliente e btnCancelarCliente. Re-
pita esses passos modificando os nomes 
dos 3 outros Buttons do GroupBox para 
btnNovaVenda, btnSalvarVenda e btnCan-
celarVenda. 

Começaremos pelo botão novo cha-
mado de btnNovo. Dê um duplo clique 
no btnNovoCliente que está dentro do 
gbxCustomer e insira o seguinte código 
da Listagem 2.

Para o evento onClick do btnSalvar que 
está dentro do gbxCustomer digite o códi-
go da Listagem 3.

Para o evento onClick do btnCancelar 
que está dentro do gbxCustomer digite o 
código da Listagem 4.

Em seguida codifique o btnNovaVenda 
que esta dentro gbxSales digite o código 
da Listagem 5.

Já para o botão btnSalvarVenda que 
também está dentro do gbxSales digite o 
código da Listagem 6.

Por último o btnCancelar digite o seguin-
te código da Listagem 7.

Conclusão
Embora os computadores de hoje possu-

am grande quantidade de memória RAM 
disponível, ainda é preciso que se tenha 
cuidado com o desenvolvimento, pois nem 
sempre as aplicações são executadas numa 

rede local. Este artigo mostrou passo a pas-
so uma técnica simples e eficaz para criar os 
componentes de acesso à dados em tempo 
de execução, o que torna a inicialização da 
aplicação mais rápida e ao mesmo tempo 
consome menos memória RAM.  




