Array
(
)

alterar nome do wsdl.

Eric Miranda
   - 06 ago 2013

Bom dia pessoal, estou enroscado com uma coisa aqui pois é a primeira vez que estou fazendo, procurei bastante na net mas ainda não encontrei o caminho..por isso queria a ajuda de vcs..
Estou registrando um wcf na locaweb..
segue abaixo meu web.config
#Código

<?xml version="1.0"?>
<configuration>

  <appSettings>
    <add key="aspnet:UseTaskFriendlySynchronizationContext" value="true" />
  </appSettings>
  <system.web>
    <compilation debug="true" />
    <httpRuntime/>
  </system.web>
  <system.serviceModel>
   <!-- <services>
      <service name="WcfServiceDevMedia.LibraryService.svc">
        <endpoint
		  address="http://cpro5870.publiccloud.com.br/Devmedia/LibraryService.svc"
		  binding="basicHttpBinding"
		  bindingConfiguration="BasicHttpBinding_ILibraryService"
          contract="WcfServiceDevMedia.ILibraryService"
           />
       </service>
    </services>-->
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <!-- To avoid disclosing metadata information, set the values below to false before deployment -->
          <serviceMetadata httpGetEnabled="true" />
          <!-- To receive exception details in faults for debugging purposes, set the value below to true.  Set to false before deployment to avoid disclosing exception information -->
          <serviceDebug includeExceptionDetailInFaults="false"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <protocolMapping>
        <add binding="basicHttpsBinding" scheme="https" />
    </protocolMapping>    
    <!--<serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" /> -->
  </system.serviceModel>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
    <!--
        To browse web app root directory during debugging, set the value below to true.
        Set to false before deployment to avoid disclosing web app folder information.
      -->
    <directoryBrowse enabled="true"/>
  </system.webServer>

</configuration>

se quiserem olhar ele está publicado
http://cpro5870.publiccloud.com.br/Devmedia/LibraryService.svc
ele aparece no wsdl o seguinte caminho
http://cpro5870/Devmedia/LibraryService.svc?wsdl
e quando não encontra nada pois o endereço correto deveria ser
http://cpro5870.publiccloud.com.br/Devmedia/LibraryService.svc?wsdl
mas não sei como alterar isso..
o meu web.config está errado ou isso é outra configuração?
obrigado.

Eric Miranda
   - 06 ago 2013

Bom dia galera.. finalmente consegui.. tinha uma dica do Israel Aece mas não estava fazendo corretamente.

Os passos são os seguintes:

1) Entre no IIS e navegue até o "Default Web Site", clique com o botão direito e vá em Editar ligações ( ou Edit Bindings)
2) Edit o http colocando no nome do host o nome desejado.. funcionou perfeitamente..

qualquer dúvida estou a disposição, caso não tenha sido claro na explicação me fale que eu tento explicar melhor.

abs

0
|
0

José
   - 06 ago 2013

Tendo entendido que a duvida foi solucionada, estou dando o tópico por concluído.
Fique a vontade para abrir novos tópicos.

0
|
0