Array
(
)

Conexões usando Ip ou Nome do host

Fernando Moraes
   - 22 jun 2011

É o seguinte,
Aconteceu comigo
que ao efetuar uma conexão no servidor de banco de dados, a conexão era efetuada somente via IP porém ao colocar o nome do computador (server) nao funcionava.
A atribuição de Ip não é possível porque é via DHCP e toda hora muda...
Gostaria de saber como faço pra resolver este problema no Sql server 2005 e 2008
Se é problema de configuração do Windows, Firewall, Opção do Próprio SQL Server..
Valeuté

Fernando Moraes
   - 22 jun 2011

Mencionando, o SQL Server está instalado no Windows Server 2003 e estava realizando uma conexão no Windows 7
up

Fernando Moraes
   - 22 jun 2011

Os named pipes, tcp/ip etc etc estão ativados (no sql server configuration manager)
 

Emerson
   - 22 jun 2011

conectar como?

Fernando Moraes
   - 22 jun 2011

conectar usando a aplicação ou Management studio

Marco Pinheiro
   - 10 jul 2011

Fernando,   O acesso que vc está tentando fazer é dentro do servidor ou é de outra máquina para o servidor?   Se for a segunda opção verifique se o serviço SQL Browser está ativo.   Outro ponto, vá em Iniciar / Executar, digite: CLICONFG. Nesta tela veja se os protocolos estão habilitados (à direita) e habilite a flag "Ativar protocolo de memória compartilhada".   Conecte-se no SSMS como SA. Vá nas propriedades da instância, guia "Security" e verifique se está habilitado o item SQL Server and Windows authentication mode.   Uma ultima analise é criar uma exceção no firewall para as portas TCP 1433 ou a porta UDP 1434   Veja isso ajuda.   Att.,   Marco.

Fernando Moraes
   - 10 jul 2011

me parece que isto vá resolver o problema, pois aconteceu na empresa onde trabalho, vou checar na segundona brava... rsrs
mas pelo que vi aqui em minha máquina, pelo cliconfg, o utilitário de rede do SQL Server, os protocolos: pipes e tcp/ip estavam desabilitados (lado esquerdo) e coloquei-os para habilitados na ordem, pipes e tcp, e habilitei o protocolo de memória compartilhada.

valeu, dpois eu posto a resposta...