Array
(
)

Fiz M.. e preciso agora consertar

Pjava
   - 10 jan 2013

Pessoal, usando Entity em meu projeto, criei meu EDMX. Bem, conforme eu postei em outro post, eu não estava conseguindo adicionar um determinada tabela, mas apenas ela, as demais foram adicionadas. Como eu não conseguia exito, consegui inserir depois um View criada depois e a tabela eu não consegui. Aí fiz o seguinte. Deletei o EDMX e criei outro Data Model. O que aconteceu? Agora meu sistema não acha a classe de entidade(MedicalServiceEntities) e claro não compila mais o meu projeto. Como eu resolvo isso? Abaixo parte do códico. O erro dá no using(MedicalServiceEntities). Como eu crio a classe de entidade? Eu fiz assim: Project >> Add New Item >> Ado.Net Entity Data Model, dei um nome pra ele(MedicalService), gerei apartir de um DataBase, selecionei as tabelas e views e finish. Mesmo assim, a tal tabela continua de fora e me dei mal. Como eu resolvo essa parada?
public void InserirUsuario(string nomeUsuario, string emailUsuario, string codigoAcesso, string tipoUsuario, int idGestor)
{
//MedicalServiceDataContext db = new MedicalServiceDataContext(conexao.Conexao());
using (MedicalServiceEntities mse = new MedicalServiceEntities())
{
try
{
TB_USUARIO usuario = new TB_USUARIO();
usuario.NOME_USUARIO = nomeUsuario;
usuario.EMAIL_USUARIO = emailUsuario;
usuario.CODIGO_ACESSO = codigoAcesso;
usuario.TIPO_USUARIO = tipoUsuario;
usuario.ID_GESTOR = idGestor;
mse.TB_USUARIO.AddObject(usuario);
mse.SaveChanges();
}


Pjava
   - 10 jan 2013

Pessoal, me desculpa, mas estava tão desesperado para resolver isso, pois precisava mostrar no Sprint View e postei sem antes parar, respirar e procurar o problema. É ele criou com outro nome, aí renomeei e agora tá ok. Desculpem-me pelo post apressado. Resolvido.

0
|
0

José
   - 31 jul 2013

Não tem problema, fique a vontade para abrir quantos forem necessário.
Tópico concluído.

0
|
0