Array
(
)

Já devemos usar o ASP.NET 5

Luiz Alves
   - 15 fev 2016

Já é indicado usar o ASP.NET 5? Tem os templates no Visual Studio, mas ainda como preview, então estou em dúvida se já é aconselhável criar novos projetos com essa versão.

Joel Rodrigues
   - 15 fev 2016

Olá, Luiz. Tudo bem?

A nível de estudos e preparação para futuras soluções, é interessante que você use o ASP.NET Core (mudou de nome). Já para projetos imediatos, ainda não é uma versão estável e não se deve utilizar ainda.

Luiz Alves
   - 15 fev 2016

Tudo bem sim Joel, posso apenas em nivel de conhecimento, por antecipação, sem problemas?

Joel Rodrigues
   - 15 fev 2016

Certamente.
Inclusive é bom destacar que o ASP.NET Core é um projeto Open Source e está disponível no GitHub.
Aqui na DevMedia já temos alguns artigos sobre essa nova versão, desde quando começou a ser anunciada. Veja no Guia de Referência de ASP.NET MVC.

Luiz Alves
   - 15 fev 2016

Que bom, já para adiantar os conhecimentos, agradeço Joel.

Rachel Andrade
   - 15 fev 2016

Já andei brincando com o novo ASP.NET e percebo que agora ele está mais perto de outras tecnologias mais "livres" como PHP. Você não precisa mais do Visual Studio para desenvolver, pode usar qualquer editor de texto e as ferramentas do console.

Fernanda Acacia
   - 15 fev 2016

Visual Studio 2015 Community tem haver? Está nele ou é em outra versão?

Joel Rodrigues
   - 16 fev 2016

Qualquer edição do Visual Studio 2015. No entanto, como a Rachel falou, não necessariamente você precisará usar o Visual Studio para criar projetos ASP.NET Core.

Fernanda Acacia
   - 16 fev 2016

Independente de IDE nesse caso? Eu gosto do VS.

Emilio Neto
   - 16 fev 2016

Sem a IDE VS? Mas tem que ter o .NET Framework não é?

Joel Rodrigues
   - 16 fev 2016


Citação:
Independente de IDE nesse caso? Eu gosto do VS.


Para o ASP.NET Core pode-se utilizar qualquer editor de texto, o que reforça a sua características multiplataforma. No entanto, para usuários do Windows, muita gente não vai querer abrir mão do Visual Studio, o que é compreensível.

Joel Rodrigues
   - 16 fev 2016


Citação:
Sem a IDE VS? Mas tem que ter o .NET Framework não é?


Sim, o .NET Framework continua sendo necessário, no entanto há agora uma versão reduzida e multiplataforma chamada .NET Core.

Emilio Neto
   - 16 fev 2016

Tenho que conhecer mais, estou bastante desatualizado, isso significa um mudança.

Fernanda Acacia
   - 16 fev 2016


Citação:
Para o ASP.NET Core pode-se utilizar qualquer editor de texto, o que reforça a sua características multiplataforma. No entanto, para usuários do Windows, muita gente não vai querer abrir mão do Visual Studio, o que é compreensível.


Verdade.

Luiz Alves
   - 17 fev 2016

Pessoal muito obrigado: Joel, Raquel pelas respostas, Emilio e Fernanda por acrescentarem mais duvidas.