Array
(
)

O módulo não foi implantado.

Rafael Barreto
   - 01 out 2013

olá estou começando a desenvolver para web, e deu o seguinte erro, ja pesquisei por todo lugar e não achei a solução... se puderem me ajudar, ficarei mt grato.... D:\NetBeansProjects\Ecommerce\nbproject\build-impl.xml:1037: O módulo não foi implantado. Verifique o log do servidor para ver mais detalhes. abraços

Roselito Silva
   - 01 out 2013

Você já viu o log e também o que tem na linha 1037 do build-impl.xml?

0
|
0

Rafael Barreto
   - 01 out 2013

#Código linha 1037 <nbdeploy clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/> Implantação local em D:\NetBeansProjects\Ecommerce\build\web Initializing... deploy?DEFAULT=D:\NetBeansProjects\Ecommerce\build\web&name=Ecommerce&contextroot=/Ecommerce&force=true falhou em GlassFish Server Error occurred during deployment: Exception while deploying the app [Ecommerce] : Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.5.0.v20130507-3faac2b): org.eclipse.persistence.exceptions.DatabaseException Internal Exception: java.sql.SQLException: Error in allocating a connection. Cause: Connection could not be allocated because: Ocorreu uma falha de autenticação da conexão. Motivo: identificação do usuário ou senha inválida. Error Code: 0. Please see server.log for more details. D:\NetBeansProjects\Ecommerce\nbproject\build-impl.xml:1037: O módulo não foi implantado. Verifique o log do servidor para ver mais detalhes. FALHA NA CONSTRUÇÃO (tempo total: 20 segundos) tô meio perdido cara, primeira vez mexendo com web.... abraços

0
|
0

Roselito Silva
   - 01 out 2013

Olhando meio por cima, parece que você configurou um datasource no glassfish, mas o usuário ou a senha não conferem com o banco de dados. Sugestão? Se você está iniciando, rode no Tomcat até pegar o jeito, porque o Glassfish é meio nojento com esses datasources. Veja algum tutorial sobre configurar a conexão com o BD usando o Tomcat, que funciona bem.

0
|
0

Rafael Barreto
   - 01 out 2013

vou dar uma olhada aqui amigão, valeu mesmo pela ajuda, vc foi o unico... abraços

0
|
0

Eriton Santos
   - 27 set 2016


Citação:
="rafa2012"]olá estou começando a desenvolver para web, e deu o seguinte erro, ja pesquisei por todo lugar e não achei a solução... se puderem me ajudar, ficarei mt grato.... D:\NetBeansProjects\Ecommerce\nbproject\build-impl.xml:1037: O módulo não foi implantado. Verifique o log do servidor para ver mais detalhes. abraços
Você precisa checar as anotações das Servlets. A anotação das Servlets deve seguir esse padrão: #Código @WebServlet(name = "Servlet", urlPatterns = {"/Servlet"}) Essa anotações ficará acima da declaração da sua classe. (public class ...)

0
|
0