Array
(
)

Sumiu meu TPRINCIPAL.PAS ...

Seven
   - 01 set 2004

alo !?

pelo desesperadamente... a ajuda de vcs...

eh que estava trabalhando normalmente...
e alterando um sisteminha que soh tinha uma tela, porem muito trabalhoso...

do nada... comecei a dar o F9-RUN para verificar uma pequena alteração... e estava testando.. funcionando perfeitamente...
mudando uma coisa aqui, outra alih...
de repente... clico vou no RUN... e o sistema abre sem as alterações que havia feito...
achei estranho... porem... continuei...
F9 nele... e nada... daih fechei o projeto... quando fui abri-lo...
ele acusa que o arquivo TPRINCIPAL.PAS nao existe mais...
nunca vih algo parecido... Alguem jah !?

ficou uns arquivos... entre eles... o TPRINCIPAL.DCU !
acredito que o (TPRINCIPAL.PAS nunca mais conseguirei recuperar)... tem alguma forma de eu recuperar alguma coisa atraves desse arquivo (TPRINCIPAL.DCU) !?

se alguem puder me ajudar...
desde ja agradeço
Arielton Lima

Título editado pelo Moderador (AZ) - Removido: ´DESESPERADO !!! ´


Seven
   - 01 set 2004

bom pessoal...
passei a manha toda pesquisando sobre o assunto...

e cheguei a conclusão que vou ter que refazer todo o codigo...
eh um sisteminha bem simples...
discador / transferencia de movimento via .TXT...
mas putz... da um trabalho da p.......................

eu soh queria saber se alguem ja passou por isso... e o que fazer !...
pois se isso acontecer com outros projetos que tenho... estou f.....

mesmo sempre fazendo backup...
como vou saber a hora que vai dar pau no meu projeto...

se alguem puder fazer seu comentario... (se ja aconteceu com vc)...
desde ja agradeço...
até +

P.S.: uso aqui WINDOWS 2000... talvez tenha sido pau nesse lixo de maquina... e de repente... procurando nos escombros do meu H.D. naum posso achar nada, neh. MAS QUE AZARRRRRRRRRRRRRRRRRRRRRRRR


Aroldo Zanela
   - 01 set 2004

Colega,

Trabalho com Delphi há alguns anos e nunca tive problema semelhante. É importante lembrar que o Delphi mantém backup a cada salvamento que você faz, ou seja, além de não ter possibilidade ´dele´ ter evaporado com seu código, você deve ter na máquina um arquivo com a extensão: *. ~???.
Utilize a opção ´Pesquisar´ em toda a sua máquina, pois o que pode ter acontecido é você ter salvado em algum outro lugar. Procure também usando o argumento *.~???.


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

Aroldo...

obrigado pela dica...
porem,
realmente tem um arquivo tprincipal.~???

mas nao consegui sucesso...

acho que pode ter sido alguma coisa do tipo: virus ou pau no windows mesmo... sei lah... H.D.

realmente eh dificil acreditar que isso tenha acontecido comigo... logo numa coisa que eu preciso com tanta urgencia... e eh tão chato de fazer...

o estranho eh que quando eu vih que compilava e não afetava no .EXE... ainda estava com o projeto aberto (em perfeito estado)... desesperador mesmo.

ja mandei localizar por: Tprincipal ..
tb em todos os arquivos que contiam algum texto com palavras que soh tinha nesse arquivo... sem sucesso.

assim que chegar em casa vou verificar mais uma vez... dando atenção para o que vc descreveu.. mas ja estou desanimado...

mesmo assim... obrigado
[]s


Seven
   - 01 set 2004

foi mal...
TAVA DANDO ERRO ... e achei que a mensagem não estava sendo enviada.

até