Como configurar Proxy Reverso no Linux Slackware com Grafana?

23/02/2021

3

Em /etc/httpd/extra/httpd-ssl.conf deixei assim:

<VirtualHost _default_:443>

#   General setup for the virtual host
DocumentRoot "/srv/httpd/htdocs"
ServerName myu.com:443
ErrorLog "/var/log/httpd/error_log"
TransferLog "/var/log/httpd/access_log"

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on


<Location /grafana/>
   ProxyPreserveHost On
   ProxyPass https://127.0.0.1:3000/
   ProxyPassReverse https://127.0.0.1:3000/

   SSLRequireSSL
   AuthType basic
   AuthBasicProvider ldap
   AuthName "Restrict Access"
   AuthLDAPBindDN cn=apacheldap,ou=DSA,dc=myu,dc=com
   AuthLDAPBindPassword <password>
   AuthLDAPURL ldap://ldap.myu.com:389/ou=people,dc=myu,dc=com?uid?one TLS
   AuthLDAPGroupAttribute memberUid
   AuthLDAPGroupAttributeIsDN off
   Require ldap-group cn=restrictintranet,ou=groups,dc=myu,dc=com
</Location>



E no Grafana, assim:

[server]
# Protocol (http, https, h2, socket)
protocol = https

# The ip address to bind to, empty will bind to all interfaces
http_addr = 127.0.0.1

# The http port  to use
http_port = 3000

# The public facing domain name used to access grafana from a browser
domain = myu.com

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
;enforce_domain = false

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
root_url = %(protocol)s://%(domain)s:%(http_port)s/grafana/

# Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
serve_from_sub_path = true


No entando, ao tentar acessar https://myu.com/grafana diz que a URL não foi encontrada.
Cesar Murilo

Cesar Murilo

Responder

Posts

25/02/2021

Cesar Murilo

Em /etc/httpd/extra/httpd-ssl.conf deixei assim:

<VirtualHost _default_:443>

#   General setup for the virtual host
DocumentRoot "/srv/httpd/htdocs"
ServerName myu.com:443
ErrorLog "/var/log/httpd/error_log"
TransferLog "/var/log/httpd/access_log"

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on


<Location /grafana/>
   ProxyPreserveHost On
   ProxyPass https://127.0.0.1:3000/
   ProxyPassReverse https://127.0.0.1:3000/

   SSLRequireSSL
   AuthType basic
   AuthBasicProvider ldap
   AuthName "Restrict Access"
   AuthLDAPBindDN cn=apacheldap,ou=DSA,dc=myu,dc=com
   AuthLDAPBindPassword <password>
   AuthLDAPURL ldap://ldap.myu.com:389/ou=people,dc=myu,dc=com?uid?one TLS
   AuthLDAPGroupAttribute memberUid
   AuthLDAPGroupAttributeIsDN off
   Require ldap-group cn=restrictintranet,ou=groups,dc=myu,dc=com
</Location>



E no Grafana, assim:

[server]
# Protocol (http, https, h2, socket)
protocol = https

# The ip address to bind to, empty will bind to all interfaces
http_addr = 127.0.0.1

# The http port  to use
http_port = 3000

# The public facing domain name used to access grafana from a browser
domain = myu.com

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
;enforce_domain = false

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
root_url = %(protocol)s://%(domain)s:%(http_port)s/grafana/

# Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
serve_from_sub_path = true


No entando, ao tentar acessar https://myu.com/grafana diz que a URL não foi encontrada.


Consegui resolver. Solução aqui: https://www.linuxquestions.org/questions/showthread.php?p=6224347#post6224347
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar