Conexão Servidor ao WorkBech

20/01/2019

7

Bom dia,

Estou tentando criar um servidor MySQL com o sistema operacional Ubuntu-server 16.04, porem não consigo conectar o mysql workbench ao servidor.

Obs:
Consigo ter acesso ao Mysql via SSH e pelo PHPMYADMIN. Porém necessito da conexão com o WorkBench.

Desde já agradeço a ajuda!!
Responder

Posts

Bom dia,

Mas o que acontece, conseguiu intalar o workbench? vc está tentando usar o workbench no Linux?

se puder posta o erro...

abraço,
Responder

20/01/2019

Andre

O servidor em que o Mysql-server esta instalado é Linux e estou tentando conectar ele no Linux quanto no Linux. Sendo que estão todos em rede local


> Esse erro acontece quando tento conectar com ele direto pela caixa que fica disponível na tela principal
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Cannot Connect to Database Server

Your connection attempt failed for user 'root' from your host to server at 192.168.0.54:3306:
Can't connect to MySQL server on '192.168.0.54' (113)

Please:
1 Check that mysql is running on server 192.168.0.54
2 Check that mysql is running on port 3306 (note: 3306 is the default, but this can be changed)
3 Check the root has rights to connect to 192.168.0.54 from your address (mysql rights define what clients can connect to the server and from which machines)
4 Make sure you are both providing a password if needed and using the correct password for 192.168.0.54 connecting from the host address you're connecting from
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Responder
Já viu se não esta bloqueado para conexão externa? Uso o slackware e é preciso fazer a liberação. No slackware o procedimento é o seguinte:

1 - No arquivo:
/etc/rc.d/rc.mysqld

Comentar a linha
# SKIP="--skip-networking"

2 - Reiniciar o servidor

3 - No MySql:
mysql -u root nomedobanco

use mysql;

GRANT ALL ON *.* TO 'root'@'%' IDENTIFIED BY 'senha' WITH GRANT OPTION;

flush privileges;

Talvez seja preciso reiniciar novamente.
Responder

10/02/2019

Andre

Boa Tarde,


Venho agradecer a ajuda de todos, pois acabo de solucionar o problema de conexão.


A solução foi executar os seguintes comandos


vim /etc/mysql/mysql.conf.d/mysqld.cnf

e na linha 28 alterar o ip local para o ip do seu servidor

bind-address = ipnarede:3306
Responder