LÓGICA DE PROGRAMAÇÃO PARA CÁLCULO DO IRRF ATRAVÉS DO VALOR LÍQUIDO.

12/10/2019

10

Olá Pessoal, estou há dias tentando realizar por formula aritmética o calculo reverso do IRRF através do valor líquido, mas sem sucesso!!!

Preciso saber qual o Valor do IRRF de uma operação que tributa o mesmo, sendo essa operação qualquer: Folha de pagamento, Contrato de Câmbio, Lucro, Operações no Mercado Financeiro e etc.

-Partindo do princípio que eu tenha apenas a informação do Valor Líquido, como chegar ao exato do IRRF descontado?
-Sei que é preciso programar um loop (while, for(qualquer linguagem)) para ir testando os valores, até dar o resultado exato.
-Já vi isso funcionando em um sistema, quanto maior o valor, mais tempo demora para trazer o resultado do IRRF.
-Tabela de IRRF Atual:

DE ATÉ % DEDUÇÃO
R$ 1.903,99 R$ 2.826,65 7,50 R$ 142,80
R$ 2.826,66 R$ 3.751,05 15,00 R$ 354,80
R$ 3.751,06 R$ 4.664,68 22,50 R$ 636,13
R$ 4.664,68 Infinito 27,50 R$ 869,36

Alguém pode me ajudar? Desde já muito obrigado!
Responder

Posts

01/12/2019

Gustavo

Vitor, boa tarde.
Você pode colocar essa tabela em uma sheet separada e trabalhar com procv para ficar mais fácil de atualizar, mas caso precise de uma solução mais simples você pode colocar vários SE's em uma única fórmula. Segue o exemplo abaixo. Para utiliza-lo, cole a fórmula na célula B1 e coloque o valor líquido na célula A1 da mesma planilha:
=SE(A1>4664,68;A1*0,275-869,36;SE(A1>3751,05;A1*0,225-636,13;SE(A1>2826,65;A1*0,15-354,8;SE(A1>1903,98;A1*0,075-142,8;0))))

Explicando:
A primeira verificação:
Valor líquido é maior que R$4.664,68?
Se sim aplique a fórmula Valor Líquido * 27,5% (no caso 0,275) - 869,36.
Se não aplique a segunda verificação.

Segunda verificação:
Valor líquido é maior que R$3.751,05?
Se sim aplique a fórmula Valor Líquido * 22,5% (no caso 0,225) - 636,13.
Se não aplique a terceira verificação.

Terceira verificação:
Valor líquido é maior que R$2.826,65?
Se sim aplique a fórmula Valor Líquido * 15% (no caso 0,15) - 354,80.
Se não aplique a quarta verificação.

Quarta verificação:
Valor líquido é maior que R$1.903,98?
Se sim aplique a fórmula Valor Líquido * 7,5% (no caso 0,075) - 142,8.
Se não informe 0 (isento).

Espero que tenha ajudado.
Atenciosamente.
Gustavo

Responder