Por que eu devo ler este artigo:Este artigo apresenta os conceitos fundamentais para a implantação de redes IP multicast, tecnologia que suporta as transmissões de fluxos de dados para grupos de usuários de maneira mais eficiente que as comunicações tradicionais unicast.

Frequentemente, o IP multicast é utilizado pelas novas aplicações da Internet, tais como: IPTV, videoconferência, ensino a distância, entre outras. Serão detalhados diversos cenários com o objetivo de suportar a implementação deste recurso em redes de computadores com características distintas, desde as mais simples, àquelas que necessitam de uma arquitetura escalável e redundante. Os exemplos de configuração expostos serão baseados na plataforma de roteadores da Cisco Systems, popular fornecedor de hardware para as infraestruturas de dados.

As redes IP (Internet Protocol) convencionais permitem que um dispositivo qualquer (servidores, desktops, equipamentos móveis, roteadores, firewalls, entre outros) envie fluxos de dados para outro componente por meio da comunicação unicast. Opcionalmente, estas encaminham os pacotes IP para todos os outros elementos conectados à rede por intermédio da transmissão via broadcast.

Este artigo descreve uma terceira alternativa, denominada multicast, que suporta o envio do fluxo de dados de um dispositivo para um conjunto de equipamentos simultaneamente. A principal vantagem desta estratégia é o uso mais eficiente da largura de banda disponível nas infraestruturas de dados. Diferentemente da tradicional comunicação unicast, na qual o consumo de recursos é proporcional à quantidade de usuários que desejam receber certo conteúdo, as transmissões multicast demandam a largura de banda necessária para encaminhar um único fluxo de dados.

A primeira parte deste artigo revisará alguns conceitos básicos para a compreensão dos aspectos mais comuns da implantação do multicast nas redes de computadores. Portanto, será exposto o funcionamento das redes IP unicast e multicast por meio de um enfoque comparativo.

Em seguida, será contextualizado o Internet Group Management Protocol (IGMP), principal protocolo responsável por informar aos roteadores a presença de usuários interessados em participar de um grupo. Também será descrito o conjunto de endereços IP versão 4 reservados para o uso nas comunicações multicast, destacando como estes foram organizados. Finalmente, será abordado o Protocol Independent Multicast (PIM), elemento que possui a função de encaminhar os pacotes de dados entre os roteadores da infraestrutura.

É importante lembrar que esta parte inicial do artigo não possui o objetivo de revisar detalhadamente todas as características da tecnologia IP multicast, mas apenas rever os fundamentos necessários ao entendimento dos cenários de implantação que serão detalhados nas seções seguintes. Para mais informações sobre as redes IP multicast, recomenda-se a leitura do artigo “Redes IP Multicast”, publicado na Revista Infra Magazine 5.

Diferentes cenários de implantação do IP multicast serão descritos na segunda parte deste artigo, a qual detalha os comandos necessários à configuração destes exemplos em equipamentos da Cisco Systems. Assim, serão detalhadas as topologias comumente utilizadas em redes menores, envolvendo os modos de operação do Protocol Independent Multicast em Dense Mode e em Sparse Mode.

Por fim, serão apresentadas as situações indicadas para as maiores e mais complexas redes, empregando o Protocol Independent Multicast em Sparse Mode com eleição dinâmica do rendezvous point (RP), roteador que possui a função de tratar as requisições iniciais dos usuários em uma rede multicast. Nestes últimos exemplos serão evidenciadas as principais características das soluções propostas que suportarão infraestruturas escaláveis e redundantes.

Conceitos básicos das redes IP multicast

As redes IP multicast possibilitam a redução do tráfego de dados por meio da transmissão de um único fluxo de informações para diversos usuários. Entre as aplicações que podem se beneficiar desta tecnologia, destacam-se aquelas relacionadas à videoconferência, ao ensino a distância, à distribuição de softwares, à divulgação de notícias, entre outras.

Segundo o artigo IP Multicast Technology Overview, publicado pela Cisco Systems, o IP multicast reduz a utilização da largura de banda das redes porque replica os pacotes somente para os roteadores e switches que possuem clientes diretamente conectados. O remetente das informações encaminha uma única cópia do conteúdo para todos os usuários que desejam recebê-la.

Potencialmente, as redes IP multicast podem suportar milhares de clientes simultaneamente. A Figura 1 exemplifica um servidor de uma aplicação de ensino a distância que envia um único fluxo de dados para três clientes localizados em redes diferentes (A, B e C). É importante observar que, caso esta tecnologia não fosse empregada, seriam necessárias três cópias dos pacotes IPs. Consequentemente, haveria um uso menos eficiente da largura de banda na infraestrutura de rede (Figura 2).

Figura 1. Exemplo do fluxo de dados em uma rede IP multicast.

Figura 2. Exemplo do fluxo de dados em uma rede IP unicast.

Os clientes interessados em receber o conteúdo da aplicação de ensino a distância utilizam o Internet Group Management Protocol (IGMP) para ingressar no grupo multicast. Já os roteadores podem empregar diversos protocolos para gerenciar a árvore de distribuição multicast, a qual assegura o encaminhamento do fluxo de dados somente para os segmentos de rede que estiverem entre a origem e os destinatários do conteúdo. Entre os protocolos mais conhecidos, o Protocol Independent Multicast (PIM) é a alternativa mais utilizada. Neste contexto, além deste protocolo, o IGMP e os grupos multicast serão detalhados sucintamente nas próximas seções.

Grupos multicast

Um grupo multicast é um conjunto arbitrário de destinatários que expressam seu interesse em receber um determinado fluxo de dados. Não possui restrições físicas ou geográficas, dado que os usuários podem estar localizados em qualquer lugar na Internet e para se registrarem no grupo que desejam participar, basta utilizarem o IGMP.

Quando estão configurados para suportar o IGMP, os roteadores processam as mensagens de ingresso nas redes multicast e enviam consultas periódicas a fim de identificar os grupos ativos e inativos nos segmentos nos quais estão inseridos. O IGMPv2 (Internet Group Management Protocol version 2) é a especificação mais utilizada pelos dispositivos clientes. Esta versão define quatro tipos de mensagens:

· Membership report version 2: enviadas por aqueles que almejam receber o tráfego de um determinado grupo;

· Membership report version 1: empregadas primariamente para a manutenção do suporte da versão anterior. Também são utilizadas para ingresso nos grupos;

· Membership query: encaminhada pelos roteadores para identificar proativamente os usuários interessados em participar dos grupos. Se não forem observadas respostas após três consultas consecutivas, o roteador encerrará a transmissão dos fluxos de informações para estes grupos;

· Leave group: utilizada pelos dispositivos clientes para manifestar seu interesse em sair de um determinado grupo.

A Figura 3 ilustra um cliente enviando uma mensagem IGMP membership report para se registrar no endereço multicast 239.0.0.100, ou seja, informando seu interesse em receber os pacotes designados a este grupo. O roteador, após recebê-la, passa a encaminhar o fluxo de dados ao usuário.

Figura 3. Registro no grupo 239.0.0.100 por meio do IGMP membership report.

Endereços IP multicast

A Internet Assigned Numbers Authority (IANA), entidade que administra os recursos de numeração do IPv4 (Internet Protocol version 4), reservou a faixa de endereços 224.0.0.0 até 239.255.255.255 para atribuição aos grupos multicast, conforme as categorias a seguir:

· Reserved Link Local Addresses: conjunto de endereços alocados para uso exclusivo de protocolos de rede nos segmentos locais (224.0.0.0 a 224.0.0.255);

· Globally Scoped Addresses: utilizados para a comunicação de grupos multicast localizados em diferentes empresas por intermédio da Internet (224.0.1.0 a 238.255.255.255);

· Limited Scope Addresses: especificados para grupos multicast que possuem abrangência local ou organizacional. Portanto, não são transmitidos pelos roteadores para outras empresas – geralmente são conhecidos como endereços privados (239.0.0.0 a 239.255.255.255).

Protocol Independent Multicast (PIM)

Este protocolo suporta o roteamento de pacotes IP multicast de forma independente do roteamento unicast utilizado na infraestrutura de rede, ou seja, pode ser configurado concomitantemente ao Enhanced Interior Gateway Routing Protocol (EIGRP), ao Open Shortest Path First (OSPF), ao Border Gateway Protocol (BGP), às rotas estáticas, entre outras abordagens para a definição das políticas de encaminhamento do tráfego de dados. A implementação do PIM pode seguir duas vertentes distintas:

· PIM Dense Mode (PIM DM): emprega um modelo conhecido como push, no qual os pacotes multicast são encaminhados para todos os roteadores.

Estes, por sua vez, solicitam o cancelamento do envio dos dados quando não possuem nenhum cliente registrado nos grupos. O PIM DM é recomendado quando os destinatários dos fluxos estão conectados em todos os segmentos da rede;

· PIM Sparse Mode (PIM SM): utiliza o modelo denominado pull, no qual o tráfego multicast será enviado somente para os segmentos de rede com clientes ativos que tenham explicitamente requerido tal fluxo IP. Esta característica requer, ao menos inicialmente, a definição de um roteador com a função de tratar as requisições dos usuários da rede IP multicast. Conhecido como rendezvous point (RP), este deve ser configurado em todas as infraestruturas baseadas no PIM SM.

Cenários de implantação do IP multicast

As seções a seguir contemplarão diversos cenários que pretendem auxiliar a compreensão das diferentes abordagens de implantação das redes IP multicast. Embora embasados em equipamentos da Cisco Systems, não estão limitados a versões de software ou hardware especificas, pois buscam ser abrangentes para suportarem as mais distintas necessidades dos profissionais da área de redes. Mais detalhes podem ser obtidos diretamente nos documentos publicados pelo fornecedor destas soluções. As próximas seções descreverão as seguintes topologias e enfoques de configuração:

· PIM Dense Mode;

· PIM Sparse Mode com um único RP;

· PIM Sparse Mode com múltiplos RPs;

· PIM Sparse-Dense Mode;

· PIM SM com configuração dinâmica do RP (Auto-RP);

· PIM SM com configuração dinâmica do RP (BSR Protocol).

PIM Dense Mode

Segundo o artigo Multicast Quick−Start Configuration Guide, publicado pela Cisco Systems, para configurar o PIM DM, será necessário habilitar o roteamento multicast, por meio do comando ip multicast−routing. Para cada interface que processará os pacotes multicast, também deve ser aplicada a instrução ip pim dense-mode.

Este cenário é ilustrado na Figura 4, que apresenta dois roteadores interligados por um enlace gigabit ethernet (1000 Mbps). No roteador A, está conectado o servidor do conteúdo multicast; já o cliente está localizado no segmento local do roteador B. A Listagem 1 detalha os comandos que devem ser inseridos para a configuração destes equipamentos.

Figura 4. Cenário para a configuração do PIM Dense Mode.

Listagem 1. Comandos para a configuração do PIM Dense Mode.


  //CONFIGURAÇÃO DO ROTEADOR A
  ip multicast-routing
   
  interface Gi 1/0
  ip address 192.168.0.1 255.255.255.0
  ip pim dense-mode
   
  interface Gi 1/1
  ip address 10.0.0.1 255.255.255.252
  ip pim dense-mode
   
  //CONFIGURAÇÃO DO ROTEADOR B
  ip multicast-routing
   
  interface Gi 1/0
  ip address 192.168.1.1 255.255.255.0
  ip pim dense-mode
   
  interface Gi 1/1
  ip address 1.0.0.2 255.266.255.252
  ip pim dense-mode

É importante observar que todos os IPs das interfaces dos roteadores A e B pertencem à classe de endereços unicast. Servidor e cliente também estão configurados com IPs deste grupo (redes 192.168.0.0/24 e 192.168.1.0/24, respectivamente).

Assim, é importante notar que somente se utiliza os endereços multicast nos pacotes gerados pelo servidor com destino ao grupo (por exemplo, 239.0.0.100) e nas mensagens IGMP membership report originadas pelo cliente para indicar seu interesse em receber estes fluxos.

PIM Sparse Mode com um único RP

Neste exemplo, baseado no artigo Multicast Quick−Start Configuration Guide, divulgado pela Cisco Systems, um dos roteadores será definido manualmente como o RP. Este método estático requer que os demais roteadores no domínio de roteamento PIM SM sejam configurados com o comando ip pim rp−address.

A Figura 5 detalha um mapa de rede composto por dois roteadores operando em modo esparso e interligados por um enlace gigabit ethernet (1000 Mbps). O servidor com a aplicação multicast está alocado no segmento de rede local do roteador A; já o cliente, no roteador B. Finalmente, a Listagem 2 descreve a configuração necessária para a implantação deste cenário.

Figura 5. Cenário para a configuração do PIM Sparse Mode.


   
  Listagem 2. Comandos para a configuração do PIM Sparse Mode.
  //CONFIGURAÇÃO DO ROTEADOR A
  ip multicast-routing
  ip pim rp-address 10.0.0.1
   
  interface Gi 1/0
  ip address 192.168.0.1 255.255.255.0
  ip pim sparse-mode
   
  interface Gi 1/1
  ip address 10.0.0.1 255.255.255.252
  ip pim sparse-mode
   
  //CONFIGURAÇÃO DO ROTEADOR B
  ip multicast-routing
  ip pim rp-address 10.0.0.1
   
  interface Gi 1/0
  ip address 192.168.1.1 255.255.255.0
  ip pim sparse-mode
   
  interface Gi 1/1
  ip address 10.0.0.2 255.255.255.252
  ip pim sparse-mode

É importante destacar que nesta abordagem o cliente deverá notificar explicitamente a infraestrutura sobre seu interesse em receber o tráfego para um determinando grupo multicast por meio de uma mensagem IGMP membership report. Geralmente, esta alternativa é a mais indicada, pois na maior parte das redes os usuários estão distribuídos de forma esparsa, o que torna o uso da largura de banda disponível mais eficiente.

PIM Sparse Mode com múltiplos RPs

Na topologia exposta na Figura 6 (referenciada no artigo Multicast Quick−Start Configuration Guide, publicado pela Cisco Systems), foram especificados dois servidores de aplicações multicast: o primeiro (A), dissemina o conteúdo para os grupos 224.1.1.10 e 224.1.1.11; já o segundo (B), atende aos usuários registrados nos IPs 224.2.2.20 e 224.2.2.21.

Os clientes 1, 2, e 3 estão esparsamente distribuídos na rede local onde estão conectados os roteadores C e D. Para ativar dois ou mais RPs estáticos e alocar os grupos multicast entre os mesmos, será necessário configurar todos os roteadores do domínio PIM SM com a instrução ip pim rp−address <address> <acl>, na qual <address> representa o endereço do RP e <acl> associa uma lista com os grupos ao rendezvous point.

Figura 6. Cenário para a configuração do PIM Sparse Mode com múltiplos RPs.

Os comandos necessários à configuração de todos os roteadores estão indicados na Listagem 3. Estes omitem as instruções necessárias para a definição dos endereços IP das interfaces e sua configuração como PIM SM, visto que estes pontos já foram detalhados nas seções anteriores. Também é importante assegurar que o roteamento unicast foi implementado corretamente, pois todos os roteadores devem possuir conectividade com os endereços IP atribuídos aos RPs.

Listagem 3. Comandos para a configuração do PIM Sparse Mode com múltiplos RPs.


  //CONFIGURAÇÃO DOS ROTEADORES A, B, C e D
  ip multicast-routing
   
  ip pim RP-address 1.1.1.1 10
  ip pim RP-address 2.2.2.2 10
   
  access-list 10 permit 224.1.1.10
  access-list 10 permit 224.1.1.11
   
  access-list 20 permit 224.2.2.20
  access-list 20 permit 224.2.2.21

PIM Sparse-Dense Mode

O PIM sparse-dense mode é uma extensão do PIM SM que habilita o PIM DM para todos os grupos multicast para os quais não há um RP configurado (conforme o artigo Configuring PIM-SM and PIM Sparse-Dense Mode, disponibilizado por Justin Menga). Este cenário pode ocorrer quando todas as interfaces de um roteador são especificadas no modo esparso (ip pim sparse-mode). Neste caso, ao receber o tráfego multicast para um grupo não mapeado, este será descartado, pois não há rendezvous point conhecido.

Nos exemplos discorridos nas seções anteriores, a situação citada não ocorreu, porque a instrução que identifica o RP foi adicionada em cada um dos roteadores. Entretanto, a operação em modo esparso passa a apresentar dificuldades quando são habilitados protocolos de aprendizagem dinâmica dos RPs, ao invés da configuração manual, porquanto estes utilizam pacotes multicast para o envio de suas mensagens de controle.

Tal fato gera um problema curioso: um roteador precisa conhecer pelo menos um RP para encaminhar o tráfego multicast, mas os protocolos utilizados para anunciar a localização dos rendezvous points são baseados em comunicações multicast.

Uma solução possível para este caso é o uso do PIM DM para os protocolos que anunciam os RPs, ou seja, estas comunicações serão enviadas para todos os segmentos de rede locais. Contudo, este modo de operação não possibilita os benefícios do PIM SM detalhados nas seções anteriores.

Assim, surgiu o PIM sparse-dense mode, que mescla as funcionalidades de ambos os protocolos: comporta-se como PIM DM para os grupos não associados a um RP, e, opcionalmente, como PIM SM para os grupos associados a um rendezvous point. A Listagem 4 apresenta o comando para a configuração de uma interface no modo sparse-dense. É importante destacar que a Cisco Systems sugere o uso deste enfoque, pois desta forma eliminam-se as situações em que os fluxos multicast são descartados.

Listagem 4. Comando para a configuração do PIM Sparse-Dense Mode.


  ip pim sparse-dense-mode

PIM SM com configuração dinâmica do RP (Auto-RP)

Nos cenários explorados até agora, todos os roteadores multicast foram configurados manualmente com o RP. Este processo é frequentemente adotado pelos administradores de pequenas redes. No entanto, os profissionais que atuam em grandes infraestruturas, com diversos rendezvous points organizados por grupos, geralmente utilizam protocolos dinâmicos para a manutenção dos RPs, pois estes reduzem as atividades operacionais e a probabilidade de erros na configuração.

Segundo o artigo Configuring PIM-SM and PIM Sparse-Dense Mode, publicado por Justin Menga, Auto-RP é um recurso proprietário da Cisco Systems que introduz os mapping agents, denominação atribuída aos roteadores que aguardam as mensagens enviadas para um grupo multicast chamado Cisco-RP-Announce (224.0.1.39).

Os dispositivos definidos com RP divulgam sua presença por meio de mensagens RP-Announce, que possuem o endereço do rendezvous point e de seus grupos associados. Ao recebê-las, o mapping agent armazena as informações em seu cache local e as retransmite em mensagens multicast RP Discovery encaminhadas para o grupo Cisco-RP-Discovery (224.0.1.40).

Como todos os roteadores da Cisco Systems que possuem a funcionalidade de multicast habilitada se registram neste grupo, estes recebem automaticamente as informações dos RPs e dos grupos mapeados a cada um deles.

Na Figura 7, como o roteador E foi configurado como RP, este envia as mensagens RP-Announce para o grupo multicast 224.0.1.39. Já o equipamento D foi definido como um mapping agent, dispositivo responsável pela propagação das informações aprendidas para todos os demais roteadores do domínio PIM por intermédio das mensagens RP-Discovery.

A configuração do modo PIM sparse-dense é mandatória, pois permitirá a inundação das mensagens RP-Announce e RP-Discovery para os roteadores da rede, assegurando que todos aprendam dinamicamente o endereço IP do rendezvous point e dos grupos mapeados.

Figura 7. Cenário para a configuração do PIM SM com Auto-RP.

Supondo que a topologia da Figura 7 foi configurada para operar no modo PIM sparse-dense, conforme indicado na seção anterior, para habilitar o Auto-RP será necessário configurar os roteadores multicast candidatos a RP e o mapping agent.

Ao especificar o roteador E como RP, este equipamento encaminhará periodicamente as mensagens RP-Announce para o grupo 224.0.1.39, indicando seu endereço IP e os grupos que serão atendidos. Para configurá-lo, basta empregar o comando ip pim send-rp-announce <interface> scope <ttl> group-list <acl> interval <tempo>.

O parâmetro <interface> define qual interface do roteador será utilizada para gerar as mensagens multicast. Comumente, recomenda-se o uso de interfaces de loopback, pois estas são lógicas e permanecem sempre ativas, diferentemente das interfaces físicas, que dependem de uma conexão operacional com outro dispositivo.

O campo time-to-live <ttl> permite controlar o escopo dos pacotes multicast. Este foi criado com o intuito de evitar que, principalmente em decorrência de problemas de roteamento, um pacote seja transmitido indefinidamente pela rede.

Destarte, o valor do <ttl> é decrementado em uma unidade, em cada roteador pelo qual o pacote atravessa, sendo descartado ao atingir o valor zero. É importante garantir que seu valor seja suficiente para que a mensagem alcance todos os mapping agents especificados.

Já o parâmetro <acl> possibilita a definição de quais serão os grupos atendidos pelo rendezvous point (no exemplo, grupos 239.1.1.1 e 239.1.1.2). A configuração de um conjunto maior de endereços multicast é uma prática comum, porque possibilita provisionar grupos para o uso futuro; neste cenário, todos os IPs da faixa 239.1.1.0/24 serão liberados.

Por fim, o campo <tempo> determina a periodicidade de envio das mensagens RP-Announce. Por padrão, estas são enviadas a cada 60 segundos. A Listagem 5 ilustra os comandos sugeridos para a configuração do roteador E como RP, habilitando o Auto-RP para o grupo 239.1.1.0/24. Cabe ainda destacar que, quando forem configurados múltiplos rendezvous points e estes atenderem aos mesmos grupos multicast, o RP com maior endereço IP será escolhido como primário. Este mecanismo suporta a criação de uma infraestrutura redundante, pois o roteador com o menor endereço IP atuará como backup nos eventos de falha do equipamento principal.

Listagem 5. Comandos para a configuração do RP.


  //CONFIGURAÇÃO DO ROTEADOR E (RP)
  interface Loopback 0
  ip address 10.10.10.10 255.255.255.255
  ip pim sparse-dense-mode
   
  ip pim send-rp-announce Loopback 0 scope 2 group-list 1
  access-list 1 permit 239.1.1.0 0.0.0.255

Em seguida, deve-se configurar o roteador D como um mapping agent. Desta forma, o mesmo gerará mensagens RP-Discovery em resposta aos pacotes RP-Announce. É fundamental relembrar que a hierarquia entre rendezvous points e mapping agents foi criada para assegurar a escalabilidade em grandes redes e o controle dos fluxos multicast no processo de aprendizagem dinâmica. Assim, para configurar o roteador D, deve-se inserir a instrução ip pim send-rp-discovery <interface> scope <ttl>.

As mesmas recomendações apresentadas na configuração do RP são válidas para a definição do mapping agent, ou seja, especificar uma interface lógica (<interface>) para gerar as mensagens RP-Discovery, evitando a interrupção no envio destes pacotes quando ocorrerem falhas nas interfaces físicas. A definição de um valor criterioso para o <ttl> também é uma prática que restringe o encaminhamento destes pacotes por toda a rede de dados. A Listagem 6 ilustra os comandos necessários para a configuração do roteador D.

Listagem 6. Comandos para a configuração do mapping agent.


  //CONFIGURAÇÃO DO ROTEADOR D (Mapping Agent)
  interface Loopback 0
  ip address 10.10.10.100 255.255.255.255
  ip pim sparse-dense-mode
   
  ip pim send-rp-directory Loopback 0 scope 2

PIM SM com configuração dinâmica do RP (BSR Protocol)

Conforme os artigos PIM Sparse Mode – BSR and Multicast Security, escrito por Laurent Prat, e, Understanding BSR Protocol, disponibilizado por Petr Lapukhov, bootstrap router ou BSR é um protocolo padronizado que se tornou disponível no PIMv2 (Protocol Independent Multicast version 2). Possui função similar ao Auto-RP exposto na seção anterior, ajudando no processo de divulgação dinâmica do RP.

Ambos utilizam o conceito de roteador candidato a rendezvous point, entretanto, o BSR não emprega a operação em PIM dense-mode para encaminhar o IP do RP e de seus grupos mapeados: estas informações são enviadas em mensagens incorporadas ao PIM, de roteador a roteador (hop-by-hop).

Assim, ao receber um pacote BSR em determinada interface, um roteador PIM SM inicialmente confirma em sua tabela de roteamento unicast se o remetente é acessível por este caminho e, em caso afirmativo, reencaminha para todas as demais interfaces configuradas no domínio multicast – este processo é conhecido como Reverse Path Forwarding (RPF).

Os BSRs recebem, armazenam e divulgam as mensagens dos RPs, executando um papel similar àquele realizado pelos mapping agents no Auto-RP. Para cada grupo multicast, estes roteadores constroem uma lista com todos os candidatos a rendezvous point. Esta matriz, contendo os grupos e os RPs é distribuída por intermédio de mensagens PIM para os demais equipamentos da infraestrutura. Basicamente, a operação dos roteadores PIM BSR ocorre em duas fases distintas:

1. Descoberta dos BSRs: cada dispositivo configurado com BSR divulga mensagens bootstrap, anunciando sua disponibilidade, e aguarda as mensagens de outros roteadores. Caso seja identificado um BSR com maior prioridade, as entidades configuradas com menor prioridade tornam-se backup, abdicando de sua função como BSR;

2. Descoberta dos RPs: neste momento, os RPs enviam ao BSR seu endereço IP e os grupos configurados via uma mensagem unicast.

O funcionamento detalhado de uma rede PIM SM configurada com o suporte ao protocolo BSR é apresentado na Figura 8:

1. Inicialmente, o roteador B envia mensagens BSR bootstrap para todos os roteadores da infraestrutura (no exemplo, roteadores A e C). É importante observar que, enquanto o RP (roteador C) não receber a mensagem do BSR, não será possível divulgar seu endereço IP e os grupos multicast mapeados;

2. O rendezvous point envia uma mensagem unicast diretamente para o BSR, informando seu endereço IP e os grupos que serão atendidos;

3. O roteador BSR recebe a mensagem e consolida as informações (quando existirem dados de outros RPs), transmitindo a matriz completa com todos os grupos e RPs disponíveis.

Figura 8. Cenário para a configuração do PIM SM com BSR protocol.

Para configurar o roteador B como BSR, será necessário inserir o comando ip pim bsr-candidate <interface> <hash-mask-length> <priority>. Conforme observado nas seções anteriores, é importante associar uma interface lógica ao parâmetro <interface>, pois esta será responsável por gerar todas as mensagens do protocolo BSR. O campo <hash-mask-length> define quantos bits do endereço IP multicast serão utilizados para realizar o balanceamento entre os RPs nos cenários em que múltiplos roteadores desempenharem esta função.

Por fim, <priority> é utilizado para eleger um BSR em um domínio PIM SM. A maior prioridade ou o endereço IP mais alto definirão o roteador BSR primário. A Listagem 7 descreve os comandos para a configuração do roteador B como BSR (o exemplo pressupõe que todos os equipamentos já foram configurados em modo PIM SM, conforme apresentado nas seções anteriores).

Listagem 7. Comandos para a configuração do BSR.


  //CONFIGURAÇÃO DO ROTEADOR B (BSR)
  interface Loopback 0
  ip address 10.10.10.100 255.255.255.255
  ip pim sparse-mode
   
  ip pim bsr-candidate Loopback 0 30 192

Já para definir o roteador C como rendezvous point, será utilizada a instrução ip pim rp-candidate <interface> group-list <acl> interval <tempo> priority <número>. O campo <interface> novamente deve ser associado a uma interface lógica para assegurar que não haja interrupção na transmissão dos fluxos multicast em uma eventual falha de uma conexão física.

O parâmetro <acl> permite definir quais serão os grupos atendidos pelo RP (no exemplo, 239.1.1.1 e 239.1.1.2). A especificação de um conjunto maior de endereços multicast é uma prática recomendada, pois possibilita provisionar grupos para o uso futuro. Assim, neste cenário, todos os IPs da faixa 239.1.1.0/24 serão liberados.

É possível definir a periodicidade de transmissão das mensagens do rendezvous point por meio do parâmetro <tempo>. Finalmente, a prioridade do RP é configurada pela instrução <número>. Nos cenários com múltiplos roteadores candidatos, quanto menor for o valor, maior a probabilidade de seleção do dispositivo para desempenhar esta função. A Listagem 8 aborda as configurações necessárias para definir o roteador C como RP (o exemplo pressupõe que os equipamentos estão operando em PIM SM).

Listagem 8. Comandos para a configuração do RP.


  //CONFIGURAÇÃO DO ROTEADOR C (RP)
  interface Loopback 0
  ip address 10.10.10.10 255.255.255.255
  ip pim sparse-mode
   
  ip pim rp-candidate Loopback 0 group-list 1 interval 30 priority 30
  access-list 1 permit 239.1.1.0 0.0.0.255

A tecnologia IP multicast possibilita maior eficiência no uso dos recursos das redes de dados, reduzindo o consumo da largura de banda nos enlaces que conectam os produtores e os consumidores de aplicações multimídia, tais como: videoconferência, ensino a distância, computação distribuída, entre outras. Seu funcionamento comumente é separado em duas partes com funções específicas.

A primeira está relacionada ao gerenciamento dos participantes nos grupos multicast (admissão e remoção) – papel do protocolo Internet Group Management Protocol (IGMP). Já a segunda função trata do encaminhamento dos pacotes IP multicast entre os roteadores, desde o remetente até os clientes que se registraram no grupo para a recepção deste conteúdo. Suportada pelo Protocol Independent Multicast (PIM), esta atribuição pode ser implementada de maneiras distintas, conforme as características do ambiente no qual estará inserida.

Administradores de redes menores poderão configurar o PIM Dense Mode ou Sparse Mode manualmente, ou seja, adicionando os comandos em cada um de seus roteadores. O PIM DM é recomendado para aquelas estruturas que atenderão aos usuários das aplicações multicast em todos os segmentos de rede local; já o PIM SM é mais adequado para aquelas redes que possuem clientes esparsamente localizados.

Finalmente, para grandes e complexas redes, sugere-se o uso do PIM SM com o auxílio de protocolos que propagam dinamicamente as informações dos rendezvous points e de seus grupos mapeados. Duas alternativas foram expostas: a primeira, envolvendo uma solução proprietária da Cisco Systems denominada Auto-RP; a segunda, utilizando uma abordagem padronizada conhecida como BSR Protocol.

Foram detalhadas as características e os comandos necessários para a configuração de cada um destes enfoques por meio de diferentes cenários práticos. Assim, observou-se que o uso do BSR Protocol é a opção mais interessante por duas razões principais: compatibilidade com dispositivos de diferentes fornecedores (protocolo padronizado) e ausência da necessidade do PIM sparse-dense mode (possui atuação inicial menos eficiente).

Links

Artigo “Configuring PIM-SM and PIM Sparse-Dense Mode”, escrito por Justin Menga.
http://www.informit.com/library/content.aspx?b=CCNP_Studies_Switching&seqNum=62

Artigo “IP Multicast Technology Overview”, escrito pela Cisco Systems.
http://www.cisco.com/c/en/us/td/docs/ios/solutions_docs/ip_multicast/
White_papers/mcst_ovr.html

Artigo “Multicast Quick−Start Configuration Guide”, escrito pela Cisco Systems.
http://www.cisco.com/c/en/us/support/docs/ip/ip-multicast/9356-48.html

Artigo “PIM Sparse Mode – BSR and Multicast Security”, escrito por Laurent Prat.
http://aitaseller.wordpress.com/2012/09/11/basic-multicast-part-4-pim-
sparse-mode-bsr-and-multicast-security/

Artigo “Redes IP Multicast”, escrito por André Koide da Silva.
http://www.devmedia.com.br/redes-ip-multicast-revista-infra-magazine-5/24091

Artigo “Understanding BSR Protocol”, escrito por Petr Lapukhov.
http://blog.ine.com/2009/04/07/understanding-bsr-protocol/