Calculo de números ímpares e pares no Visualg(Portugol)

28/03/2019

12

Fala galera!!
Eu estou tentado fazer um algoritmo que calcule 4 notas e apresente uma média, e se reprovou quanto faltou para ser aprovado.
Eu fiz o que calcula a média porém não sei como faz para apresentar quanto falta para aprovação.
Por enquanto está assim:
Var
// Seção de Declarações das variáveis
n1,n2,n3,n4,Media:Real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
escreva("Programa que calcula media")
escreval("Digite a primeira nota")
leia (n1)
escreval("Digite a segunda nota")
leia (n2)
escreval("Digite a terceira nota")
leia (n3)
escreval("Digite a quarta nota")
leia (n4)
media<-(n1+n2+n3+n4)/4
se (Media>=7) entao
escreval("O aluno foi aprovado com média:",Media)
fimse
se (Media=3.1) ou (Media=3.2) ou (Media=3.3) ou (Media=3.4) ou (Media=3.5) ou (Media=3.6) ou (Media=3.7) ou (Media=3.8) ou (Media=3.9) entao
escreval("O aluno está de recuperação com média:",Media)
fimse
se (Media<2.9) entao
escreval("O aluno está reprovado")
fimse


Fimalgoritmo

Se puderem me ajudar agradeço!!
Responder

Post mais votado

28/03/2019

Olá Felipe, não sei se vou utilizar os valores corretos mas faz assim:


se (Media>=7) entao
escreval("O aluno foi aprovado com média:",Media)
senao
   se (Media<7.0) e  (Media>3.0)  entao
      escreval("O aluno está de recuperação com média:",Media)
   senao
      escreval("O aluno está reprovado")
      escreval("Para passar o aluno precisaria de ",7-Media)
   fimse
fimse


Espero que ajude.
Um forte abraço e fique com Deus.
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar