Criptografia de uma palavra

29/05/2021

5

Olá, meu professor pediu para fazer uma criptografia de uma palavra
na qual temos que usar numero para trocar com letras, ainda não entendi muito bem
porem todas as tentativas deram erro então gostaria de esta pedindo algum esclarecimento
eles passaram um aplicativo VisualG para tentarmos programar esse questão. e deram um modelo que não entendi nada.
se alguém poder me ajudar agradeço.

algoritmo
var
// Aqui será criada a estrutura de dados para a mensagem original e para a mensagem cifrada.
// Variáveis auxiliares também deverão ser declaradas aqui.
original: vetor [1..20] de caractere
cifra: vetor [1..20] de inteiro
alfabeto: vetor [1..26] de caractere

i, j, aux : inteiro
inicio
// Aqui vão todos os comandos responsáveis pela lógica e funcionamento do algoritmo.
// Preenchimento do vetor de caracteres do alfabeto.
alfabeto[1] <- "A"
alfabeto[2] <- "B"
alfabeto[3] <- "C"
alfabeto[4] <- "D"
alfabeto[5] <- "E"
_________________________________________________
// Continue preenchendo os demais espaços do vetor alfabeto.

// Início da solução do problema com a obtenção dos dados básicos.
escreval ("Digite os caracteres da mensagem original um por um: ")
para i de 1 ate 20 faca
leia (original[i])
se (original[i] = "#") entao
original[i] <- ""
Interrompa
fimse
fimpara
escreva ("Quantos dígitos possui seu RA: ")
leia (RA)
para i de 1 ate RA faca
escreva ("Digite o ", i, ". dígito de seu RA: ")
leia (aux)
soma <- soma + aux
fimpara
resto <- soma mod 26 // VARIÁVEL RA TROCADA POR SOMA !!!
escreval ("RA: ", RA, " - RESTO: ", resto)
para i de 1 ate 20 faca
escreva (original[i])
fimpara
escreval()
// Etapa de desenvolvimento do algoritmo de criptografia.
// Crie um mecanismo para fazer a troca de letras por números.
___________________________________
// Exibição da mensagem cifrada com números gerada pelas trocas.
escreva ("Mensagem criptografada: ")
___________________________________
// Etapa de desenvolvimento do algoritmo de recuperação da mensagem original.
para i de 1 ate 20 faca
se (cifra[i] <> 0) entao
aux <- cifra[i] - resto
original[i] <- alfabeto[aux]
fimse
fimpara
escreval()
// Exibição da mensagem original recuperada.
// A mensagem original recuperada pela etapa anterior de troca de números por letras.
escreva ("Mensagem original: ")
___________________________________

fimalgoritmo
Cleferson Oliveira

Cleferson Oliveira

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar