Digita um numero e apresentar por extenso

17/11/2014

27

Mais uma duvida quanto a um exercicio, realmente fiquei meio perdido nesse:

é pedido:

ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.

o que eu tentei fazer:


algoritmo "EXTENSO NUMERO ERRADO"
// Função :
// Autor :
// Data : 17/11/2014
// Seção de Declarações 
// ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.
var
NUMERO : INTEIRO
inicio
// Seção de Comandos 
ESCREVA("ESCREVA UM NUMERO ENTRE 1 E 5: ")
LEIA(NUMERO)
SE NUMERO = 1 ENTAO
   ESCREVA("UM")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 2 ENTAO
   ESCREVA("DOIS")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 3 ENTAO
   ESCREVA("TRES")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 4 ENTAO
   ESCREVA("QUATRO")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 5 ENTAO
   ESCREVA("CINCO")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
fimalgoritmo

Responder

Posts

Mais uma duvida quanto a um exercicio, realmente fiquei meio perdido nesse:

é pedido:

ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.

o que eu tentei fazer:


algoritmo "EXTENSO NUMERO ERRADO"
// Função :
// Autor :
// Data : 17/11/2014
// Seção de Declarações 
// ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.
var
NUMERO : INTEIRO
inicio
// Seção de Comandos 
ESCREVA("ESCREVA UM NUMERO ENTRE 1 E 5: ")
LEIA(NUMERO)
SE NUMERO = 1 ENTAO
   ESCREVA("UM")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 2 ENTAO
   ESCREVA("DOIS")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 3 ENTAO
   ESCREVA("TRES")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 4 ENTAO
   ESCREVA("QUATRO")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
SE NUMERO = 5 ENTAO
   ESCREVA("CINCO")
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
fimalgoritmo



Apenas o seu "NUMERO INVALIDO" está errado. Pela sua lógica só vai funcionar o número 1, se ele digitar qualquer outro número irá falhar. Faça assim:

...
ESCREVA("ESCREVA UM NUMERO ENTRE 1 E 5: ")
LEIA(NUMERO)
SE NUMERO = 1 ENTAO
   ESCREVA("UM")
SENAO
 SE NUMERO = 2 ENTAO
   ESCREVA("DOIS")
...

Responder
Seu codigo me parece melhor e mais enxuto! vou testar.
Responder
E para o numero invalido, como devo proceder?

funcionou sobre os numeros


SE NUMERO = 1 ENTAO
   ESCREVA("UM")
SENAO
FIMSE
 SE NUMERO = 2 ENTAO
   ESCREVA("DOIS")
SENAO
FIMSE
  SE NUMERO = 3 ENTAO
   ESCREVA("TRES")
SENAO
FIMSE
  SE NUMERO = 4 ENTAO
   ESCREVA("QUATRO")
SENAO
FIMSE
  SE NUMERO = 5 ENTAO
   ESCREVA("CINCO")
SENAO
FIMSE
SE ???????
SENAO
   ESCREVA("NUMERO INVALIDO")
FIMSE
fimalgoritmo

Responder
Depois da minha ultima pergunta, existe alguma outra forma mais facil? Minha apostila é fraquinha e tem apenas exemplos basicos usando o SE, um amigo meu citou o "CASO" mas não me deu mais informações pois a aula tinha acabado, como posso usar o "CASO" para esse exemplo?
Responder

18/11/2014

Soeuseijothaz

Depois da minha ultima pergunta, existe alguma outra forma mais facil? Minha apostila é fraquinha e tem apenas exemplos basicos usando o SE, um amigo meu citou o "CASO" mas não me deu mais informações pois a aula tinha acabado, como posso usar o "CASO" para esse exemplo?


A dica do Ronaldo Lanhellas esta correta, o número invalido seria no último senão do algorítimo.

Se sua apostila é fraca, então pesquise no google, pois existem milhares de artigos completos e exemplos. Se você se prender a um material ruim não vai aprender nada.
Infelizmente não fácil e se não tiver disposição para correr atrás fica mais complicado ainda.

Não me leve a mal, não quero criticá-lo é só uma dica para você conseguir um material realmente completo.

No exemplo a seguir como usar o CASO, não testei e pode haver erros. É só para você ter uma ideia de com usá-lo.

ESCOLHA NUMERO
	CASO 1
		 ESCREVA("UM")
	CASO 2
		ESCREVA("DOIS")

		... coloque as outras condições aqui ....
		
		
	OUTRO CASO
		ESCREVAL("NUMERO INVALIDO")
FIMESCOLHA

Responder
Que é isso jothaz, entendi perfeitamente o que quis dizer, sem problemas! espero que não haja problemas se minhas duvidas forem basicas demais.

Vou testar usando o CASO, do seu exemplo. obrigado.
Responder

18/11/2014

Soeuseijothaz

Que é isso jothaz, entendi perfeitamente o que quis dizer, sem problemas! espero que não haja problemas se minhas duvidas forem basicas demais.

Vou testar usando o CASO, do seu exemplo. obrigado.


Existem dúvidas! E mesmo as mais básicas devem ser sanadas.

Como você esta começando é como se estive pousado em Marte é tudo estranho e complicado, então pode contar com a ajuda do fórum.

Só fiz a colocação para alertá-lo para opções com melhores conteúdos para completar as informações passadas aqui.
Responder
Tudo otimo, to gostando, estarei mais atento as minhas perguntas e sempre revendo aonde estou possivelmente errando em meus exemplos.

OBRIGADO!
Responder
Apresentando a versão final


algoritmo "EXTENSO NUMERO CORRIGIDO"
// Função :
// Autor :
// Data : 19/11/2014
// Seção de Declarações 
// ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.
var
NUMERO : INTEIRO
inicio
// Seção de Comandos 
ESCREVA("ESCREVA UM NUMERO ENTRE 1 E 5: ")
LEIA(NUMERO)
ESCOLHA(NUMERO)
CASO 1
  ESCREVA("UM")
CASO 2
  ESCREVA("DOIS")
CASO 3
  ESCREVA("TRES")
CASO 4
  ESCREVA("QUATRO")
CASO 5
  ESCREVA("CINCO")
OUTROCASO
  ESCREVA("NUMERO INVALIDO")
FIMESCOLHA


fimalgoritmo

Responder

19/11/2014

Soeuseijothaz

De nada!
Responder
Valeu mesmo pelo apoio.
Responder
Apresentando a versão final


algoritmo "EXTENSO NUMERO CORRIGIDO"
// Função :
// Autor :
// Data : 19/11/2014
// Seção de Declarações 
// ALGORITMO QUE LEIA UM NUMERO DE 1 A 5 E ESCEVA POR EXTENSO, CASO CONTRARIO, ESCREVA NUMERO INVALIDO.
var
NUMERO : INTEIRO
inicio
// Seção de Comandos 
ESCREVA("ESCREVA UM NUMERO ENTRE 1 E 5: ")
LEIA(NUMERO)
ESCOLHA(NUMERO)
CASO 1
  ESCREVA("UM")
CASO 2
  ESCREVA("DOIS")
CASO 3
  ESCREVA("TRES")
CA
SO 4
  ESCREVA("QUATRO")
CASO 5
  ESCREVA("CINCO")
OUTROCASO
  ESCREVA("NUMERO INVALIDO")
FIMESCOLHA


fimalgoritmo



ótima solução, no seu caso melhor que o "SE"
Responder
Tambem achei, gostei de utilizar o CASO, nesse exemplo "criamos" as regras.
Responder
preciso de uma resposta para esse problema alquem pode ajudar?

Crie um algoritmo que leia um número de 1 a 5 e escreva este número por extenso. Caso o usuário digite um número que não esteja neste intervalo, exibir mensagem de erro. Utilizar vetor para resolver este algoritmo.
Responder
preciso de uma resposta para esse problema alquem pode ajudar?

Crie um algoritmo que leia um número de 1 a 5 e escreva este número por extenso. Caso o usuário digite um número que não esteja neste intervalo, exibir mensagem de erro. Utilizar vetor para resolver este algoritmo.
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar