Duvidas com grupo no fast report

07/08/2020

6

Estou com uma pequena duvida no fast report.

Tenho um select que busca alguns campos, e preciso agrupar no fast report por grupo e subgrupo.
uso duas bandas de grupo, uma abaixo da outra, e a banda de dados logo abaixo delas, e assim é me retornado corretamente agrupados.
Porém quando um sub grupo não existe ele me retorna mesmo assim uma linha. O que eu posso estar fazendo de errado?


Esse é meu SQL:
SELECT
    COALESCE(P.ID,'''')as IDGRUPO,
    P.NOME GRUPO,
    COALESCE(PG.ID,'''') as IDGRUPO1,
    PG.NOME AS GRUPO1,
    COALESCE(PO.ID,'''') AS IDGRUPO2,
    PO.NOME AS GRUPO2,
    p.codigo as CODIGO_GRUPO,
    PG.codigo AS CODIGO_GRUPO1,
    PO.codigo AS CODIGO_GRUPO2
FROM PLANO_CONTA P

LEFT JOIN PLANO_CONTA_GRUPO1 PG
ON PG.IDPLANO_CONTA = P.ID 

LEFT JOIN PLANO_CONTA_GRUPO2 PO
ON PO.IDGRUPO1 =PG.ID

ORDER BY P.ID,pg.id, PO.ID, P.NOME, PG.NOME, PO.NOME 



Gostaria de mostrar como obtive o retorno do fastReport, mas não encontrei opção de adicionar imagens.Vou tentar reproduzir

1.00.00.00 - RECEITAS R$220,00
1.01.00.00 - VENDAS R$220,00
1.01.04.00 - VENDAS A VISTA EM DINHEIRO R$213,00
1.01.05.00 - RECEBIMENTO DE VENDAS A PRAZO R$0,00
1.02.00.00 - RECEITA FINANCEIRA R$0,00
- R$0,00//Quero retirar isso
1.03.00.00 - OUTRAS RECEITAS R$0,00
- R$0,00 //Quero retirar isso
2.00.00.00 - DESPESAS R$0,00
- R$0,00//Quero retirar isso
- R$0,00//Quero retirar isso

Dês de já agradeço a ajuda!
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar