Ajuda com VisualG/portugol

25/08/2020

6

Estou estudando com o visualg e não sei porque este algoritmo está dando errado. O objetivo dele é listar em ordem o que possui a menor pontuação para a maior. Segue:

Algoritmo "tabeladepontos"

Var
i, j, aux, l:inteiro
vit, emp, totp: vetor[1..8] de inteiro
nome: vetor[1..8] de caractere
auxn:caractere
Inicio
Escreval("====================================================================")
Escreval("| Tabela de pontos do campeonato |")
Escreval("====================================================================")
Para i <- 1 ate 8 faca
Escreva("Digite o nome do ", i, "° time de futebol: ")
Leia (nome[i])
Escreva("Quantas vitórias o time teve até agora no campeonato? ")
Leia (vit[i])
vit[i]<-vit[i]*2
Escreva("Quantos empates o time teve até agora no campeonato? ")
Leia (emp[i])
totp[i]<-vit[i]+emp[i]
FimPara
Para j<-1 ate 7 faca
Para l<-2 ate 8 faca
Se totp[j]>totp[l] entao
aux<-totp[j]
totp[j]<-totp[l]
totp[l]<-aux

auxn<-nome[j]
nome[j]<-nome[l]
nome[l]<-auxn
FimSe
FimPara
FimPara
LimpaTela
Escreval("====================================================================")
Escreval("| Tabela de pontos do campeonato |")
Escreval("====================================================================")
Escreval("A ordem da tabela de maior pontuação para menor pontuação é:")
Para i<-1 ate 8 faca
Escreval(nome[i], " com ", totp[i], " pontos, na ", i, "ª posição.")
FimPara
Fimalgoritmo
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar