Série da semana: Primeiros passos no Angular

Veja mais

Algoritmos: Exercício de Lógica e Comparação no VISUALG

02/04/2019

12

///ESTOU TENTANDO FAZER ESSE EXERCICIO FAZ 3 DIAS, ME AJUDE POR FAVOR!

Faça um algoritmo que leia o nome do aluno, a nota total dos trabalhos, a nota da primeira e segunda avaliação, calcule a nota final e o conceito obtido seguindo a seguinte formula:

A média da avaliação será calculada da seguinte forma:
Se a nota da primeira avaliação for maior que a nota da segunda avaliação, então a média da avaliação será a soma das duas notas e dividida por dois.
Caso contrário, a nota da primeira prova é desconsiderada e a média recebe o valor da segunda avaliação.

A nota final será calculada da seguinte forma:
Se a média das avaliações for maior ou igual a seis, então a nota final será calculada com a seguinte formula: (Média das avaliações vezes 0,75) somada a (nota dos trabalhos vezes 0,25).
Caso contrário, a nota final será igual a Média das avaliações vezes 0,75.

O conceito da disciplina será calculado da seguinte forma:
Se a nota final for maior ou igual a 8.5, então o conceito é A.
Se a nota final estiver entre 7.0 e 8.4, então o conceito é B.
Se a nota final estiver entre 6.0 e 6.9, então o conceito é C.
Se a nota final estiver entre 0.1 e 5.9, então o conceito é D.
Se a nota final for igual a 0.0, então o conceito é E.
Responder

Posts


Olá segue a resposta:

Algoritmo "semnome"

Var
// Seção de Declarações das variáveis
nome: caracter
notaTrabalhos: real
notaProva1: real
notaProva2: real
mediaProvas: real
notaFinal: real
conceito: caracter

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...

// Aqui lemos os dados que o exercício pede.
escreval("Nome do Aluno: ")
leia(nome)
escreval("Nota dos Trabalhos: ")
leia(notaTrabalhos)
escreval("Nota da Prova 1: ")
leia(notaProva1)
escreval("Nota da Prova 2: ")
leia(notaProva2)

// Aqui verificamos a media das provas de acordo com o solicitado
se(notaProva1 > notaProva2) entao
mediaProvas <- (notaProva1 + notaProva2)/2;
senao
mediaProvas <- notaProva2;
Fimse

// Aqui calculamos o valor da nota final
se(mediaProvas >= 6) entao
notaFinal <- (mediaProvas * 0.75) + (notaTrabalhos * 0.25)
senao
notaFinal <- mediaProvas * 0.75
Fimse

// Aqui verificamos qual o conceito obtido pelo aluno
se(notaFinal >= 8.5) entao
conceito <- "A"
senao
se((notaFinal>=7.0)e(notafinal<=8.4)) entao
conceito <- "B"
senao
se((notaFinal>=6.0)e(notafinal<=6.9)) entao
conceito <- "C"
senao
se((notaFinal>=0.1)e(notafinal<=5.9)) entao
conceito <- "D"
senao
conceito <- "E"
FimSe
FimSe
FimSe
FimSe

escreval("Nota Final: ", notaFinal)
escreval("Conceiro: ", conceito)
Fimalgoritmo
Responder