Converter Visual para Java/Android

21/11/2019

4

Boa tarde. Estou precisando de ajuda. Sou estudante de engenharia civil e tenho uma aula de programação de app. Penamos para conseguir fazer um algoritmo simples e agora precisamos codificar em Java e em Android para que o algoritmo rode na interface que criamos. Será que podem me ajudar fazendo essa conversão? Obrigada... pedido desesperado de 3 alunos que não entendem naaaada de programação. Estamos usando o eclipse para fazer a interface gráfica

algoritmo "TIJOLAR"

// Função : Calcular quantidade de tijolo, cimento da argamassa e média de preço gasto

// Autor : Bárbara, Luciana e Raphael

// Data : 03/10/2019

// Seção de Declarações

var

comp, alt,valor,qtdtij: real

tij: inteiro // (1 - 8 furos, 2 para 9 furos, 3 para 16 furos, 4 para tijolo maciço)

inst: inteiro // (1- 1 vez, 2- 1/2 vez)

areap, areat: real

inicio

escreval ("Qual é o comprimento da parede?")

leia (comp)

escreval ("Qual é a altura da parede?")

leia (alt)

escreval ("Escolha a opcao: [1 - 8 furos 1vez, 2 - 8 furos 1/2vez, 3 - 9 furos 1vez, 4 - 9 furos 1/2vez, 5 - 16 furos 1vez, 6 - 16 furos 1/2vez, 7 - Tj Maciço 1vez]" )

leia (inst)

areap <- comp*alt


se (inst = 1) entao
areat <- 0.036
qtdtij <- (areap/areat)
valor <- (qtdtij*0.54)

senao
Se (inst= 2) entao
areat <- 0.171
qtdtij <- (areap/areat)
valor <- qtdtij*0.54
senao
se (inst= 3) entao
areat <- 0.036
qtdtij <- (areap/areat)
valor <- qtdtij*0.84
senao
se (inst= 4) entao
areat <- 0.022
qtdtij <- (areap/areat)
valor <- qtdtij*0.84
senao
se (inst= 5) entao
areat <- 0.036
qtdtij <- (areap/areat)
valor <- qtdtij*1.75
senao
se (inst= 6) entao
areat <- 0.036
qtdtij <- (areap/areat)
valor <- qtdtij*1.75
senao
areat <- 0.0095
qtdtij <- (areap/areat)
valor <- qtdtij*0.95

fimse
fimse
fimse
fimse
fimse
fimse


escreval ("Área do tijolo = ", areat)
escreval ("Quantidade de tijolo = ", qtdtij)
escreval ("Área da parede = ", areap )
escreval ("Valor total = ", valor :2:2)

fimalgoritmo
Responder

Post mais votado

21/11/2019

Olá Luciana, então, da um certo trabalho criar um app, acho um pouco difícil alguém se propor a fazer (pelo menos, não de graça).
De qualquer forma, eu codifiquei rapidinho em java, o algoritmo é relativamente simples, vocês deveriam tentar fazer também.
Você pode testar usando um compilador online, eu usei o:
Sugiro que você e seus amigos usem esse código e tentem criar o app vocês mesmos, procurem tutoriais na internet ou mesmo ajuda de outros colegas, aqui na devmedia existem vários cursos de criação de apps, sugiro que assinem e estudem, é muito legal.
Aprender programação não é tão complicado quanto parece e é de extrema importância para qualquer carreira hoje em dia. Boa sorte e bons estudos

import java.util.Scanner;

public class Main
{
	public static void main(String[] args) {
		
		/* Algoritmo "TIJOLAR" em Java
         * Função: Calcular quantidade de tijolo, cimento da argamassa e média de preço gasto
         * Autor : Bárbara, Luciana e Raphael
         * Data : 03/10/2019
         * Seção de Declarações*/

        // Variáveis
        double comp = 0, alt = 0, valor = 0, qtdtij = 0;
        int tij = 0; // (1 - 8 furos, 2 para 9 furos, 3 para 16 furos, 4 para tijolo maciço)
        int inst = 0; // (1- 1 vez, 2- 1/2 vez)
        double areap = 0, areat = 0;
        // Objeto responsável por recuperar a entrada de dados do usuário
        Scanner scanner = new Scanner(System.in);

        System.out.println("Qual é o comprimento da parede?");
        comp = scanner.nextDouble();
        
        System.out.println("Qual é a altura da parede?");
        alt = scanner.nextDouble();
        
        areap = comp*alt;
        
        System.out.println("Escolha a opcao: [1 - 8 furos 1vez, 2 - 8 furos 1/2vez, 3 - 9 furos 1vez, 4 - 9 furos 1/2vez, 5 - 16 furos 1vez, 6 - 16 furos 1/2vez, 7 - Tj Maciço 1vez]" );
        inst = scanner.nextInt();

        // O switch é uma estrutura semelhante ao if, é mais recomendado quando se tem que escolher opções sem fazer verificações lógicas.
        switch(inst){
            case 1:
                areat = 0.036;
                qtdtij = areap/areat;
                valor = qtdtij*0.54;
                break;
            case 2:
                areat = 0.171;
                qtdtij = areap/areat;
                valor = qtdtij*0.54;
                break;
            case 3:
                areat = 0.036;
                qtdtij = areap/areat;
                valor = qtdtij*0.84;
                break;
            case 4:
                areat = 0.022;
                qtdtij = areap/areat;
                valor = qtdtij*0.84;
                break;
            case 5:
                areat = 0.036;
                qtdtij = areap/areat;
                valor = qtdtij*1.75;
                break;
            case 6:
                areat = 0.036;
                qtdtij = areap/areat;
                valor = qtdtij*1.75;
                break;
            case 7:
                areat = 0.0095;
                qtdtij = (areap/areat);
                valor = qtdtij*0.95;
                break;
            default:
                System.out.println("Escolha uma opção valida");
                break;
        }

        System.out.println("Área do tijolo = " + String.format("%.02f", areat));
        System.out.println("Quantidade de tijolo = " + String.format("%.02f", qtdtij));
        System.out.println("Área da parede = " + String.format("%.02f", areap));
        System.out.println("Valor total = " + String.format("%.02f", valor));

	}
}
Responder

Mais Posts

Sim sim, o app nós que vamos fazer. Só essa codificação que tava acabando com meus neurônios hahahaha

Nós estamos tentando, de verdade. Até agora só consegui desenvolver isso:


double comp, alt, valor, qtdtij, areap, areat; // o real pode ser declarado como double
int opcao;//inteiro pode ser declarado como int
int tijolo;// inteiro para: (1 - 8 furos, 2 para 9 furos, 3 para 16 furos, 4 para tijolo maciço)
int inst;// inteiro para:(1- 1 vez, 2- 1/2 vez)

public void calcular (View v) {
// declaração de variáveis:
double comp=0, alt=0, valor=0, qtdtij=0, areap=0, areat=0;
int tijolo=0;
int inst=0;
}

Valores reais

comp= Double.parseDouble(edt1.getText().toString());
alt=Double.parseDouble(edt2.getText().toString()); 

if(rdb1.isChecked()){//se o radio0 estiver marcado inst 1 vez valerá 1.
inst = 1;
}
if(rdb2.isChecked( ) ) { // se o radio1 estiver marcado inst ½ vez valerá 2.
inst = 1;
}

Mas já vi que tá errado…
Muuuuuuuuitíssimo obrigada
Responder
Sim sim, o app nós que vamos fazer. Só essa codificação que tava acabando com meus neurônios hahahaha

Nós estamos tentando, de verdade. Até agora só consegui desenvolver isso:


double comp, alt, valor, qtdtij, areap, areat; // o real pode ser declarado como double
int opcao;//inteiro pode ser declarado como int
int tijolo;// inteiro para: (1 - 8 furos, 2 para 9 furos, 3 para 16 furos, 4 para tijolo maciço)
int inst;// inteiro para:(1- 1 vez, 2- 1/2 vez)

public void calcular (View v) {
// declaração de variáveis:
double comp=0, alt=0, valor=0, qtdtij=0, areap=0, areat=0;
int tijolo=0;
int inst=0;
}

Valores reais

comp= Double.parseDouble(edt1.getText().toString());
alt=Double.parseDouble(edt2.getText().toString()); 

if(rdb1.isChecked()){//se o radio0 estiver marcado inst 1 vez valerá 1.
inst = 1;
}
if(rdb2.isChecked( ) ) { // se o radio1 estiver marcado inst ½ vez valerá 2.
inst = 1;
}

Mas já vi que tá errado…
Muuuuuuuuitíssimo obrigada




Você está no caminho certo, muito bom.
Mas tenha em mente que a maior parte do seu algorítimo ficará dentro da função "public void calcular (View v)", depois disso, basta mostrar o resultado.
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar