Fiz uma calculadora no visualg

29/09/2020

24

Criei esse tópico para discutir e trocar conhecimentos sobre o visualg e para melhorar essa calculadora.
Fica aqui para os próximos aprendizes estudarem:

algoritmo "calculadora"


// Steam: /id/Gooper/

var
resultado : real
calculadora, numero : real
operacao, resposta : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")

calculadora <- 0

escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * /] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)


escolha operacao


caso "c"


calculadora <- 0
resultado <- 0
escreva ((" "),("Digite o primeiro número: "))
leia (resultado)

caso "+"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado + Numero
resultado <- calculadora


caso "-"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado - numero
resultado <- calculadora


caso "*"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado * numero
resultado <- calculadora


caso "/"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado/numero
resultado <- calculadora


fimescolha

limpatela

Escreval ("--------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ----------------------------")
Escreval ("--------------------------------------------------------------------")

escreval ((" "),("O seu número é: "), (resultado))

escreval ((" "),("Quer continuar?[S/N] "))
escreva (" ")
leia (resposta)

ate resposta = "N"

Escreval ("--------------------------------------------------------------------")
escreval ((" "),("O resultado final é: "), (resultado))
Escreval ("--------------------------------------------------------------------")

fimalgoritmo
Emiliano

Emiliano

Responder

Post mais votado

30/09/2020

caso queiram a calculadora final copiem esse código
algoritmo "calculadora"


// Steam: /id/Gooper/

var
resultado, numero : real
operacao : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")



escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * / =] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)

se operacao = "=" entao


senao
escreva ((" "),("Digite o número: "))
Leia (numero)
fimse

escolha operacao



caso "c"


resultado <- numero

caso "+"


resultado <- resultado + Numero



caso "-"


resultado <- resultado - numero



caso "*"


resultado <- resultado * numero



caso "/"


resultado <- resultado/numero



fimescolha

limpatela

Escreval ("--------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ----------------------------")
Escreval ("--------------------------------------------------------------------")

escreval ((" "),("O seu número é: "), (resultado))



ate (operacao = "=")

limpatela

Escreval ("--------------------------------------------------------------------")
escreval ((" "),("O resultado final é: "), (resultado))
Escreval ("--------------------------------------------------------------------")

fimalgoritmo

Emiliano

Emiliano
Responder

Mais Posts

29/09/2020

Emiliano

Criei esse tópico para discutir e trocar conhecimentos sobre o visualg e para melhorar essa calculadora.
Fica aqui para os próximos aprendizes estudarem:

algoritmo "calculadora"


// Steam: /id/Gooper/

var
resultado : real
calculadora, numero : real
operacao, resposta : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")

calculadora <- 0

escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * /] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)


escolha operacao


caso "c"


calculadora <- 0
resultado <- 0
escreva ((" "),("Digite o primeiro número: "))
leia (resultado)

caso "+"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado + Numero
resultado <- calculadora


caso "-"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado - numero
resultado <- calculadora


caso "*"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado * numero
resultado <- calculadora


caso "/"

escreva ((" "),("Digite o número: "))
Leia (numero)
calculadora <- resultado/numero
resultado <- calculadora


fimescolha

limpatela

Escreval ("--------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ----------------------------")
Escreval ("--------------------------------------------------------------------")

escreval ((" "),("O seu número é: "), (resultado))

escreval ((" "),("Quer continuar?[S/N] "))
escreva (" ")
leia (resposta)

ate resposta = "N"

Escreval ("--------------------------------------------------------------------")
escreval ((" "),("O resultado final é: "), (resultado))
Escreval ("--------------------------------------------------------------------")

fimalgoritmo



A plataforma não computa os espaços dentro das aspas (" "), só se vocês clicarem em responder, daí vocês copiam da sua resposta o algoritmo.
Responder

30/09/2020

Emiliano

Melhorei o algoritmo e percebi que uma variável não era necessária:

algoritmo "calculadora"

// Instagram: emilianog16
// Steam: /id/Gooper/

var
resultado, numero : real
operacao, resposta : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")



escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * /] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)


escolha operacao


caso "c"



resultado <- 0
escreva ((" "),("Digite o primeiro número: "))
leia (resultado)

caso "+"

escreva ((" "),("Digite o número: "))
Leia (numero)
resultado <- resultado + Numero



caso "-"

escreva ((" "),("Digite o número: "))
Leia (numero)
resultado <- resultado - numero



caso "*"

escreva ((" "),("Digite o número: "))
Leia (numero)
resultado <- resultado * numero



caso "/"

escreva ((" "),("Digite o número: "))
Leia (numero)
resultado <- resultado/numero



fimescolha

limpatela

Escreval ("--------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ----------------------------")
Escreval ("--------------------------------------------------------------------")

escreval ((" "),("O seu número é: "), (resultado))

escreval ((" "),("Quer continuar?[S/N] "))
escreva (" ")
leia (resposta)

ate resposta = "N"

Escreval ("--------------------------------------------------------------------")
escreval ((" "),("O resultado final é: "), (resultado))
Escreval ("--------------------------------------------------------------------")

fimalgoritmo

Responder

30/09/2020

Emiliano

Melhorei um pouco mais hehehehe
percebi que seria melhor eu modificar o clear e, assim, por o segundo número universal para cada caso, e não em cada caso.


algoritmo "calculadora"

// Instagram: emilianog16
// Steam: /id/Gooper/

var
resultado, numero : real
operacao, resposta : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")



escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * /] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)


escreva ((" "),("Digite o número: "))
Leia (numero)

escolha operacao



caso "c"


resultado <- numero

caso "+"


resultado <- resultado + Numero



caso "-"


resultado <- resultado - numero



caso "*"


resultado <- resultado * numero



caso "/"


resultado <- resultado/numero



fimescolha

limpatela

Escreval ("--------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ----------------------------")
Escreval ("--------------------------------------------------------------------")

escreval ((" "),("O seu número é: "), (resultado))

escreval ((" "),("Quer continuar?[S/N] "))
escreva (" ")
leia (resposta)

ate resposta = "N"

Escreval ("--------------------------------------------------------------------")
escreval ((" "),("O resultado final é: "), (resultado))
Escreval ("--------------------------------------------------------------------")

fimalgoritmo
Responder

30/09/2020

Emiliano

Melhorei a calculadoraaa, agora não precisa mais ter que digitar "s" ou "n" para o loop funcionar, ele simplesmente para se digitar "=" na operação
algoritmo "calculadora"

// Instagram: emilianog16
// Steam: /id/Gooper/

var
resultado, numero : real
operacao : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")



escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * / =] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)

se operacao = "=" entao


senao
escreva ((" "),("Digite o número: "))
Leia (numero)
fimse

escolha operacao
Responder

30/09/2020

Emiliano

Melhorei a calculadoraaa, agora não precisa mais ter que digitar "s" ou "n" para o loop funcionar, ele simplesmente para se digitar "=" na operação
algoritmo "calculadora"

// Steam: /id/Gooper/

var
resultado, numero : real
operacao : caractere



inicio


Escreval ("-------------------------------------------------------------------")
Escreval ("--------------------------- CALCULADORA ---------------------------")
Escreval ("-------------------------------------------------------------------")



escreva ((" "),("Digite o primeiro número: "))
leia (resultado)



escreval ((" "),("o seu número é: "), (resultado))
repita


escreval ("Escolha a operação [+ - * / =] ou [c] para apagar a operacao anterior ")
ESCREVA (" ")
leia (operacao)

se operacao = "=" entao


senao
escreva ((" "),("Digite o número: "))
Leia (numero)
fimse

escolha operacao
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar