algorítimo impossível e professor lesado

18/10/2019

21

Estou cursando tecnologia da informação e até o momento tudo estava ok, até o momento que um professor infeliz passa exercícios impossíveis de se resolver, a pergunta seria qual o titulo mais apropriado para o algorítimo e o que ele faz:

var n1, n2, n3, m: real
inicio
leia (n1, n2, n3)
m <- n1="" n2="" n3="" 3="" br="">
escreval(m)
fimalgoritmo

sendo que isso não faz absolutamente nada, eu não faço ideia do que aconteceu, ele escreveu errado
supostamente era pra isso calcular uma média? eu já tentei concertar e rodar no visualg de todas as maneiras, mas essa praga não vai
o que supostamente eu deveria fazer?
Responder

Posts

22/10/2019

Manoel Junior

Boa tarde, isso não existe? De onde ele veio? talvez em outro planeta isso tenha lógica... kkkk
Responder
Estou cursando tecnologia da informação e até o momento tudo estava ok, até o momento que um professor infeliz passa exercícios impossíveis de se resolver, a pergunta seria qual o titulo mais apropriado para o algorítimo e o que ele faz:

var n1, n2, n3, m: real
inicio
leia (n1, n2, n3)
m <- n1="" n2="" n3="" 3="" br="">
escreval(m)
fimalgoritmo

sendo que isso não faz absolutamente nada, eu não faço ideia do que aconteceu, ele escreveu errado
supostamente era pra isso calcular uma média? eu já tentei concertar e rodar no visualg de todas as maneiras, mas essa praga não vai
o que supostamente eu deveria fazer?

============================================================================================================

Não seria:

algoritmo "MEDIA ALUNO - APROVADO, RECUPEAÇÃO E REPROVADO"
// Função :
// Autor :
// Data : 14/11/2014
// Seção de Declarações
var
NOTA1, NOTA2, NOTA3, MEDIA : REAL


inicio
// Seção de Comandos
ESCREVA("DIGITE A PRIMEIRA NOTA: ")
LEIA(NOTA1)
ESCREVA("DIGITE A SEGUNDA NOTA: ")
LEIA(NOTA2)
ESCREVA("DIGITE A TECEIRA NOTA: ")
LEIA(NOTA3)
MEDIA := (NOTA1 + NOTA2 + NOTA3) / 3 ;

SE MEDIA <= 4 ENTAO
ESCREVA("A MEDIA DO ALUNO FOI: ", MEDIA)
ESCREVAL (" - ALUNO REPROVADO ")
FIMSE
SE MEDIA <= 6.9 ENTAO
ESCREVA("A MEDIA DO ALUNO FOI: ", MEDIA)
ESCREVAL (" - ALUNO DE RECUPERAÇÃO ")
FIMSE
SE MEDIA >= 7 ENTAO
ESCREVA("A MEDIA DO ALUNO FOI: ", MEDIA)
ESCREVAL (" - ALUNO APROVADO ")
FIMSE

fimalgoritmo
fonte: https://www.devmedia.com.br/forum/visualg-media-de-4-notas/501247

Responder