Algoritimo visualg erro

21/10/2019

17

Preciso de ajuda urgente nisso, to a 4 dias tentando resolver e nada

A prefeitura de uma cidade desenvolveu um programa para cadastro dos moradores, e cada morador (não é especificada a quantidade) deve informar a sua idade. A prefeitura quer obter no final do cadastro a quantidade de moradores que são eleitores obrigatório, a quantidade de moradores que são eleitores facultativos e quantos moradores não são eleitores, de acordo com a tabela a seguir:
Idade

Tipo de Eleitor

>= 18 e <= 69
Obrigatório

= 16 ou = 17 ou >= 70
Facultativo

< 16
Não é eleitor

Assim, faça um programa em VisualG que receba a idade de cada morador (quantidade indeterminada) e obtenha as quantidades requeridas pela prefeitura.
Victorpetry

Victorpetry

Responder

Posts

21/10/2019

Luiz Vichiatto

var
idade: real
inicio
escreva ("Qual a idade: ")
leia(idade)
se idade_eleitor < 16
    imprime "NÃO É ELEITOR"
se idade_eleitor >= 16 e  idade_eleitor  < 18
    imprime "FACULTATIVO"
se idade_eleitor >= 18 e idade_eleitor  <70
    imprime "OBRIGATÓRIO"
se não "FACULTATIVO"
fimse
fimalgoritimo

Preciso de ajuda urgente nisso, to a 4 dias tentando resolver e nada

A prefeitura de uma cidade desenvolveu um programa para cadastro dos moradores, e cada morador (não é especificada a quantidade) deve informar a sua idade. A prefeitura quer obter no final do cadastro a quantidade de moradores que são eleitores obrigatório, a quantidade de moradores que são eleitores facultativos e quantos moradores não são eleitores, de acordo com a tabela a seguir:
Idade

Tipo de Eleitor

>= 18 e <= 69
Obrigatório

= 16 ou = 17 ou >= 70
Facultativo

< 16
Não é eleitor

Assim, faça um programa em VisualG que receba a idade de cada morador (quantidade indeterminada) e obtenha as quantidades requeridas pela prefeitura.
Responder

05/11/2020

Naelcia

Var

idade, obrigatorio, facultativo, naoeleitor, cont: inteiro

Inicio

escreval("Quantas pessoas quer cadastrar?")

leia(cont)

repita

escreval("digite a idade do morador")

leia (idade)

se (idade >= 18) e (idade <= 69) entao

obrigatorio <- obrigatorio + 1

fimse

se (idade = 16) ou (idade = 17) ou (idade >= 70) entao

facultativo <- facultativo + 1

fimse

se (idade < 16) entao

naoeleitor <- naoeleitor + 1



fimse



ate cont = (obrigatorio + facultativo + naoeleitor)

escreval("A quantidade de eleitores obrigatorios e", obrigatorio)

escreval ("A quantidade de eleitores facultativos e", facultativo)

escreval ("A quantidade de nao eleitores e", naoeleitor)

Fimalgoritmo
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar