Algoritmo - Cinema

10/09/2020

8

Boa noite!!!

Estou construindo um exercicio por conta propria no curso de Algoritmo. O exercicio caminhou bem até o momento quando coloquei o se...entao e mostrou erro "Esperava encontrar o entao". Como posso resolver? Por favor, gostaria de ouvir de vocês se é interessante usar o Escolha como forma de mostrar opções (escolha filme -> escolha sessao -> escolha ingresso). Obrigado desde já!!!

Algoritmo "Cinema"

var
poltrona: vetor[1..20] de Caractere
reserva, cont_ing: Inteiro
resp: Caractere

Procedimento Exibir_Sala()
var i: Inteiro
inicio
//construção da fileira
Para i <- 1 ate 20 faca
//verificar se a poltrona esta ou não reservada e registra no sistema ao exibir
Se (poltrona[i] = "") entao
Escreva ("[A", i:2, "]")
senao
Escreva ("[RESERVADO]")
FimSe
FimPara
EscrevaL()
EscrevaL("--------------------------------------------------------------------------------------------------------------")
FimProcedimento

inicio

Repita
LimpaTela
Exibir_Sala()

//momento da reserva do lugar
Escreva("Reservar a cadeira: ")
Leia(reserva)

//verificar se a cadeira está reservada
Se (poltrona[reserva] = "") entao
Escreva ("Cadeira ", reserva, "reservada!!!")
senao
Escreva ("Cadeira ", reserva, "ocupada!!!")
FimSe

Escreva("Quer reservar outro? [S/N] ")
Leia(resp)
Ate (resp = "N")
Fimalgoritmo
Responder

Posts

13/09/2020

Jose

Acho que a condição do então está com problema, acho que dá para usar o Escolha como forma de mostrar as opções. Encontrei um vídeo que explica isso em
https://pt.savefrom.net/download-from-twitterr.
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar