BCD / FMTBcdField

10/10/2003

23

Olá pessoal,

Estou com o seguinte problema, Minha Aplicação em delphi 6 estava funcionando legal, ai levei até uma maquina para meu patrão testar e como não estava a fim de instalar as Dll do DBExpress (e como ele tb usa o Delphi) acabei instalando o Delphi 7 lá, até ai tudo bem a aplicação abriu ai quando fui usar meu cadastro de produtos apareceu a seguinte mensagem ´CDSCAD_PRO: Type Mismatch for Field ´NQTD_PROFC´, Expecting: BCD Actual: FMTBcdField´, ai ta deixei assim, voltei para minha máquina e funcionou legal, recompilei levei para a outra com o Delphi 7, e mesmo erro, ai desisti...
Mas ontem instalei o Delphi 7 em minha maquina junto com o delphi 6, ja que estou começando uma nova aplicação (e quero usar o Rave), ai veio um cliente para mim demonstrar, e para minha suspresa na hora de entrar no cadastro de produtos o mesmo erro, ai me toquei que o delphi 7 deve fazer alguma alteração que da este problema.

Os Campos que estão dando problema são Numericos
Ja tive uma vez problema parecido, mais alterei alguma coisa no BDE e Interbase ai funcionou, mais agora estou Usando o DBExpress e Firebird
o que eu devo modificar?

Pessoal muito Obrigado e até mais.


Responder

Posts

10/10/2003

Afarias

NO BDE vc tem a opção ENABLE BCD que determina como o Delphi irá interpretar campos numéricos. Se vc compila se sistema usando determinada configuração (ou melhor, na criação dos campos persistentes -- TFIelds) -- vc dever ter esta mesma configuração onde distribuir o sistema.

Não sei onde fica esta configuração (ou é questão de versão dos drivers) no DBExpress (pois não uso) -- mas como vc usa, é bom conhecer.

Caso queira mudar no seu projeto, apenas abra o seu projeto, recrie os campos persistentes e recompile.


T+


Responder

10/10/2003

Jamersonw

Pois é,

acho que é questão da versão do meu DBExpress, acho que quando instalei o Delphi 7 ele deve ter trazido alguma dll nova ai deu este problema...

Vou tentar recriar os campos que estão encomodando...

mais valeu pela dica até mais...


Responder

10/10/2003

Jamersonw

Consegui resolver...

O Problema foi a DLL que o Delphi 7 atualizou chamada DBExpint, peguei a do cd do Delphi 6 e joguei lah na pasta System32 do XP e tudo voltou ao normal.


muito obrigado e até a minha próxima dúvida.


Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar