Conexao BSS Principal.Connected:= true, lenta

13/06/2008

1

Boa dia a todos.
Gostaria de saber dos amigos se é isto mesmo.
Desenvolvi um ´piloto ntier´ para testes e para ver as diferenças na
prática entre o modelo que uso(aplicacao + banco(uso fb2)) hoje com
este cliente+servidor+banco.
O 1o.problema que me deparei é a conexao BSS(SocketConnection)
terminal+servidor, em torno de 15 segundos, 1a, 2a(segundo terminal
apos primeiro)...tanta faz, achei que o problema era na minha
arquitetura, pois bem, instalei o exemplo do Bruno, e mesma coisa.
Gostaria de saber dos amigos se é assim mesmo.

A lentidao é no SocketCon.Connected:= true, apos conectado, a
aplicacao chega a ser superior em velocidade, com as maquinas mais
antigas, celerons e p.II e afins.
Teste base:
2 Maquinas duo-core, Windows Xp em ambas, e para comparacao, a
aplicacao atual que uso(comum), é imediata praticamente.

Desde já, um abraço a todos.


Responder

Posts

13/06/2008

Paulo

Trabalho com BSS também e este tipo de problema é muito peculiar,muito local. 15 segundos é muito tempo. Aí sou obrigado a te dar aquelas respostas que eu também não gosto de receber em forum, pois não nos dizem nada, tipo: Terá que verificar a sua máquina e os programas instalados e ver se nenhum deles ´cruzam´ com o BSS. Depende também de como está sendo aberto o BSS, se antes o seu programa não faz nenhum tipo de validação que dependa de resposta. O leque é variado. Mas o caminho é este, na minha opinião, N-Tier.


Responder

13/06/2008

Luiz Henrique

Boa Tarde, Paulo, tudo blz....
Analisei estas situacoes, desativei o antivirus no servidor, adicionei a porta que o BSS esta ´escutando´ no firewall, desabilitei o firewall...e por fim tambem achei que poderia ser alguma ´barberagem´ minha, pois como estou iniciando...dai que instalei o exemplo da CodeGear/FDD2007(Atualizado/Bruno)...e mesma coisa...mas de qualquer forma, voce ja me respondeu que 15 segundos é muito tempo. Mas tanto na minha aplicacao como no exemplo , mesma coisa, entao acho que ja nao é na minha aplicacao...verifiquei se tem algum dataset aberto, alcuma conexao, mas nada. Na minha maquina com servidor no Microsoft Virtual PC, funciona bem, agora , na rede com 2 micros, mesmo carregando a Aplicacao ´Server´, a demora no SocketConnection.Connected:= true e a mesma. No BSS, a porta é 3060 que estou usando.

Mas valeu, obrigado.


Responder

15/06/2008

Luiz Henrique

Bom dia.

O problema é a maquina. Que falta de sorte a minha, primeiro teste e ja pegar um rabo de foquete. Troquei o servidor para outra maquina na estacao e pronto !. Tudo funcionando.
Desculpe ai galera, mas as vezes a gente tem uma trave no olho
Obrigadao Paulo.

T+


Responder