Delphi 10 Seattle, teclas de atalhos trocadas

04/05/2016

5

Pessoal, estou precisando de ajuda.

Usava o Delphi 2010 numa boa, tudo correto. Agora passei pro Delphi 10 Seattle.
Instalei com sucesso em duas máquinas.
Só depois que comecei a usar percebi que, APENAS em minha máquina, O Delphi mostra as teclas de atalhos diferentes,
ou seja: antes Copiar era <CTRL><C>, agora está <CTRL><INS>; Recortar está <shift><DEL> e colar está <shift><INS>, entre outras...;

Fui verificar no outro pc e está tudo normal.
Existe algum jeito de reparar isso ???

Agradeço antecipadamente.
Responder

Posts

05/05/2016

Luiz Menin

Qual a versão do windows das duas máquinas?
Responder
Windows 10
Responder

05/05/2016

Luiz Menin

Qual o componente do Delphi você está utilizando para definir os atalhos?
Responder
Na verdade a IDE toda do Delphi... O atalho Ctrl + C, sempre foi pra copiar...
Quando vc coloca um objeto qualquer no form, uma query, e vc quer duplicar basta copiar e colar: ctrl + c, ctrl + v...

Porém tomei a decisão de reinstalar em meu notebook o Delphi 10 Seattle...
Se continuar o mesmo problema então suponho ser bronca no meu notebook, pois em outras máquinas não acontece.

De qualquer forma, Luiz, obrigado pelo apoio/força.
Se acontecer novamente postarei aqui.
Abraços.
Responder

05/05/2016

Cadu Zenor

Não se sabe alguma outra solução?
Responder
Amigo Cadu, não sei outra solução ...
Mas como eu disse vou reinstalar o Delphi, aliás já está acontecendo...
Sei que é uma dor de cabeça danada, mas ... fazer o quê?

Depois postarei aqui o resultado da reinstalação...
Abraços amigos...
Obrigado a todos.
Responder

06/05/2016

Cadu Zenor

Você está certo, melhor reinstalar do que perder bastante tempo!
Responder

09/07/2019

Ricardo Santos

Já tem algum tempo, mas segue resposta para quem passar pelo problema:
Você deve ter modificado o "Key Mappings" por engano.
Para corrigir, basta ir em Tools > Options > Editor Options > Key Mappings, selecione a opção "Default".
Responder
×
+1 DevUP
Acesso diário, +1 DevUP
Parabéns, você está investindo na sua carreira