Emitir Nfs-e pelo WebService Pública

18/01/2022

4

Uso C++ Builder no Rad Studio 10. Berlin e estou usando a biblioteca Soap.SOAPHTTPTrans.hpp para fazer o envio do RPS/XML para fazer a emissão das Nfs-e pelo WebService Pública e esta me ocorrendo erro na hora do envio.

Estou enviado para a URL: ""http://nfse-teste.publica.inf.br/homologa_nfse_integracao/Services?wsdl" e SoapAction: "RecepcionarLoteRps"

Acredito que o meu problema seja o Envelope, que esteja faltando alguma Tag. O erro que me retorna é o seguinte:

<?xml version='1.0' encoding='UTF-8'?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
<S:Body>
<ns2:RecepcionarLoteRpsResponse xmlns:ns2="http://service.nfse.integracao.ws.publica/">
<return>
<EnviarLoteRpsResposta xmlns="http://www.publica.inf.br" xmlns:pub="http://www.publica.inf.br/integracao_nfse" xmlns:ds="http://www.w3.org/2000/09/xmldsig#">
<ListaMensagemRetorno>
<MensagemRetorno>
<Codigo>E160</Codigo>
<Mensagem>Arquivo enviado fora da estrutura do arquivo XML de entrada. XML enviado está vazio.</Mensagem>
<Correcao>Envie um arquivo dentro do schema do arquivo XML de entrada.</Correcao>
</MensagemRetorno>
</ListaMensagemRetorno>
</EnviarLoteRpsResposta>
</return>
</ns2:RecepcionarLoteRpsResponse>
</S:Body>
</S:Envelope>

Arquivo em anexo.

Se alguém poder me ajudar fico grato. Já entrei em contato com suporte deles, já li os manuais deles, já pesquisei na Internet, mas não encontrei a solução para o meu problema.
Danrlei

Danrlei

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar