04/06/2012

Erro de conexão com o banco

Bom dia a todos

Sou iniciante em .net, estou utilizando, Visual Studio 2010, SqlServer 2008 e criei uma aplicação utilizando Asp.Net Web Application.

Estou tentando fazer uma conexão com um banco próprio para validar usuário, mas esta dando erro.
Alguém pode ajudar?

No Web.config já vem com as seguinte configurações:
<?xml version=1.0?>

<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->

<configuration>
  <connectionStrings>
    <add name=ApplicationServices
         connectionString=data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true
         providerName=System.Data.SqlClient />
  </connectionStrings>

  <system.web>
    <compilation debug=true targetFramework=4.0 />

    <authentication mode=Forms>
      <forms loginUrl=~/Account/Login.aspx timeout=2880 />
    </authentication>

    <membership>
      <providers>
        <clear/>
        <add name=AspNetSqlMembershipProvider type=System.Web.Security.SqlMembershipProvider connectionStringName=ApplicationServices
             enablePasswordRetrieval=false enablePasswordReset=true requiresQuestionAndAnswer=false requiresUniqueEmail=false
             maxInvalidPasswordAttempts=5 minRequiredPasswordLength=6 minRequiredNonalphanumericCharacters=0 passwordAttemptWindow=10
             applicationName=/ />
      </providers>
    </membership>

    <profile>
      <providers>
        <clear/>
        <add name=AspNetSqlProfileProvider type=System.Web.Profile.SqlProfileProvider connectionStringName=ApplicationServices applicationName=//>
      </providers>
    </profile>

    <roleManager enabled=false>
      <providers>
        <clear/>
        <add name=AspNetSqlRoleProvider type=System.Web.Security.SqlRoleProvider connectionStringName=ApplicationServices applicationName=/ />
        <add name=AspNetWindowsTokenRoleProvider type=System.Web.Security.WindowsTokenRoleProvider applicationName=/ />
      </providers>
    </roleManager>

  </system.web>

  <system.webServer>
     <modules runAllManagedModulesForAllRequests=true/>
  </system.webServer>
</configuration>


Estou tentando alterar a string de conexão para:
  <connectionStrings>
    <add name=ApplicationServices
         connectionString=Data Source=10.0.0.90;Initial Catalog=Teste;Persist Security Info=True;User ID=sa;Password=123
         providerName=System.Data.SqlClient />
  </connectionStrings>


Porque será que esta dando erro.

Desde já agradeço a colaboração de todos.

Ureis

Respostas

04/06/2012

Felipe Ggs

Tente usar o código abaixo na tag connectionStrings e no lugar do nome do servidor coloque o nome da máquina que esta sendo seu servidor de banco de dados, se for um banco local, coloque o nome da sua máquina.


<connectionStrings>
    <add name=nome_da_string_conexao
         connectionString=Data Source=nome_servidor;Initial Catalog=nome_banco;Integrated Security=SSPI
         providerName=System.Data.SqlClient />
  </connectionStrings>
Responder Citar

04/06/2012

Ureis

Tente usar o código abaixo na tag connectionStrings e no lugar do nome do servidor coloque o nome da máquina que esta sendo seu servidor de banco de dados, se for um banco local, coloque o nome da sua máquina.
<connectionStrings>
    <add name=nome_da_string_conexao
         connectionString=Data Source=nome_servidor;Initial Catalog=nome_banco;Integrated Security=SSPI
         providerName=System.Data.SqlClient />
  </connectionStrings>


Não deu certo...
Responder Citar

10/06/2012

Joel Rodrigues

Qual está sendo, exatamente, o erro?
Responder Citar

13/06/2012

Ureis

Consegui resolver tirando Integrated Security=SSPI

Obrigado, a todos.
Responder Citar