Erro Fatal 500 - includes.php

04/07/2019

8

PHP

Ola pessoal, estou com problemas meu servidor virtual, ai pensei se vocês poderiam me dar uma ajuda...

Meu servidor deu problema e recuperei o backup do Hyper-V do servidor do GLPI. Quando iniciei o sistema, deu HTTP ERRO 500, após depurar o erro, deu a mensagem:

Fatal error: Uncaught Error: Call to undefined method Config::getCache() in /var/www/html/glpi/inc/config.php:45 Stack trace: #0 /var/www/html/glpi/inc/includes.php(48): include_once() #1 /var/www/html/glpi/index.php(71): include(''''/var/www/html/g...'''') #2 thrown in /var/www/html/glpi/inc/config.php on line 45

Verifiquei o arquivo includes.php linha 48:
include_once (GLPI_ROOT . "/inc/config.php");

Verifiquei o config.php linha 45:
$GLPI_CACHE = Config::getCache(''''cache_db'''');

Não sei como resolver esse problema, alguém poderia me ajudar?

Tenho muita informação cadastrada nesse sistema.
Responder

Posts

08/07/2019

Claudio Lopes

Ola pessoal, estou com problemas meu servidor virtual, ai pensei se vocês poderiam me dar uma ajuda...

Meu servidor deu problema e recuperei o backup do Hyper-V do servidor do GLPI. Quando iniciei o sistema, deu HTTP ERRO 500, após depurar o erro, deu a mensagem:

Fatal error: Uncaught Error: Call to undefined method Config::getCache() in /var/www/html/glpi/inc/config.php:45 Stack trace: #0 /var/www/html/glpi/inc/includes.php(48): include_once() #1 /var/www/html/glpi/index.php(71): include(''''/var/www/html/g...'''') #2 thrown in /var/www/html/glpi/inc/config.php on line 45

Verifiquei o arquivo includes.php linha 48:
include_once (GLPI_ROOT . "/inc/config.php");

Verifiquei o config.php linha 45:
$GLPI_CACHE = Config::getCache(''''cache_db'''');

Não sei como resolver esse problema, alguém poderia me ajudar?

Tenho muita informação cadastrada nesse sistema.


Já tive algum erros com servidor apache2.
segue algumas dicas:
1 - Verifique se o arquivo existe
2 - troque os includes pelo caminho absoluto (sem usar namespaces)
3- verifique se é alguma permissão nas pastas.

me fale o resultado.
Responder
Pessoal, consegui resolver o problema.
Baixei a versão mais nova do GLPI e fiz a atualização do sistema, depois importei o banco sql e pronto. Voltou tudo!
Responder