Erro http 500

09/04/2009

1

Bom dia, estou integrando o Hibernate ao Struts2 utilizando o tomcat e estou tendo este erro e pelo que eu descobri esse erro se da devido a especificao JSP e Servlets nao ser compativel com a versao, entao minha pergunta é, como faco para atualizar a especificacao e se eu devo utilizar o jike ou ant para fazer esta integracao.

HTTP Status 500 -

--------------------------------------------------------------------------------

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: Unable to compile class for JSP:


An error occurred at line: 18 in the generated java file
The return type is incompatible with JspSourceDependent.getDependants()

Stacktrace:
org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:93)
org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:451)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:319)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:298)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:286)
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:564)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:302)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:329)

javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
org.apache.struts2.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:414)
org.apache.struts2.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:414)
org.apache.struts2.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:99)


note The full stack trace of the root cause is available in the Apache Tomcat/5.5.28 logs.


--------------------------------------------------------------------------------
Responder

Posts

09/04/2009

Dyego.carmo

Não é possivel atualizar a especificacao JSP (e Servlet) sem atualizar o seu TOMCAT...

Atualize-o para a versao 6.x
Responder

09/04/2009

Anonymous

Entao cara primeiramente obrigado pela ajuda mas eu estava com o tomcat 6.0 e efetuando algumas pesquisas constatei que este erro se da devido ao deployment descriptor(web.xml) ou algum arquivo do tipo jsp nao esta de acordo com a especificacao compativel com a minha versao do tomcat e o web container tomcat 5.5 trabalha com a especificacao 2.4 para servlets e 2.0 para jsps e o que eu quero te perguntar e se voce conhece ou sabe onde posso achar um dtd valido para esta minha versao do tomcat.
Responder

09/04/2009

Dyego.carmo

Não entendi...
Voce esta usando o 6.0 ou o 5.5 ?
Responder

09/06/2009

Anonymous

Estou usando o tomcat 6.0 agora reinstalei a versao 6.0 do container web
Responder

09/09/2009

Dyego.carmo

E Funcionou ?
Responder