Erro MySQL.

21/11/2005

SQL Error: Client does not support authentication protocol requested by server; consider upgrading MYSQL Client.

Este erro da no connected dos componentes zeosdbo v6.1.5.

Urgente.

[color=red:7f7372a12f]Título editado por Massuda Removido: ´Uergente::::::´ Evite usar termos apelativos no título[/color:7f7372a12f].



Rui Lisboa

Respostas

21/11/2005

Wiltonfenix

Amigo, vou dar uma sugestão:

Já usei o Zeos e outros componentes de acesso direto ao MySQL, e em nenhum deles cheguei a estabilidade e o mínimo de problemas que o ADO dá. Considere o uso do ADO.


Responder Citar

21/11/2005

Sr.reis

Rui Lisboa, também trabalho c/ delphi + mysql e zeos, e aqui tá tdo rodando direitinho ... apesar de ser iniciante me identifiquei muito com ele.

esse é seu primeiro projeto com mysql + zeos ?

se for observe direitinho, veja no object inspector as configurações do o Zconection, aqui eu configuro assim:

Database = nomedobanco
Hostname = localhost
Port = 3306
Protocol = a versão do seu servidor
user = root

assumindo que vc não tenha alterado as configurações padrão ...

o grande problema é q falta material para estudarmos ... mas qualquer coisa post ae de novo ... para ver se conseguimos te ajudar ....

abraços :arrow: sr.reis


Responder Citar

21/11/2005

Mysys

bem provavel que a propriedade protocol de seu ZDatabase estaja com uma versao diferente de seu mysql instalado


Responder Citar

22/11/2005

Rui Lisboa

Rui Lisboa, também trabalho c/ delphi + mysql e zeos, e aqui tá tdo rodando direitinho ... apesar de ser iniciante me identifiquei muito com ele. esse é seu primeiro projeto com mysql + zeos ? se for observe direitinho, veja no object inspector as configurações do o Zconection, aqui eu configuro assim: Database = nomedobanco Hostname = localhost Port = 3306 Protocol = a versão do seu servidor user = root assumindo que vc não tenha alterado as configurações padrão ... o grande problema é q falta material para estudarmos ... mas qualquer coisa post ae de novo ... para ver se conseguimos te ajudar .... abraços :arrow: sr.reis


Obrigado amigo mas ele continua a dar erro, as versões que estão lá nenhuma é igual a k eu tenho.


Responder Citar

22/11/2005

Ramms

[quote]Rui Lisboa, também trabalho c/ delphi + mysql e zeos, e aqui tá tdo rodando direitinho ... apesar de ser iniciante me identifiquei muito com ele. esse é seu primeiro projeto com mysql + zeos ? se for observe direitinho, veja no object inspector as configurações do o Zconection, aqui eu configuro assim: Database = nomedobanco Hostname = localhost Port = 3306 Protocol = a versão do seu servidor user = root assumindo que vc não tenha alterado as configurações padrão ... o grande problema é q falta material para estudarmos ... mas qualquer coisa post ae de novo ... para ver se conseguimos te ajudar .... abraços :arrow: sr.reis


Obrigado amigo mas ele continua a dar erro, as versões que estão lá nenhuma é igual a k eu tenho.[/quote:6725980bda]

Jah tentou reinstalar seu servidor mysql?


Responder Citar

22/11/2005

Rui Lisboa

[quote:a034377b0e=´Rui Lisboa´][quote:a034377b0e=´sr.reis´]Rui Lisboa, também trabalho c/ delphi + mysql e zeos, e aqui tá tdo rodando direitinho ... apesar de ser iniciante me identifiquei muito com ele. esse é seu primeiro projeto com mysql + zeos ? se for observe direitinho, veja no object inspector as configurações do o Zconection, aqui eu configuro assim: \ Database = nomedobanco Hostname = localhost Port = 3306 Protocol = a versão do seu servidor user = root assumindo que vc não tenha alterado as configurações padrão ... o grande problema é q falta material para estudarmos ... mas qualquer coisa post ae de novo ... para ver se conseguimos te ajudar .... abraços :arrow: sr.reis


Obrigado amigo mas ele continua a dar erro, as versões que estão lá nenhuma é igual a k eu tenho.[/quote:a034377b0e]

Jah tentou reinstalar seu servidor mysql?[/quote:a034377b0e]


A versão k eu tenho no server é a 4.1.5. Qual a solução???

Estou cm muita urgencia.


Responder Citar

23/11/2005

Sr.reis

Rui, se a tua versão do server é 4.1.5, o zeos tem o protocolo 4.1, que serve perfeitamente ....

PS: vc copiou a libmySQL.dll para a pasta system32 ??

vc testou o servidor c/ algum gerenciador de banco de dados tipo o Mysql-Front ???

pode ser que seu servidor esteja instalado, mas não esteja startado, por isso dá erro ....

acessa esses tutoriais, q vai te ajudar: [url]http://www.imasters.com.br/artigo.php?cn=3405&cc=254[/url]

[url]http://www.imasters.com.br/artigo.php?cn=3377&cc=254[/url]
tenta ae, qualquer coisa posta de novo ....

abraço, sr.reis :arrow:


Responder Citar