Erro na atribuição de valor na variável no visualg

09/10/2020

4

Estou enfrentando dificuldades pra entender o erro no meu código. O erro na na atribuição da variavel "TN" que significa TotalNulos, todos os outros valores etão me voltando o valor correto mas o "TN" está me retornando 24 e não consigo achar o erro

Algoritmo "Lab02 - Sistema de Votação "
// Disciplina : [Linguagem e Lógica de Programação]
//***********************************/
//* Aluno: Mateus Satiro */
//* TURMA: CC2A06 – LPA */
//* Profa. Eliane */
//***********************************/
Var
// Seção de Declarações das variáveis
eleitores, TotalPC1, TotalPC2, TotalPC3, TotalPC4, TotalV1, TotalV2, TotalV3, TotalV4, TotalVB, TN, TotalPDB, TotalPSB: inteiro
voto1, voto2: caractere
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
escreval("IDENTIFICAÇÃO DA URNA ELETRÔNICA")
escreval("Identificação da Seção e Zona Eleitoral......: A")
escreval("Total dos Eleitores que podem votar..........: 159")
//leia(contador)
escreval("Código de Identificação da Urna Eletrônica...: 1")
escrevaL(" Candidatos a Prefeitos ")
escreval("Partido Candidato Sigla")
escreval(" PDB Candidato1 C1")
escreval(" PDB Candidato2 C2")
escreval(" PSB Candidato3 C3")
escreval(" PSB Candidato4 C4")
escreval(" --- Branco Enter")
escreval(" --- Nulo Enter")
escreval(" Candidatos a Vereador ")
escreval(" Partido Candidato Sigla")
escreval(" PDB Candidato1 V1 ")
escreval(" PDB Candidato2 V2 ")
escreval(" PSB Candidato3 V3 ")
escreval(" PSB Candidato4 V4 ")
//eleitores <- 0
//TotalPC1 <- 0
//TotalPC2 <- 0
//TotalPC3 <- 0
//TotalPC4 <- 0
//TotalV1 <- 0
//TotalV2 <- 0
//TotalV3 <- 0
//TotalV4 <- 0
//TotalVB <- 0
TN <- 0
//TotalPDB <- 0
//TotalPSB <- 0
enquanto (eleitores < 3) faça
eleitores <- (eleitores + 1)
escreval("Digite o codigo do seu candidato a prefeito: ")
leia(voto1)
escreval("Digite o codigo do seu candidato a vereador: ")
leia(voto2)
se (voto1 = "C1") ou (voto1 = "c1") entao
TotalPC1 <- (TotalPC1 + 1)
TotalPDB <- (TotalPDB + 1)
senao
se (voto1 <> "C1") ou (voto1 <> "c1") entao
TN <- (TN + 1)
fimse
fimse
se (voto1 = "C2") ou (voto1 = "c2") entao
TotalPC2 <- (TotalPC2 + 1)
TotalPDB <- (TotalPDB + 1)
senao
se (voto1 <> "C2") ou (voto1 <> "c2") entao
TN <- (TN + 1)
fimse
fimse
se (voto1 = "C3") ou (voto1 = "c3") entao
TotalPC3 <- (TotalPC3 + 1)
TotalPSB <- (TotalPSB + 1)
senao
se (voto1 <> "C3") ou (voto1 <> "c3") entao
TN <- (TN + 1)
fimse
fimse
se (voto1 = "C4") ou (voto1 = "c4") entao
TotalPC4 <- (TotalPC4 + 1)
TotalPSB <- (TotalPSB + 1)
senao
se (voto1 <> "C4") ou (voto1 <> "c4") entao
TN <- (TN + 1)
fimse
fimse

se (voto1 = "") ou (voto1 = "") entao
TotalVB <- (TotalVB + 1)
fimse

se (voto2 = "V1") ou (voto2 = "v1") entao
TotalV1 <- (TotalV1 + 1)
TotalPDB <- (TotalPDB + 1)
senao
se (voto2 <> "V1") ou (voto2 <> "v1") entao
TN <- (TN + 1)
fimse
fimse
se (voto2 = "V2") ou (voto2 = "v2") entao
TotalV2 <- (TotalV2 + 1)
TotalPDB <- (TotalPDB + 1)
senao
se (voto2 <> "V2") ou (voto2 <> "v2") entao
TN <- (TN + 1)
fimse
fimse
se (voto2 = "V3") ou (voto2 = "v3") entao
TotalV3 <- (TotalV3 + 1)
TotalPSB <- (TotalPSB + 1)
senao
se (voto2 <> "V3") ou (voto2 <> "v3") entao
TN <- (TN + 1)
fimse
fimse
se (voto2 = "V4") ou (voto2 = "v4") entao
TotalV4 <- (TotalV4 + 1)
TotalPSB <- (TotalPSB + 1)
senao
se (voto2 <> "V4") ou (voto2 <> "v4") entao
TN <- (TN + 1)
fimse
fimse

se (voto2 = "") ou (voto2 = "") entao
TotalVB <- (TotalVB + 1)
fimse

fimenquanto
escreval("Divulgação de Resultados")
escreval("")
escreval("Total de votos PDB: ", TotalPDB)
escreval("Total de votos PSB: ", TotalPSB)
escreval("")
escreval("Prefeitos")
escreval("Total de votos Candidato1: ", TotalPC1)
escreval("Total de votos Candidato2: ", TotalPC2)
escreval("Total de votos Candidato3: ", TotalPC3)
escreval("Total de votos Candidato4: ", TotalPC4)
escreval("")
escreval("Vereadores")
escreval("Total de votos Candidato1: ", TotalV1)
escreval("Total de votos Candidato2: ", TotalV2)
escreval("Total de votos Candidato3: ", TotalV3)
escreval("Total de votos Candidato4: ", TotalV4)
escreval("Total de votos Brancos: ", TotalVB)
escreval("Total de votos Nulos: ", TN)
Fimalgoritmo
Mateus

Mateus

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar